close

Enter

Log in using OpenID

4. deney

embedDownload
DOĞU AKDENİZ ÜNİVERSİTESİ BAHAR 2012-2013
BİLGİSAYAR MÜHENDİSLİĞİ BÖLÜMÜ
BLGM-324 BİLGİSAYAR MİMARİSİ
DENEY #4
ALTERA MAX-PLUS-II VHDL Araçları Kullanarak Devre Sentezi Girişi
1.Giriş
8-bitlik tam toplayıcı tasarımını 8 kere yapmak çok zordur bunu çözmek için ALTERA MAX-PLUS-II
yi kullanacağız. İlk önce 1 bitlik tam toplayıcı tasarımı yapacağız ve bu sembolden 8 tane kopya almamız
gerekiyor.
2. Deneysel Uygulama
1 Bitlik Tam Toplayıcı (1-Bit Full-Adder)
1. Masaüstünde yeni bir dosya (Deney-4) oluşturun.
2. ALTERA MAX-PLUS-II programını açınız.
3. File-> New-> Graphic Editor Page.
4. Bu dosyayı, Deney-4 dosyası içinde “onebitadder” olarak kaydediniz.
5. Sayfa üzerine çift tıklayın ve kütüphane sembolleri içinden: “prim draw the circuit”
CO = A B + A CI + B CI ; and
S = A B Ci + A' B' Ci + A B' Ci' + A' B Ci' .
Tam toplayıcının üç girişi (a, b, ci) ve iki çıkışı (sum, co) vardır. a, ile b artan ve eklenen bitlerini,
ci (carry-input) elde girişini, sum toplam çıkışını, co (carry-output) ise elde çıkışını gösterir.
6. Projeyi kaydediniz.
7. File-> Project-> set project to current file.
8. Assign-> device-> Flex10k ve Auto.
9. Max+plusII-> compiler-> start
10. File ->New-> Waveform Editor file
11. Dosyayı aynı isimle Deney-4 ‘ün içinde kaydediniz.
12. Nodes->Enter nodes from SNF->list->ok.
13. - Option-> gradesize->100ns.
14. Aşağıdaki işlemleri sırayla yapınız:
15. Grid-size değişmeden, A ve B girişlerini A: “multiplied by = 4” ve B: “multiplied by = 2”
16. Bu dosyayı .scf ile kaydedin ve simülasyonu bu komutla: [ MAX-plus II |
simulator | start ] başlatın. Eğer sonuç 0 error olursa .scf dosyasını waveform sonuçlarını
görmek için açınız.
17. View-> Fit in window.
18. Rapor sayfasına gidiniz ve ilk bölümü yapınız.
8 Bitlik Tam Toplayıcı (8-Bits Full-Adder)
1. File-> create default symbol.
2. File->New->Graphic editor file.
3. Bu dosyayı, Deney-4 dosyası içinde “8bitadder” olarak kaydediniz.
4. Sayfa üzerine çift tıklayın ve kütüphane sembolleri içinden: “prim draw the circuit”
5. Onebitadder sembolü sembol penceresinden seçiniz ve 8 tane kopya alarak sayfaya
yapıştırınız.
Kalın çizgiler sinyal yolu demektir ve birçok sinyal taşırlar. [ Options | Linestyle, thickline ] komutunu kullanarak sinyal yolu oluşturabilirsiniz. İsimlendirme bölümü
bağlantılar için çok önemlidir. Satırlar A0, A1,A2,…,A7 şeklinde isimlendirilir. Bu
isimleri girmek için
sembolüne yada Fn2 ‘yi kullanacağız.
6. Projeyi kaydediniz.
7. File-> Project-> set project to current file.
8. Assign-> device-> Flex10k ve Auto.
9. Max+plusII-> compiler-> start.
10. File-> New-> Waveform Editor File.
11. Dosyayı aynı isimle Deney-4 ‘ün içinde kaydediniz.
12. Nodes-> Enter nodes from SNF-> list-> ok.
13. Option-> gradesize-> 10ns.
14. File-> Endtime-> 600ns.
15.
dalga-bölmesi aracı yada Fn3 ile COI 50 ns den 150 ns ye kadar bölünür. A[7..0]
için 0xFF değerlerini 150 ns den 250 ns ye atayınız ve 400 ns den 500 ns ye kadar aynı
değerleri atayınız. B[7..0] için 0x01 değerlerini 0 ns den 100 ns ye atayınız ve 200 ns den
300 ns ye kadar aynı değerleri atayınız. Dalga formunuz (waveform) aşağıdaki gibi
olmalıdır:
16. Projeyi kaydediniz.
17. Max+plusII-> simulator-> start.
18. Rapor sayfasına gidiniz ve ikinci bölümü yapınız.
İsim:__________________ Öğrenci No:__________________
DOĞU AKDENİZ ÜNİVERSİTESİ BİLGİSAYAR MÜHENDİSLİĞİ BÖLÜMÜ
BLGM-324 BİLGİSAYAR MİMARİSİ
DENEY #4
Bölüm-1: Giriş ve çıkış gecikmelerini toplam ve elde çıkışı için aşağıda verilen zaman
aralıkları için yazınız:
Bölüm-2:
Hangi aralık en yüksek dengede tutma (stabilization) zamanına sahiptir?
Neden?:
Author
Document
Category
Uncategorized
Views
0
File Size
596 KB
Tags
1/--pages
Report inappropriate content