close

Enter

Log in using OpenID

ae_chap2_askiseis5

embedDownload
Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Φυλλάδιο 5
Ασκήσεις πάνω στο 2ο και 8ο Κεφάλαιο (Δομή επανάληψης)
1. Ερωτήσεις της μορφής Σωστό – Λάθος
a.
b.
c.
Εντός μίας δομής επιλογής δεν μπορεί να περιέχεται μία δομή επανάληψης.
Εντός μίας δομής επανάληψης δεν μπορεί να περιέχεται δομή επιλογής.
Βρόχος ονομάζεται το μπλοκ των εντολών που περιέχονται σε μία δομή επιλογής ή σε μία δομή
επανάληψης.
d. Όταν μία δομή επανάληψης είναι εμφωλευμένη σε μία άλλη, τότε για κάθε επανάληψη του
εξωτερικού βρόχου πρέπει να ολοκληρώνονται όλες οι επαναλήψεις του εσωτερικού.
e. Η περατότητα ενός αλγορίθμου αναφέρεται στο γεγονός ότι καταλήγει στη λύση του
προβλήματος μετά από πεπερασμένο αριθμό βημάτων (εντολών).
f. Στη δομή ΓΙΑ, αν το βήμα είναι γνωστό, τότε μπορεί να παραληφθεί.
g. Στην επαναληπτική δομή ΓΙΑ … ΑΠΟ … ΜΕΧΡΙ … ΜΕ_ΒΗΜΑ οι τιμές ΑΠΟ, ΜΕΧΡΙ και ΜΕ_ΒΗΜΑ δεν
είναι απαραίτητο να είναι ακέραιες.
h. Όταν μία δομή ΓΙΑ είναι εμφωλευμένη σε μία άλλη δομή ΓΙΑ, τότε μπορούμε –αν το επιθυμούμε- για
ευκολία να χρησιμοποιήσουμε την ίδια μεταβλητή ως μετρητή και στις δύο δομές.
i. Κάθε πρόβλημα που απαιτεί τη χρήση δομής επανάληψης μπορεί να επιλυθεί με τη χρήση της
δομής ΓΙΑ.
j. Κάθε βρόχος ΓΙΑ μπορεί να μετατραπεί σε ΟΣΟ.
k. Κάθε βρόχος ΟΣΟ μπορεί να μετατραπεί σε ΓΙΑ.
l. Στην επαναληπτική δομή ΟΣΟ… ΕΠΑΝΑΛΑΒΕ, δεν γνωρίζουμε εκ των προτέρων το πλήθος των
επαναλήψεων.
m. Η εντολή επανάληψης ΟΣΟ… ΕΠΑΝΑΛΑΒΕ, εκτελείται τουλάχιστον μία φορά.
n. Δεν μπορούμε να έχουμε μία δομή επανάληψης μέσα σε μία άλλη δομή επανάληψης.
o. Όταν το πλήθος των επαναλήψεων είναι γνωστό, δεν μπορεί να χρησιμοποιηθεί η δομή
επανάληψης ΟΣΟ.
2. Τι θα εκτυπωθεί μετά την εκτέλεση του παρακάτω αλγορίθμου:
ΑΛΓΟΡΙΘΜΟΣ άσκηση1
s0
y1
ΟΣΟ y ≤ 5 ΕΠΑΝΑΛΑΒΕ
ss+y
yy+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΚΤΥΠΩΣΕ s
ΤΕΛΟΣ άσκηση1
3. Αν η τιμή εισόδου είναι η τιμή 60, πόσες φορές θα τυπωθεί η λέξη “ΔΙΑΚΟΠΕΣ”;
ΔΙΑΒΑΣΕ y
ΟΣΟ y <> 90
ΕΠΑΝΑΛΑΒΕ
ΕΜΦΑΝΙΣΕ “ΔΙΑΚΟΠΕΣ”
y  y + 10
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
α. 1
ΓΕΛ Μολάων
β. 3
γ. 4
δ. άπειρες
Σελίδα 1 από 4
Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Φυλλάδιο 5
4. Αν η τιμή εισόδου είναι η τιμή 61, πόσες φορές θα τυπωθεί η λέξη “ΔΙΑΚΟΠΕΣ”;
ΔΙΑΒΑΣΕ y
ΟΣΟ y <> 90
ΕΠΑΝΑΛΑΒΕ
ΕΜΦΑΝΙΣΕ “ΔΙΑΚΟΠΕΣ”
y  y + 10
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
α. 1
β. 3
γ. 4
δ. άπειρες
5. Να σχηματιστεί ο πίνακας τιμών του παρακάτω αλγορίθμου, αν η τιμή που διαβάζεται
είναι α = 120. Τι θα εκτυπωθεί;
ΑΛΓΟΡΙΘΜΟΣ άσκηση2
ΔΙΑΒΑΣΕ α
β1
ΟΣΟ α div 10 > 0 ΕΠΑΝΑΛΑΒΕ
α  α div 10
ΑΝ α mod 2 = 1 TOTE
ββ+3
ΑΛΛΙΩΣ
ββ+α
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΚΤΥΠΩΣΕ β
ΤΕΛΟΣ άσκηση2
6. Να σχηματιστεί ο πίνακας τιμών του παρακάτω αλγορίθμου. Τι θα εκτυπωθεί;
ΑΛΓΟΡΙΘΜΟΣ άσκηση3
β  10
ΟΣΟ β ≥ 0 ΕΠΑΝΑΛΑΒΕ
αβ+3
ΑΝ α < 8 TOTE
γα–β
ΑΛΛΙΩΣ
γα+β
ΤΕΛΟΣ_ΑΝ
ΕΚΤΥΠΩΣΕ γ
ββ–4
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ άσκηση3
7. Οι εντολές
i 1
A0
ΟΣΟ i ≤ 10
ΕΠΑΝΑΛΑΒΕ
ΔΙΑΒΑΣΕ x
AA+x
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΕΛ Μολάων
Σελίδα 2 από 4
Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Φυλλάδιο 5
α. οδηγούν σε ένα βρόχο που εκτελείται επ’
άπειρον
γ. υπολογίζουν το άθροισμα 10 τυχαίων αριθμών
που διαβάζονται από το πληκτρολόγιο
β. υπολογίζουν το άθροισμα 1+2+…+10
δ. οδηγούν σε ένα βρόχο που εκτελείται ακριβώς
μία φορά
8. Να συμπληρώσετε τα κενά στον παρακάτω αλγόριθμο, έτσι ώστε να εμφανίζονται οι
αριθμοί: -1, 2, -3, 4, -5, 6, -7
ΑΛΓΟΡΙΘΜΟΣ συμπλήρωση_κενών
ΓΙΑ i ΑΠΟ _____ ΜΕΧΡΙ ______
ΑΝ __________ ΤΟΤΕ
ΕΜΦΑΝΙΣΕ _______
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ _______
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ συμπλήρωση_κενών
9. Ποιο από τα παρακάτω τμήματα αλγορίθμου υπολογίζει το άθροισμα των περιττών
ακεραίων που βρίσκονται στο διάστημα [1, 100];
α.
άθροισμα  0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
γ.
άθροισμα  0
άθροισμα  άθροισμα + i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
β.
άθροισμα  0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 2
άθροισμα  άθροισμα + i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 2
άθροισμα  άθροισμα + i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
δ.
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 2
άθροισμα  άθροισμα + i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
10. Πόσες φορές θα εκτελεστεί η εντολή ΕΚΤΥΠΩΣΕ Α στο παρακάτω τμήμα αλγορίθμου;
Α  10
ΟΣΟ Α <> 0 ΕΠΑΝΑΛΑΒΕ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
α. 10
ΓΕΛ Μολάων
ΑΑ–1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΚΤΥΠΩΣΕ Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
β. καμιά
γ. 2
δ. άπειρες
Σελίδα 3 από 4
Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Φυλλάδιο 5
11.Ερωτήσεις Αντιστοίχισης
1.
Στήλη Α
Εκφράσεις
Στήλη Β
Αλγοριθμικές Έννοιες
1. Χ  Χ + 2
2. 3 + Α > Β
3. ΕΜΦΑΝΙΣΕ Β
4. ΟΣΟ Κ < 3 ΕΠΑΝΑΛΑΒΕ
εντολές
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
5. Χ – (Χ / 2) * 2
α. Αριθμητική έκφραση (παράσταση)
β. Μεταβλητή
γ. Λογική έκφραση (παράσταση)
δ. Δομή ακολουθίας
ε. Δομή επανάληψης
στ. Εντολή εκχώρησης
ζ. Εντολή εξόδου
12.Δίνεται
η
διπλανή
αλληλουχία
εντολών. Να βρείτε πόσες φορές
εκτελείται η εντολή
Α Α+z
για καθένα από τους παρακάτω
συνδυασμούς των μεταβλητών x, y
και z:
α. x = 0, y = 8, z =3
β. x = 7, y = 10, z =5
γ. x = -10, y = -5, z =-1
δ. x = 10, y = 5, z =2
13.Να μετατρέψετε το διπλανό τμήμα
αλγορίθμου σε ισοδύναμο με τη
χρήση
της
εντολής
ΟΣΟ
…
ΕΠΑΝΑΛΑΒΕ
14.Δίνεται
η
εντολών.
διπλανή
Ax
ΟΣΟ Α ≤ y ΕΠΑΝΑΛΑΒΕ
AA+z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Κ0
ΓΙΑ Α ΑΠΟ 5 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 10
ΚΚ+Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΚΤΥΠΩΣΕ Κ
αλληλουχία
α. Να απαντήσετε με ΝΑΙ ή ΟΧΙ, αν η
διπλανή αλληλουχία εντολών ικανοποιεί
όλα τα αλγοριθμικά κριτήρια.
α1
ΟΣΟ α <> 6
ΕΠΑΝΑΛΑΒΕ
αα+2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΚΤΥΠΩΣΕ α
β. Να αιτιολογήσετε την απάντησή σας.
ΓΕΛ Μολάων
Σελίδα 4 από 4
Author
Document
Category
Uncategorized
Views
0
File Size
72 KB
Tags
1/--pages
Report inappropriate content