close

Enter

Log in using OpenID

2600/3600 シリーズ ルータの音声とデータのサポートについて

embedDownload
2600/3600 シリーズ ルータの音声とデータのサポートについて
目次
概要
前提条件
要件
使用するコンポーネント
表記法
背景説明
NM-HDV でサポートされるタイムスロット グループ
タイムスロット グループの結合
PRI(pri-group)
ネットワークおよび User-Side PRI
フラクショナル PRI
音声 PRI とデータ PRI
ISDN回線 切り替え
Cisco 2600/3600 シリーズと Cisco AS5300 シリーズ ルータの PRI 設定の違い
NM-HDV および T1/E1 マルチフレックス 音声/WAN インターフェイス カード(DS0-Group)を使用する CAS シグナリ
ング
Transparent Common Channel Signaling(T-CCS; トランスペアレント CCS)とネイティブ PRI
TDM クロス コネクト(tdm-group)
データ WAN機能(チャネルグループ)
チャネルグループ 帯域幅
サポートされるカプセル化
サポートされているシナリオ
シナリオ 1: 同じ NM-HDV に 1 回線の音声 T1/E1 と 1 回線のデータ T1/E1 を設定する場合
シナリオ 2: 同じ NM-HDV のオンネット コールの PSTN 呼び出しのための D&I および VoIP/FR
シナリオ 3: 同じ NM-HDV に PSTN コールと、オンネット コール用の VoIP/FR を設定する場合
警告と設計上の留意点の要約
関連情報
概要
この文書では、1 ポートまたは 2 ポートの T1/E1 マルチフレックス音声/WAN インターフェイス カード(VWIC)が搭載された
High Density Voice Network Module(NM-HDV; 高密度音声ネットワーク モジュール)のさまざまな使用方法の概要を説明しま
す。 マルチフレックス VWIC には、WIC と Voice Interface Card(VIC; 音声インターフェイス カード)の機能が結合されてお
り、Cisco 2600 および 3600 マルチサービス ルータでさまざま音声アプリケーションとデータ アプリケーションのサポートが
実現されています。
前提条件
要件
このドキュメントの読者は次のトピックについて理解している必要があります。
テレフォニーの概念
Voice over IP(VoIP)ダイヤル ピア
E1/T1 概念
使用するコンポーネント
このドキュメントの情報は、次のソフトウェアのバージョンに基づくものです。
NM-HDV の音声サポートのための Cisco IOS ソフトウェア リリース 12.0(7)T
NM-HDV の WAN データ サポートのための Cisco IOS ソフトウェア リリース 12.1.3T
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべ
てのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜
在的な影響を十分に理解しておく必要があります。
表記法
ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。
背景説明
Cisco 2600/3600 シリーズ IOS ゲートウェイでは、まず ISDN がサポートされました。これは PRI とも呼ばれており、次のよう
な多くのネットワーク モジュールのデータ接続が実現されています。
NM-1CT1
NM-1CT1-CSU
NM-2CT1
NM-2CT1-CSU
NM-1CE1B
NM-2CE1B
NM-1CE1U
NM-2CE1U
NM-1FE1CT1
NM-1FE1CT1-CSU
NM-1FE2CT1
NM-1FE2CT1-CSU
NM-1FE1CE1B
NM-1FE1CE1U
NM-1FE2CE1B
NM-1FE2CE1U
Cisco IOS ソフトウェア リリース 12.0(7)T では Cisco 2600/3600 シリーズ IOS Gateway からの PBX か Public Switched
Telephone Network (PSTN)に T1/E1 インターフェイスの音声接続をサポートするために、NM-HDV は導入されました。 Cisco
2600/3600 シリーズ ゲートウェイのデジタル インターフェイスとアナログ インターフェイスでは、現在次のシグナリングがサ
ポートされています。
T1-PRI
E1-PRI
T1-Channel Associated Signaling(CAS; 個別線信号方式)
E1 R2
T1/E1 Q シグナリング(QSIG)
T1 Feature Group D(FGD; 機能グループ D)
BRI、外国為替事務所 (FXO)
受信と伝送(E&M)
Foreign Exchange Station (FXS)
Cisco IOS ソフトウェア リリース 12.1.3T にマージした Cisco IOS ソフトウェア リリース 12.1.2xh では、WAN データ接続は
また NM-HDV でもたらされました。
T1/E1 の Digital Signaling Zero (DS0)チャネルはグループ化し、音声かデータトラフィックおよび両方のトラフィック の
種類伝送するために割り当てられて同時に運ぶことができます。 この機能により、音声チャネルを PSTN に、D チャネルを IP
またはフレームリレーのデータ バックボーンに分割する統合アクセス プロバイダーに接続できるようになります。 この機能を
モデムのデータ コールに拡張することはできません。それらのコールを処理できるのは、リストにある従来型のデータ ネットワ
ーク モジュールだけです。
NM-HDV モジュールに関する詳細については、これらの文書を参照して下さい:
データシート: デジタル T1/E1 パケット音声トランクネットワークモジュール
高密度音声ネットワークモジュール(NM-HDV)について
マルチフレックスVWIC に関する詳細については、これらの文書を参照して下さい:
データシート: Cisco 1 ポートおよび 2 ポート T1/E1 マルチフレックス 音声/WAN インターフェイス カード
1 および 2 ポート T1 マルチフレックス トランク音声/WAN インターフェイス カード(VWIC)の理解
1 および 2 ポート E1 マルチフレックス トランク ボイス/WAN インターフェイス カード(VWIC)について
NM-HDV でサポートされるタイムスロット グループ
NM-HDV に収容されているマルチフレックス T1/E1 には、4 つの異なるタイプのタイムスロット グループを定義できます。 それ
ぞれに特定の目的があり、特定の機能をサポートします。
注:ds0-group および PRI グループに関しては、ルータのモデムコール 終了は NM-HDV モジュールでサポートされません。
次の表では、データ ネットワーク モジュール(または 2600 WIC スロット)に収容されているマルチフレックス T1/E1 のさま
ざまなタイプのグループの使用可否とサポート状況を、NM-HDV に収容されているマルチフレックス T1/E1 と比較して要約してあ
ります。
タイムスロ
ット グルー
プ
説明
データ ネットワーク
モジュールまたは
NM-HDV 内の
WIC スロット内の
T1/E1
T1/E1
tdm-group
PBX/PSTN への音声接続
の PRI/QSIG シグナリン はい(D&I)
グをサポート。
pri-group
Cross Connect 分岐挿入 (デジタル信号プロセ 音声専用
(D&I)アプリケーショ ッサ[DSP]アクセス無 (データは
ンをサポートします。
し)
不可)
ds0-group
PBX/PSTN への音声接続
の CAS シグナリングを
サポート。
channelgroup
NM-HDV でデータ WAN 接
○
続をサポート。
はい(D&I)
(DSP アクセス無し) ○
○
タイムスロット グループの結合
これらのグループの結合はこれらのガイドライン内の同じ T1/E1 インターフェイスで定義することができます:
ds0 または tdm-groups の最大数: T1/E1 のチャネル数(24/31)。
チャネルグループの最大数: 使用可能なメモリ容量に依存(およそ 2 3)。
PRI グループの最大数: 1(T1 にはチャネル 24、E1 にはチャネル 16 の設定が必要)。
次の例は、CAS と channel-group をインターフェイス 2/0 に実装した T1 コントローラの設定を示しています。
controller T1 2/0
ds0-group 1 timeslots 1-4 type e&m-wink-start
channel-group 5 timeslots 5-10
channel-group 6 timeslots 11-15
注:同じ T1/E1 コントローラに ds0-group を pri-group と一緒に設定することはできません。
PRI(pri-group)
このセクションでは、NM-HDV の PRI を Cisco IOS ソフトウェアでサポートする際のさまざまな概念の概要を説明します。
ネットワークおよび User-Side PRI
ISDN ネットワーク 側および user-side Q.931 PRI シグナリングは両方 NM-HDV の Cisco IOSソフトウェアによってサポートさ
れます。 Cisco IOSソフトウェアは現在これらのスイッチタイプのためのネットワーク側シグナルをサポートします:
Primary-QSIG
Primary-NI
Primary-NET5
デフォルト設定は、常にユーザ側になります。 ネットワーク側のシグナリングに設定を変更するには、次のコマンドを発行しま
す。
isdn protocol-emulate network
ネットワーク側の PRI シグナリングで動作するようにするには、D チャネル用に作成したシリアル インターフェイスにこのコマ
ンドを指定する必要があります。 次に、例を示します。
controller T1 1/1
framing ESF
linecode B8ZS
pri-group timeslots 1-24
interface Serial1/1:23
isdn protocol-emulate network
Q.931 ISDN PRI シグナリングは非対称プロトコルです。 ネットワーク側PRI はサービス プロバイダー側(PSTN スイッチ側)に
よって一般的に user-side PRI は Customer Premises Equipment (CPE)によって設定されるが、設定されます(PBX かルータ
側)。 ISDN PRI ネットワーク側シグナルに関する詳細については、これらの文書を参照して下さい:
Q.931 ユーザ側およびネットワーク側スイッチのサポート
ネットワーク側ISDN PRI シグナリング、トランキングおよび切り替え
ETSI Net5 PRI のための ISDN ネットワーク 側
Cisco IOSソフトウェアはルータの Cisco IOS Command Line Interface (CLI) ヘルプに表示されているようにスイッチタイプ
に信号を送るこれらの user-side をサポートします:
router(config-if)# isdn switch-type ?
primary-4ess
AT&T 4ESS switch type for the U.S.
primary-5ess
AT&T 5ESS switch type for the U.S.
primary-dms100
Northern Telecom switch type for North America
primary-net5
NET5 switch type for UK, Europe and Asia
primary-ni
National ISDN Switch type for North America
primary-ntt
Japan switch type
primary-qsig
QSIG switch type
primary-ts014
Australia switch type
スイッチ タイプは、グローバルに指定するか、D チャネル用に作成したシリアル インターフェイスに指定します。 グローバル
な設定を指定する場合は、コントローラが ISDN PRI で使用可能になる前に指定する必要があります。 グローバル な 設定が規
定 されない場合、NM-HDV コントローラの PRI グループを設定することはできません。
グローバルな設定は、ルータのすべての E1/T1 ISDN PRI インターフェイスのデフォルト設定として使用されます。 ある特定の
PRI インターフェイスがさまざま な スイッチタイプを使用する必要がある場合適切な型は D チャネル インターフェイス レベ
ルで規定 する必要があります。 インターフェイスの switch-type コマンドは、グローバルな switch-type コマンドを上書きし
ます。 Cisco IOS ソフトウェア リリース 12.1(3)T では、この機能が導入されているので、異なるスイッチ タイプを使用する
さまざまな ISDN スイッチにルータを接続できます。
たとえば、この T1 コントローラはインターフェイス 1/1 の primary-net5 スイッチタイプを使用します。
isdn switch-type primary-qsig
controller T1 1/1
pri-group timeslots 1-24
interface Serial1/1:23
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
グローバルに定義されるので T1 コントローラがインターフェイス 1/1 のプライマリ QSIG スイッチタイプを使用するところに
もう一つの例はここにあります。
isdn switch-type primary-qsig
controller T1 1/1
pri-group timeslots 1-24
interface Serial1/1:23
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
フラクショナル PRI
フラクショナル PRI という用語は、この分野のさまざまな箇所で異なる意味に使用されています。 たとえば、同じ T1/E1 イン
ターフェイス上の複数の PRI グループ(B チャネルとそれに関連する D チャネル)の意味で使用される場合があります。 NMHDV が T1/E1 ごとの単一 D チャネルだけサポートするので、PRI 機能はフラクショナル PRI のこの定義をサポートしません。
ただし、条件の他のバージョンはそれと関連付けられるを用いる各インターフェイスのための単一 D チャネルを B チャネル少数
により 23/31 の定義する機能を示します。 先にこの資料で示されているように、フラクショナル PRI のこの定義はサポートさ
れます。
たとえば、この設定は定義される 5 つの B チャネルが付いている PRI インターフェイスを示します:
controller T1 2/0
channel-group 5 timeslots 5-10
channel-group 6 timeslots 11-15
pri-group timeslots 16-20,24
注:T1/E1 インターフェイスごとの単一 D チャネルはサポートされます。 T1 コントローラで D チャネルは常時接続 チャネル
24 であり、E1 コントローラで D チャネルは常時接続 チャネル 16 です。 このアソシエーションはルータのソフトウェアコン
フィギュレーションによって変更することができません。 現在、Non-facility Associated Signaling (NFAS)は Cisco IOS ソ
フトウェア Release 12.2(8)T と それ以降の NM-HDV モジュールを使用して 26/36 プラットフォームで B チャネルの以上 1
T1/E1s 価値が単一 D チャネルにマッピング されるようにするサポートされます。 ISDN NFAS に関する詳細については、この資
料を参照して下さい:
4つの T1s を使用する NFAS の設定
音声 PRI とデータ PRI
Cisco 2600/3600 シリーズ ルータの音声、データ、モデムの各コールのサポートを明確にするために、2 つの用語を造語しまし
た。 音声 PRI とデータ PRI という用語です。 音声 PRI とは、Time-Division Multiplexing(TDM; 時分割多重)音声トラフィ
ックを PRI の B チャネルで伝送する、PBX または PSTN に接続された T1/E1 インターフェイスのことです。 データ PRI は
WAN 接続を示し、ISDN ハイレベル データ リンク コントロール(HDLC) データまたはモデム データのようなパケット化された
(データか音声)トラフィックを運びます。 NM-HDV でサポートされるのは、A チャネル音声 PRI だけです。 それは ISDN
DATA およびモデムコールをサポートしません。 データネットワーク モジュールがデータ PRI をサポートするために必要となり
ます。
PRI の着信コールが Cisco 2600/2300 シリーズ IOSルータによってどのように処理されるか決まりますこれらの変数によって:
T1/E1 が収容される位置(NM-HDV 内かデータ ネットワーク モジュール内か)
ベアラの機能(Q.931 SETUP メッセージの Bearer CAP フィールド)
着信番号のマッチングと変換が行われる Cisco IOS の仕組み
データ PRI (CT1/CE1 モジュール)
データトラフィックのためのデータ PRI 接続、かチャネライズド T1/e1 は Cisco IOS ソフトウェア リリース 11.x.以来の
Cisco 2600/3600 シリーズ ルータで、サポートされました データ PRI の接続をサポートするには、次の条件を満たす必要があ
ります。
PRI インターフェイスが、NM-HDV の内部ではなく、この文書の最初に説明したデータ ネットワーク モジュールに収容され
ている。
コールセットアップのベアラケーパビリティ(ベアラケーパビリティ)はデータです。
着信番号がダイヤラ グループによってマッチングされている。
アクセスが DSP へないのでデータ PRI は音声コールをサポートできません。 そのため、データ PRI に到達するコールが、音声
ダイヤル ピアとマッチングされるようには設定しないでください。 データ PRI のための設定例は次の通りです:
controller T1 1/0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Serial1/0:23
encapsulation ppp
no logging event link-status
dialer rotary-group 1
isdn switch-type primary-5ess
no fair-queue
interface Dialer1
ip address 6.6.6.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer in-band
no logging event link-status
dialer idle-timeout 2147483 either
dialer-group 1
no fair-queue
ppp authentication chap
ppp multilink
peer default ip address pool ISDN
音声 PRI(NM-HDV T1/E1 モジュール)
音声 PRI のサポートは、Cisco IOS ソフトウェア リリース 12.1.3T で最初に導入されました。使用するためには、次の条件を
満たしている必要があります。
PRI インターフェイスが DSP を搭載した NM-HDV に収容されている。
コールセットアップのベアラケーパビリティは音声です。
着信番号が音声ダイヤル ピアによってマッチングされている。
音声 PRI はデータ呼び出しをサポートできません。 そのため、音声 PRI に到達するコールは、常に音声ダイヤル ピアにマッチ
ングされるように(さらにダイヤラ ピアにはマッチングされないように)設定する必要があります。 音声 PRI の設定例を次に
示します。
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Serial2/0:23
isdn switch-type primary-net5
isdn incoming-voice voice
isdn T309-enable
no cdp enable
voice-port 2/0:23
no modem passthrough
dial-peer voice 1 pots
destination-pattern 4...
port 2/0:23
prefix 4
dial-peer voice 3 voip
destination-pattern 6...
session target ipv4:141.245.41.2
dtmf-rely h225-signal
ip precedence 5
PRI インターフェイスのモデムコール
モデムトラフィックはちょうど説明される 2 つの概念の間でだいたい落ちます。 それはデータトラフィックを運ぶ音声コールと
してを捉えることができます。 5300 では、モデムプールの設定に一致する着信番号(Dialed Number Identification Service
[DNIS; 着信番号識別サービス])によって音声 PRI 上でモデム コールを処理できます。 Cisco 2600/3600 シリーズ ルータで
は、この機能はサポートされていません。 設定のインテントがプラットフォーム内のモデムカードのモデムコールを終了するこ
とである場合モデムトラフィックは NM-HDV の代りにデータネットワーク モジュールとのデータ PRI で処理する必要がありま
す。
モデムコールが Cisco 2600/3600 音声 PRI (NM-HDV の T1/E1)に到着すれば、クリアチャネル コーデックによって処理されま
す。 モデム接続の場合は、通常の音声コールと同様に、Cisco IOS ゲートウェイ間のエンドツーエンドに接続が渡されます。 こ
のコールは、ゲートウェイのモデム カードでは終端できず、ルータでスイッチングされます。 モデム コールをサポートする設
定は、次の理由によりお勧めできません。
Clear-channel コーデック ベースの透過的なサポートはタイミングに敏感です。 たとえば、バッファ アンダーランにより
DSP はデータアプリケ ションを混同する音声 autofill アルゴリズムを実行します。
トラフィックのエラーまたは損失を検出できないので、ネットワークで IP パケットが失われると、モデム接続に障害が発
生してリトレインが必要になります。
ISDN回線 切り替え
Cisco IOS の音声 PRI の実装では、本当の意味での ISDN 回線交換はサポートされていません。 ただし、それは 2 つのさまざ
まな方法で近づけることができます。 このセクションでは、着信インターフェイスと発信インターフェイスでの pri-group と
POTS-to-POTS ダイヤル ピアを使用する方法を説明します。 他は tdm-group および D&I を利用し、次の セクションで考慮され
ます。
PRI での着信コールと発信コールの交換に POTS-to-POTS ダイヤル ピアを使用する場合、次のような特性があります。
それは他のどの POTS間 コール(E&M、T1 CAS、等)と同等です。
PRI シグナリングが解釈される(終端および再生成が行われる)。
DSP は使用されます。
ディジット操作はすることができます。
一部の着信コールを PRI で送出して、他のコールを Voice-operated eXchange(VoX)で伝送できる。 インバウンド タイ
ム スロットとアウトバウンド タイム スロットの間には関連性はありません。
それはプラットフォームのあらゆる PRI 音声 トランクを渡って可能性のあるです。
PRI 音声コールだけを処理できる。
プレフィクスとして切り替えるダイヤルされる何れかの 4 ディジットのための 4 か 5 の T1 PRI 行で音声コールをための設定
例はここにあり。 ダイヤル番号が "6" から開始する場合、VoIP にコールを変換し、終了のための 10.1.1.1 終端ゲートウェイ
にそれを送信 します。 この設定は、次の図と一致しています。
controller E1 1/0<
pri-group timeslots 1-31
controller E1 2/1
pri-group timeslots 1-10,16
interface Serial1/0:15
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice voice
interface Serial2/1:15
isdn switch-type primary-net5
isdn incoming-voice voice
dial-peer voice 1 pots
destination-pattern 4...
port 1/0:15
prefix 4
dial-peer voice 2 pots
destination-pattern 5...
port 2/1:15
prefix 5
dial-peer voice 3 voip
destination-pattern 6...
session target ipv4:10.1.1.2
Cisco 2600/3600 シリーズと Cisco AS5300 シリーズ ルータの PRI 設定の違い
Cisco 2600/3600 シリーズ プラットフォームと Cisco AS5300 の設定の主な違いを次に示します。
1. D チャネル シリアルインターフェイスに関しては:
Cisco2600/3600 はこのコマンドを必要とします: isdn incoming-voice voice
Cisco AS5300 はこのコマンドを必要とします: isdn incoming-voice modem
2. D チャネル 音声ポート:
3.
4.
5.
6.
Cisco 2600/3600 は自動的に作成します: ポート 2/0:23(T1)または 2/0:15(E1)。
Cisco AS5300 は自動的に作成します: ポート 1:D。
Cisco AS5300 は PRI のモデムカードに ISDN データおよびモデム 音声コールを終了できます。 Cisco 2600/3600 シリー
ズ ルータはできません; これらのルータは 2 つの異なるネットワークモジュールを使用する必要があります。
クリアチャネル コーデックは Cisco 2600/3600 シリーズ ルータでサポートされます。 この機能は、AS5300 ではサポート
されていません。
トランスペアレント CCS(T-CCS)および D&I 機能は PRI のための Cisco 2600/3600 のサポートです。 この機能は、
AS5300 ではサポートされていません。
ISDN NFAS 信号を送ることは Cisco AS5300 とまた 2600/3600 シリーズ ルータでサポートされます。
注:2600/3600 シリーズ ルータでは、ISDN の dms100、4ess および 5ess の各スイッチ タイプに、サポートが制限されて
います。 また user-side だけ NFAS 2600/3600 シリーズ プラットフォームでサポートされることに、注目して下さい。
NM-HDV および T1/E1 マルチフレックス 音声/WAN インターフェイス カード(DS0Group)を使用する CAS シグナリング
T1 CAS を使用すると、これらのネットワーク モジュールで、チャネル化 T1 回線を使用した音声コールの伝送が可能になりま
す。 CAS は T1 行で使用されるシグナリングの形式です。 CAS を使用すれば、シグナリング要素が T1 フレーム内の各チャネル
専用になります。 このタイプのシグナリングは、スイッチとやり取りするシグナリング情報を提供するために、ユーザのデータ
ストリームから 1 ビットが取られる(損失する)ので、Robbed Bit Signaling(RBS; 損失ビット シグナリング)と呼ばれるこ
ともあります。
T1 マルチフレックス モジュールのすべての可能性のある CAS シグナルサポートのリストはここにあります:
3640router# configure t
Enter configuration commands, one per line.
End with CNTL/Z.
3640route(config)# controller t1 2/0
3640router(config-controller)# ds0-group 1 timeslots 1-24 type ?
e&m-delay-dial
E & M Delay Dial
e&m-fgd
E & M Type II FGD
e&m-immediate-start E & M Immediate Start
e&m-wink-start
E & M Wink Start
ext-sig
External Signaling
fgd-eana
FGD-EANA BOC side
fxo-ground-start
FXO Ground Start
fxo-loop-start
FXO Loop Start
fxs-ground-start
FXS Ground Start
fxs-loop-start
FXS Loop Start
none
Null Signaling for External Call Control
3640router(config-controller)# ds0-group 1 timeslots 1-24 type e&m-wink-start
このコマンドを発行すると、関連する音声ポートが作成されます。
次に、例を示します。
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
voice-port 2/1:1
where the "2/1" is the controller # and ":1" is the ds0-group
T1 CAS シグナリングの設定およびトラブルシューティングに関する詳細については、この資料を参照して下さい:
Cisco 2600 および 3600 シリーズ ルータのデジタル T1 パケット音声トランクネットワークモジュールの設定
E1 CAS シグナリングに関しては、それは全く異なります。 E1 CAS に関しては、タイムスロット 16 は CAS シグナリングのため
に、ISDN に類似した完全に使用されます。 ただし、形式は異なっています。 E1 CAS に関する詳細については、これらの文書を
参照して下さい:
E1 R2 シグナル理論
cas-custom コマンドを使用する E1 R2 カスタマイゼーション
E1 R2 シグナリングの設定とトラブルシューティング
Transparent Common Channel Signaling(T-CCS; トランスペアレント CCS)とネイテ
ィブ PRI
PRI が設定されている Cisco 2600/3600 シリーズ ルータでは、T-CCS もサポートできます。 T-CCS を使用すれば、独自または
サポートされていない CCS プロトコルを使用するデジタル インターフェイスが設定された 2 台の PBX を、CCS シグナリングを
解釈してコール処理しなくても接続できるようになります。 この機能では、T1/E1 のトラフィックがデータ ネットワークを透過
的に伝送されるので、独自のシグナリングが維持されます。 PBX 観点から、シグナリングはポイントツーポイント接続によって
実行された。 PBX からの呼び出しはルーティングされませんが、宛先に前もって構成されたルートに続きます。 この機能を使用
すれば、PBX に WAN 経由での透過性が確保されるので、発信者の名前と番号の表示、キャンプオンとコールバック、ネットワー
ク コール転送、集中対応、および集中メッセージング待機などの高度な機能を PBX ネットワークで実現できるようになります。
ネイティブ PRI サポートは Dチャネルシグナリングが Cisco IOSゲートウェイによってローカルで解読され、終了することを意
味します。 次にルータでは、発信ダイヤルピアと一致した着信番号(DNIS)に基づいてコールのルーティングを決定できます。
ネットワークの反対側の音声インターフェイスは PRI または別の音声 Trunk Protocol であるかもしれません(たとえば、
QSIG、E&M、または FXS/FXO)。 この設定を使用すれば、すべてのロケーション間でスイッチド コールがフル サポートされま
す。
一方 T-CCS を使用すると、IP/フレーム リレー/ATM クラウド経由で、シグナリングが 2 台の PBX 間をポイントツーポイント方
式で透過的にトンネリングされます。 PBX では、互いに直接接続されているように設定されており、同じ音声トランク プロトコ
ルを実行している必要があります。 音声コールのスイッチングは行えず、ロケーション間は接続トランクを介して 1 対 1 のマ
ッピングでスタティックに設定されます。 PBX とルータの間に定義するシグナリング チャネルには、クリア コーデックを設定
する必要があります。 音声トラフィックの符号化には、2 台のルータ間のダイヤル ピアで定義されている任意のコーデックを使
用できます。
次の図と表は、T-CCS の設定例を示しています。
3640_1 ルータの設定
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 24 type ext-sig
ds0-group 1 timeslots 1 type ext-sig
.
.
(continue up to max time slot required)
.
ds0-group 23 timeslots 23 type ext-sig
!
interface Serial0/0
ip address 172.16.1.2 255.255.255.252
!
voice-port 1/0:0
!--- signaling channel
3640_2 ルータの設定
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 24 type ext-sig
ds0-group 1 timeslots 1 type ext-sig
.
.
(continue up to max time slot required)
.
ds0-group 23 timeslots 23 type ext-sig
!
interface Serial0/0
ip address 172.16.1.1 255.255.255.252
!
voice-port 1/0:0
!--- signaling channel
connection trunk 1000 answer-mode
!
voice-port 1/0:10
!--- bearer channel
connection trunk 3000
!
voice-port 1/0:10
!--- bearer channel
connection trunk 2001 answer-mode
!
.
.
(continue onward for every voice-port setup)
.
voice-port 1/0:23
!--- bearer channel
connection trunk 4001
!
.
.
(continue onward for every voice-port setup)
.
voice-port 1/0:23
!--- bearer channel
connection trunk 2023 answer-mode
!
dial-peer voice 1000 voip
description Signaling Channel
destination-pattern 1000
session target ipv4:172.16.1.1
codec clear-channel
no vad
!
dial-peer voice 2000 voip
description Voice Bearer Channels
destination-pattern 2...
session target ipv4:172.16.1.1
!
dial-peer voice 3000 pots
description Signaling Channel
destination-pattern 3000
port 1/0:0
!
dial-peer voice 4001 pots
description Voice Bearer Channel
destination-pattern 4001
port 1/0:1
.
.
(continue onward…one for every ds0/voice port setup)
.
!
dial-peer voice 4023 pots
description Voice Bearer Channel
destination-pattern 4023
port 1/0:23
connection trunk 4023
!
dial-peer voice 3000 voip
description Signaling Channel
destination-pattern 3000
session target ipv4:172.16.1.2
codec clear-channel
no vad
!
dial-peer voice 4000 voip
description Voice Bearer Channels
destination-pattern 4...
session target ipv4:172.16.1.2
!
dial-peer voice 1000 pots
description Signaling Channel
destination-pattern 1000
port 1/0:0
!
dial-peer voice 2001 pots
description Voice Bearer Channel
destination-pattern 2001
port 1/0:1
.
.
(continue onward…one for every ds0/voice port setup)
.
!
dial-peer voice 2023 pots
description Voice Bearer Channel
destination-pattern 2023
port 1/0:23
T-CCS に関する詳細については、これらの文書を参照して下さい:
Transparent Common Channel Signaling
透過型 CCSの設定とトラブルシューティング
TDM クロス コネクト(tdm-group)
このセクションでは、以前のセクションで述べたとおり、ISDN 回線交換を実現する 2 番目の方法を説明します。 それは実用的
な値を制限しましたが、外部マルチプレクサ (mux) 機器を除去するのに使用でき、根本的に顧客のアプリケーションによって
がある方法を変更しないで顧客向けのラック スペースは動作します。 このコンテキストで tdm-group の使用の例を示すことを
使用します。
この機能のもう一つの名前は D&I.D&I 示します TDM 回線の相互接続をです。 音声トラフィック用にシスコ製ルータを使用する
場合、この用語は、ルータ上のあるポートから別のポートへの TDM ストリームのクロス コネクトを意味します。 D&I は別の
T1 の 64Kb DS0 チャネルに 1 T1 およびデジタルで Cross Connect から 64Kb DS0 チャネルをそれら持って行くことを可能にし
ます。 ユーザー 64Kb DS0 チャネルは DSP処理なしで T1/E1 ポートの間で圧縮解除されて透過的に、渡す、ことができます。
これは D&I がパケット交換が用いる DSP を必要としない回線交換を使用するという理由によります。 基本的には、ルータはス
イッチか PBX によって使用される音声シグナリングを終了しませんし、解読しません。 それは TDM バックプレーンを単に提供
し、2 つのコントローラ DS0 タイム・スロットを接続します。
D&I との接続は VoIP と従来の回線ベース PBX テクノロジーを統合 1 つの方法です。 チャネル トラフィックは PSTN による長
距離サービスのためのいくつかの PBX チャネルの使用を可能にする PBX および Central Office (CO) スイッチか他のテレフ
ォニーデバイスの間でたとえばルータが局間 VOIPコールのために他を圧縮する間、送信 されます。 さらに外部アナログ接続を
提供、D&I はチャンネルバンクに Cross Connect テレフォニースイッチ(CO から)できます。 それはまた Private Integrated
services Network eXchange (PINX)が QSIG をサポートしないか、または PINX が独自 の ソリューションを使用するとき
PBX、鍵システム(KTs)、および CO を相互接続する方法を提供します。 この機能を使用すれば、コール処理用に音声シグナリ
ングを解釈しなくても、2 台の PBX を接続できるようになります。 基本的には、シグナルメッセージは専用タイムスロットの内
で伝えられ、これらのタイム・スロットは 1 人の T1/E1 コントローラから VWIC モジュール内の他の T1/E1 コントローラに相
互接続です。
従来の方法では、TDM クロス コネクトを行えるのは、同じ VWIC の 2 基のコントローラ間だけです。 12.2(4)T 以降では、
Cisco 2600 シリーズ ルータで、同じゼロ LAN 2 スロット ネットワーク モジュール(NM-2W)の 2 枚の VWIC 間の TDM ストリ
ームの接続が可能になっています。 Cisco 3600 シリーズ ルータで、それは同じファースト イーサネット ネットワークモジュ
ール(NM-xFE2W)の 2 VWIC 間の TDM ストリームの接続を可能にします。 MIX モジュール(MIX-3660-64)が装備されている
Cisco 3660 マルチサービス プラットフォームでまた異なる混合使用可能 な ネットワークモジュールのポートを互いに接続でき
ます。
MIX に関する詳細については、これらの文書を参照して下さい:
Cisco 2600 および 3600 シリーズ モジュラ アクセス ルータのためのマルチサービス交換 (MIX)
Cisco 3600 シリーズ マルチサービス プラットフォームのためのマルチサービス交換 (MIX)
tdm-group を使用して T1/E1 の全体または一部をクロス コネクトする場合は、次の特性が適用されます。
PRI シグナリングは解釈されない(実際にシグナリングは無関係)。
DSP は使用されません。
ディジット操作はすることができません。
受信されるすべての呼び出しは入出力タイム・スロット間の 1対1の関係に従って相互接続タイムスロットで送信されます。
このメカニズムを適用できるのは、同じ VWIC の T1/E1 を通過する場合だけ。
PRI コールのどの型でも処理することができます(データ、音声、モデム、またはビデオ)。
同じフレーミングタイプは D&I.に関連する T1 両方のコントローラで使用される必要があります。
TDM Cross Connect のための設定例はこのダイアグラムを一致するために示されています:
注:ISDN PRI シグナリングは、PBX と PSTN の間で行われます。 この場合、ルータは透過的です。つまり、ルータは 2 つの
T1 回線間の TDM クロス コネクトだけを実行します。 TDM クロス コネクトは、使用するシグナリングにかかわらず実装できま
す。
controller T1 2/0
framing esf
linecode b8zs
tdm-group 1 timeslots 1-24 type e&m
controller T1 2/1
framing esf
linecode b8zs
tdm-group 2 timeslots 1-24 type e&m
connect pri-di T1 2/0 1 T1 2/1 2
注:D&I を設定するとき、コントローラの下で(tdm-groups が設定されるかところで)、同じである必要含みましたフレーム化
する T1 は。 もし違ったらフレーミングタイプは使用されました、1 人のコントローラからのチャネルが他のコントローラから
のチャネルに廃棄され、挿入されるときシグナリングビットはきちんと理解されないかもしれません。 TDM Cross Connect 例で
は、拡張スーパーフレーム(ESF)フレーム作成は両方の例で使用されました。
TDM Cross Connect に関する詳細については、これらの文書を参照して下さい:
『Cisco 2600 および 3600 シリーズ ルータの 1 ポートおよび 2 ポート T1/E1 マルチフレックス音声/WAN インターフェ
イス カードの設定』の「分岐挿入の設定」のセクション
共通チャネル信号(CCS)
TDM Cross Connect のための MC3810 の設定
データ WAN機能(チャネルグループ)
データ WAN 接続機能により、channel-group コマンドを使用して、NM-HDV に収容されている T1/E1 のデータ通信用のタイムス
ロット グループを定義できるようになります。 構文は次のとおりです。
(config)# controller {T1 | E1} slot/port
(config-controller)# channel-group channel-group-no timeslots timeslot-list [speed [48|56|64]]
(config)# interface serial slot/port:channel-group
チャンネルグループを自動的に定義する場合、チャンネルグループ数のすぐ前にコロンに先行しているコントローラ数でシリアル
ポートを作成します。 次に、例を示します。
controller T1 2/1
channel-group 10 timeslots 1-15
interface serial 2/1:10
encapsulation ...
チャネルグループ 帯域幅
チャネル グループの最大帯域幅は、グループに含まれる個々のタイムスロット数の集約帯域幅(n*DS0-speed)になります。 任
意の数からすべてのタイムスロットまでをグループ化する機能は、フラクショナル E1/T1 と呼ばれています。 たとえば、この設
定に 960K の最大帯域幅があります。 明示的に指定しないと、DS0 の速度は T1 の場合で 56K、E1 の場合で 64K になります。
サポートされている速度は、48K、56K および 64K です。
controller T1 2/1
channel-group 10 timeslots 1-15 speed 64
サポートされるカプセル化
ルータの Cisco IOS CLI のヘルプに表示されるように、シリアル インターフェイスでは次のカプセル化がサポートされていま
す。
controller T1 2/1
channel-group 2 timeslots 1-4
lab2(config)# interface s2/1:2
lab2(config-if)# encapsulation ?
atm-dxi
bstun
frame-relay
hdlc Serial
lapb
ppp
sdlc
sdlc-primary
sdlc-secondary
smds
stun
x25
ATM-DXI encapsulation
Block Serial tunneling (BSTUN)
Frame Relay networks
HDLC synchronous
LAPB (X.25 Level 2)
Point-to-Point protocol
SDLC
SDLC (primary)
SDLC (secondary)
Switched Megabit Data Service (SMDS)
Serial tunneling (STUN)
X.25
controller T1 2/1
framing esf
linecode b8zs
channel-group 1 timeslots 1-24
!
interface serial 2/1:1
ip address 10.1.1.1 255.255.255.0
encapsulation PPP
controller T1 2/1
framing esf
linecode b8zs
channel-group 1 timeslots 1-24
!
interface serial 2/1:1
ip address 10.1.1.2 255.255.255.0
encapsulation PPP
サポートされているシナリオ
シナリオ 1: 同じ NM-HDV に 1 回線の音声 T1/E1 と 1 回線のデータ T1/E1 を設定する場合
NM-HDV の 2 ポート VWIC は次のように設定されています。
1 回線の音声 T1/E1 を PBX に接続
1 回線のデータ T1/E1 を WAN に接続
PBX から受信されたすべての音声コールは VoIP または Voice over Frame Relay (VoFR) ダイヤル ピアに一致し、同じネット
ワークモジュールの他の T1/E1 ポートのチャネルグループと定義される WAN リンクの IP アドレスまたはフレームリレーデータ
リンク接続 識別子(DLCI)に指示することができます。
注:ATM はこの設定でサポートされません。
この機能の使用により、お客様がどのようにポート スロットをさらに効率的に使用できるようになるかが次の設定に示されてい
ます。この情報は、ネットワーク モジュール スロットが 1 つだけ搭載された Cisco 2600 を使用する場合には特に重要です。
次に設定例を示します。
controller T1 1/0
description Voice signaling with the PBX
framing esf
linecode b8zs
ds0-group 1 timeslots 1-24 type e&m-wink
!
controller T1 1/1
description DATA link to the WAN cloud
framing esf
linecode b8zs
channel-group 4 timeslots 1-24
!
interface serial 1/1:4
no ip address
encapsulation frame-relay
!
interface serial 1/1:4.1 point-to-point
ip address 192.168.100.1 255.255.255.0
frame-relay interface-dlci 100
!
voice-port 1
シナリオ 2: 同じ NM-HDV のオンネット コールの PSTN 呼び出しのための D&I および VoIP/FR
NM-HDV の 2 ポート VWIC は次のように設定されています。
VWIC の 1 つの T1/E1 ポートを PBX に接続。
VWIC のもう 1 つの T1/E1 ポートを PSTN および WAN アクセス用の統合アクセス キャリアに接続。
PBX からのある特定のタイム・スロットの PSTN 呼び出しは D&I.を使用して回線交換です。
オンネット コールは他のタイムスロットを使用。 これらのコールは、VoIP または VoFR を使用して WAN 上を伝送されま
す。
このシナリオで PBX は T1/E1 のチャネルの異なるグループにオンネット([HQ ブランチ ツー ブランチ/本部])呼び出しからの
PSTN によって送信される呼び出しを分割します:
チャネル 1 12 の PBX から受信された呼び出し(コントローラ 1/0 および tdm-group は 1) コントローラ 1/1 の PSTN
に行く 12 の相互接続される D&I 音声 チャネルに、tdm-group 4.です。
チャネル 13 24 の PBX から受信された呼び出しは(コントローラ 1/0 ds0-group)オンネット コールです。 これらのコ
ールは、ルータで終端されてから、VoIP または VoFR のダイヤルピアとマッチングされます。これらのダイヤルピアでは、
WAN リンク(コントローラ 1/1、channel group 13)上の IP アドレスまたはフレーム リレー DLCI にコールが振り向けら
れます。
設定 例は次の通りです:
controller T1 1/0
description PBX connection
framing esf
linecode b8zs
tdm-group 1 timeslots 1-12
ds0-group 13 timeslots 13-24 type e&m-wink
!
controller T1 1/1
description PSTN connection
framing esf
linecode b8zs
tdm-group 4 timeslots 1-12
channel-group 13 timeslots 13-24
!
interface serial 1/1:13
no ip address
encapsulation frame-relay
!
interface serial 1/1:13.1 point-to-point
ip address 192.168.100.1 255.255.255.0
frame-relay interface-dlci 100
!
voice-port 1/0:13
!
connect tdm1 T1 1/0 1 T1 1/1
シナリオ 3: 同じ NM-HDV に PSTN コールと、オンネット コール用の VoIP/FR を設定する場合
NM-HDV の 2 ポート VWIC は次のように設定されています。
オンネット 音声コールのための PBX からのフル T1/E1。
統合アクセス プロバイダーの 1 回線の T1/E1 を PSTN への音声コールと WAN リンクへのデータ通信に使用。
このシナリオでは、PBX からの PSTN への呼び出しはオンネット コールからダイヤリングプランを通して顕著である必要があり
ます。 従って、D&I 機能は使用することができません。 PBX からのすべての呼び出しはダイヤル ピアによってコールの宛先を
判別するために一致する必要があります(PSTN かオンネット)。 PSTN のコールは、POTS-to-POTS ダイヤルピアのコールであ
り、PSTN に到達する ds0-group(コントローラ 1/1、ds0-group 2)に振り向けられます。 PSTN からのインバウンド コールに
も同じシナリオが適用されます。 呼び出しはルータで定義されるダイヤリングプランを通して顕著である必要があります。
オンネット コールは、WAN リンク(コントローラ 1/1, channel-group 7)上の IP アドレスまたはフレーム リレー DLCI に振
り向けることができる VoIP または VoFR のダイヤル ピアとマッチングされます。
設定 例はそのようにあります:
controller T1 1/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-24 type e&m-wink
!
!
controller T1 1/1
framing esf
linecode b8zs
ds0-group 2 timeslots 1-6 type type e&m-wink
channel-group 7 timeslots 7-24
!
interface serial 1/1:7
no ip address
encapsulation frame-relay
!
interface serial 1/1:7.1 point-to-point
ip address 192.168.100.1 255.255.255.0
frame-relay interface-dlci 100
!
voice-port 1/0:1
!
voice-port 1/1:2
警告と設計上の留意点の要約
各 T1/E1 のための単一の固定 D チャネルはチャネル 24 (T1)またはチャネル 16 (E1)で、サポートされます。 各
T1/E1 のための複数の D チャネルはサポートされません。 そのため、各 T1/E1 に設定できる PRI グループは 1 つだけに
なります。 pri-group コマンドが数値的な引数に先行していないことに注意して下さい。
ISDN NFAS 信号を送ることは NM-HDV の Cisco 2600/3600 シリーズ ルータでサポートされません。 ただし、他のプラット
フォームでは NFAS がサポートされているので、CLI にはこのコマンドが表示されます。 NFAS はデータネットワーク モジ
ュールのためにサポートされます。
pri-group をコントローラから削除するには、コントローラと一緒に音声ポートもシャットダウンする必要がある。 コント
ローラか、D チャネル シリアルインターフェイス、またはその両方をシャットダウンすることは十分ではないです。
インターフェイスにスイッチ タイプが指定されている場合は、グローバル レベルで指定されているスイッチ タイプが上書
きされる。
PRI インターフェイスで音声をサポートするためには、Cisco 2600/3600 で isdn incoming-voice voice コマンドを使用し
て音声 PRI を設定する必要がある。 CLI に表示される modem オプションと data オプションを適用できるのは他のプラッ
トフォームだけです。
NM-HDV の PRI T1/E1 で受信されたモデムコールはクリアチャネル コーデックによって音声コールとして処理されます。
パケットの損失が検出されず、ジッタによる DSP バッファのアンダーランまたはオーバーランが宛先で発生する可能性があ
るので、この設定はお勧めしません。 これが起こる場合、モデムをリトレインします。
NM-HDV のデータ WAN 接続は pri-group コマンドで実行することができません。 そのため、NM-HDV モジュールでは ISDN
のデータ コールはサポートされません。 それは channel-group コマンドでデータ WAN 接続しかサポートなできます。
channel-group コマンドと pri-group コマンドは NM-HDV のメモリを使用する。 ds0-group コマンドと tdm-group コマン
ドはそうではありません。
channel-group コマンドと tdm-group コマンドは音声 DSP を使用しない。 ds0-group コマンドと pri-group コマンドは
音声 DSP を使用します。
NM-HDV T1/E1 が音声およびデータアクセスを両方する場合、カードにより多くの DSP リソースがよりあることは定義され
る音声 チャネルによって可能性のある使用することができますです。 将来の Cisco IOS ソフトウェアの機能強化でルータ
バックプレーンをまたいだ TDM スイッチングが可能になるまでは、これらの DSP をルータ内の他の音声インターフェイス
やアクティビティと共有することはできません。 この機能が使用できるのは、Cisco 3660 プラットフォームだけです。
NM-HDV のチャネル グループの最大数は、NM-HDV のメモリによって制限される。 これは NM-HDV に関するネットワーク モ
ジュールの制限であり、個々の T1/E1 の制限ではありません。
タイムスロット グループの異なる型はチャンネルグループのためのメモリ 制限内の同じ T1/E1 で PRI グループにそれら
に利用可能 な D チャネル タイムスロット(24、および E1 の T1 の 16)があれば任意に組み合わせて組み合わせ。
TDM D&I は同じ NM-HDV の 2 つの T1/E1 ポート間だけで可能性のあるです。
データ WAN 機能では、VoIP および VoFR による WAN データ接続をサポートできるが、VoATM または VoIPoATM はサポート
できない。 ATM WAN 接続はまだ ATM の逆多重化(IMA)または OC-3 カードのような ATM 対応 ネットワークモジュール
を、必要とします。
関連情報
Troubleshooting Cisco IP Telephony
トラブルシューティング テクニカルノーツ
1992 - 2014 Cisco Systems, Inc. All rights reserved.
Updated: 2014 年 12 月 24 日
Document ID: 23525
http://www.cisco.com/cisco/web/support/JP/100/1003/1003261_Understanding_Support_26xx.html
Author
Document
Category
Uncategorized
Views
9
File Size
327 KB
Tags
1/--pages
Report inappropriate content