close

Enter

Log in using OpenID

技術文書のための Word の使い方

embedDownload
技術文書のための Word の使い方
Usage of Word for Technical Writing
電子情報工学科
藤田
悠
1. はじめに
TeX を使うと,非常に質の高い文書を作成することができる.他方,手軽に文書を作成
するソフトウェアとして Word がある.これらは互いに使い方が異なり,それぞれ得意な面
と不得意な面がある.
しかし,TeX が利用できる環境になかったり,テンプレートが Word にて指定されてい
たり,Word ファイルにてやり取りする必要があったり,Word の有効な機能を使いたい場
合などが存在する.例えば,企業における活動の中では,TeX を使って文章を書くための
環境がない場合や,Word による文書作成が必須となっている場合もある.インターンなど
で,必要に迫られたとの声も聴く.そのような必要に迫られたときに困らないために,基
本的な Word の使い方を学習する.
そこで,TeX で作成する文書に近づけるために Word の設定し,TeX に劣らない文書に
近づける方法をまとめる.
注意として,この授業は「TeX よりも Word を使うことを勧める」ために行うのではな
い.TeX は優れた組版処理環境であるため,TeX で完結できる場合には TeX を使うことを
勧める.
なお,卒業論文予稿のためのテンプレートは,現時点で TeX のスタイルファイルとして
配布されている.したがって,卒業論文予稿の作成は,TeX を用いるほうが適切である.
2. やってはいけないこと
Word を使うときに,以下のような方法を使っていたらそれは,適切な方法ではないの
で,やってはいけない.その代わりに,適した手段をとることで,修正や再利用などにお
ける手間がなくなるはずである.
(1) 章番号や箇条書きの番号,参照番号などを自分で打ち込むこと
(2) 間隔は空白の調整にスペースを使うこと
これらは,どうしようもない「最後の手段」として使うことはあるが,通常は使うべ
きではない.このような手段を多用すると,周りに迷惑であるので,やめていただきたい.
これらが「やってはいけないこと」であることは,TeX でも同様である.TeX で章番号や,
図や表,数式などの参照番号を手入力で行っているのであれば,見直すことが必要である.
-1-
3. 目標
以下の事ができることを今回の目標とする.
(1) 「スタイル」を設定する.
(2) 図表の番号と見出しをつける
(3) 参考文献を設け,本文から参照する.
(4) 改行を設定する.
(5) ページ番号を表示する.
-2-
4. 準備
Word の設定
Word の標準状態では,画面の設定や状態表示など,編集に必要な設定が表示されない
ようになっている.そこで,自分で適切に設定し,それを把握するために,設定の状態を
表示させるようにする必要がある.以下に,設定する主要な項目の表示方法を示す.
(1) ルーラーを表示する
「ルーラー」とは,文書の上部と左部に表示されている「ものさし」のような部分であ
る(図 1).
図 1 ルーラーを表示させた様子
このルーラーを確認することで,どのようなインデント設定になっているのか,把握す
ることができる.また,種々のインデントを設定するときに,ルーラーを操作するために
表示させる必要がある.
ルーラーを表示させる方法は以下の手順による.
(手順1) 「表示」タブを開く.
(手順2) 「表示」欄の「ルーラー」チェックボックスにチェックを入れる.
上部のルーラーでは文書の幅や,段落やインデントなどを設定する.左側のルーラー
では,文書の高さを設定する.
(2) 編集記号を表示する
「編集記号」とは,
「タブ」や「スペース」など,文字情報以外に文章の体裁などを整
えるために用いられる部品を表す記号である.文章を編集するために用いられるため「編
集記号」と呼ぶ.これらを表示させることで,自分が作っている文書の状態を正確に把握
して,思い通りに操作できるようにする.
「編集記号」を表示する方法を以下に示す.
(手順1)
「ファイル」タブを開く.
(手順2)
「オプション」をクリックして Word オプションウィンドウをひらく(図 2).
(手順3)
「表示」メニューの「常に画面に表示する編集記号」にある「すべての編集
-3-
記号を表示する」にチェックを入れる(図 3).
図 2 「ファイル」から「オプション」を選ぶ
図3
Word のオプションウィンドウにて編集記号の表示を設定する
(3) ナビゲーションを表示する
「ナビゲーション」は文章全体の構成を表示する.正しくスタイルが設定されている
-4-
と,見出しが表示されて,文章の章・節などの構成を把握することができる.そのため,
本文表示では分かりにくい全体の構成を把握することができるので,文書のバランスなど
を見ることができる.さらに,章や節のまとまりで移動させることができるので,構成を
編集するときに便利である.次の手順で表示させる.
(手順1) 「表示」タブを開く.
(手順2) 「表示」欄の「ナビゲーション
ウィンドウ」チェックボックスにチェック
を入れる.
フォント
(1) 本文と見出し
文書の読みやすさを高めるために,適切なフォントを選ぶ必要がある.標準として採
用されているスタイルとして,見出しにゴシック体,本文に明朝体を用いる.
ゴシック体
明朝体
ゴシック体の例
明朝体の例
図 4 ゴシック体と明朝体
ゴシック体は,文字の太さが一定であり,黒色が目立つため,文章から見出しだけを
たどるためのフォントとして適している.一方,明朝体は,適度な白黒のバランスから,
本文の文章を構成する文字として適している.
(2) アルファベットと数字
アルファベットと数字については,Time New Roman もしくは Century を使う.おすす
めとしては,Times New Roman である.その理由は,Windows に搭載されているフォント
セットでは,斜体にした時,Century では機械的に斜体に変形させるが,Times New Roman
では,イタリック体のフォントに切り替わるからである.図 5 の例をみると「f」の斜体
表現に大きな違いが表れていることがわかる.
標準
yutaka fujita
yutaka fujita
斜体
yutaka fujita
yutaka fujita
フォント名
Times New Roman
Century
図 5 アルファベットフォント
(3) 等幅フォントとプロポーショナルフォント
等幅フォントは,全ての文字の幅がすべての文字で同じであるが,プロポーショナル
フォントでは,文字によって幅が異なる.
-5-
「プロポーション」は,よく,体の体型,スタイルなどを説明するときなどに用いら
れるのではないだろうか.それと同じで,フォントの形状に応じて幅,1 文字が占有する
幅を調整されたフォントにつけられる.
日本語において通常は,等幅フォントを用いる.
「MS 明朝」と「MS P 明朝」とある
ときには,前者が等幅フォントで後者がプロポーショナルフォントである. 図 6 で見比
べると,アルファベット「i」の幅に,等幅フォントでは他の文字と同じだけの幅が与えら
れているのに対して,プロポーショナルフォントでは,他の文字よりも狭く,文字分の幅
しか与えられていないことが分かる.
アルファベット専用のフォントでは,通常プロポーショナルフォントであり,特に等
幅フォントかプロポーショナルフォントかを考える必要はない.
表示例
MS Gothic
MS P Gothic
種類
等幅フォント
プロポーショナルフォント
フォント名
MS ゴシック
MS P ゴシック
図 6 プロポーショナルフォントの表示
-6-
5. 文書作成
「スタイル」の設定
今回の設定するスタイルとして,以下のようなアウトラインになるように設定する.
1. 章の見出し
1.1 節の見出し
(1)項の見出し
(a)条の見出し
本文はこのような文章からなっているものと仮定します.段落の場合には,字下げ
をします.
スタイルの設定を利用することで,章や節の番号が自動的に振られる.これによって,
途中に章や節を挿入した際も,自動的に振りなおしてくれる.
(1) 「アウトライン」から基準にするリストを選ぶ
既にあるリストを修正して所望のリストを作るために,所望のリストに似ているリス
トを選ぶと楽に設定できる(図 7).
図 7 リストライブラリから選ぶ
(2) 「新しいアウトラインの定義」を選ぶ
選んだリストを変更するために,「新しいアウトラインの定義」を選ぶ.
-7-
図 8 「新しいアウトラインの定義」
(3) 定義したいアウトラインを構成する
「新しいアウトラインの定義」ウィンドウが表示されるので,左下の「オプション」
を開く(図 9).
図 9 「新しいアウトラインの定義」の画面
章のスタイルを設定する
章の番号および見出しのスタイルを設定するために,レベルとして,
「1」を選択する.
-8-
図 10 レベル 1 の設定
「番号書式」を所望の書式に変更する.
「このレベルに使用する番号の種類」から,番
号の種類を選ぶ.今回は,数字を使うので,このままの書式でよい.
さらに,
「レベルと対応付ける見出しスタイル」の設定として選択リストから「見出し
1」を選択する(図 11).これによって,レベル1(章)の見出しにするときには,スタ
イルのリストをクリックすることで,設定することができる.
図 11 スタイルへの反映
節見出しのスタイルを設定する.
節の番号および見出しのスタイルを設定するために,レベルとして,
「2」を選択する.
「番号書式」の部分が所望の形式になるように設定する(図 12).番号書式のグレー色の
背景がついている数字は,自動で付番される部分である.どのレベルの番号を使うか,
「次
のレベルの番号を含める」から,上位のレベルにある番号を選択することができる.
-9-
図 12 節のスタイル設定
項見出しのスタイルを設定する
レベル 3 は標準状態では,図 13 のように設定されているので,「番号書式」を変更す
る.3 件の数字が並んでいるが,1 番目がレベル 1 の章番号を表し,2 番目がレベル 2 の
節番号を表し,3 番目がレベル 3 の番号を表している.
レベル 3 の数字をカッコ書きにして表したいので,3 番目の数字のみを残して削除する.
または,すべて消して,「このレベルに使用する番号の種類」にて表示したい数字を選ぶ
ことで,用いる数字が表示される.
さらに,カッコ書きにするために,数字の前後をカッコで囲む.その結果,図 14 のよ
うに変更する.そのほかの項目も,レベル 1,レベル 2 の時と同様に変更する.
- 10 -
図 13 レベル 3 の設定標準状態
図 14 レベル 3 の設定
条のスタイルを設定する
レベル 4 を選択し,「番号書式」に表示されている上位レベルの番号を削除する.
「こ
のレベルに使用する番号の種類」から,小文字のアルファベットを選択する.番号書式に
表示されたアルファベットをカッコで囲む.
- 11 -
図 15 条の設定
本文のスタイルを設定する
本文の文章では,段落ごとに 1 文字分字下げするスタイルに設定する.そのような設
定になるように,編集画面にてルーラーを設定する.
まずは,本文に文章を書きいれる.次に,段落を構成したい行にカーソルを移動させ
る.その状態で,ルーラーを設定する.下側にある上にとがったマークは 2 行目以降の行
頭の位置を設定する.上側にある下にとがったマークは 1 行目の行頭の位置を設定する(図
16).
(2)上側を字下げの位置に移動
(1)カーソルを置く
I
図 16 段落のルーラー設定
さらに,段落形式による本文のスタイルをクイックスタイルに設定する.ルーラーを
設定した段落に含まれる行にカーソルを合わせて,「スタイル」の「その他」のボタンを
選ぶ(図 17).
- 12 -
図 17
「スタイル」の「その他」を選ぶ
「選択範囲をクイックスタイルとして保存」を選ぶことで,字下げの段落設定を保存
することができる(図 18).
図 18 クイックスタイルに追加する
今回の段落の設定を「章本文」と名前を付けることにするために,
「名前」の欄に「章
本文」と入力する(図 19).
図 19 スタイルに名前を付ける
図表の番号と見出し
図表には「図 2 アンケート結果の比較」などのように.ラベルと番号,見出しをつけ
る.ラベルごとの番号は順番に自動で付番されるように,設定して用いる.これによって,
後から図を挿入したときにも,自動的に番号を振りなおしてくれる.
- 13 -
(1) 図を挿入する
図を挿入する仕方は,画像ファイルであるか,Word 上の図形であるかによって,方法
が複数あるが,ここでは,Excel で作成したグラフを表示するための図の挿入のしかたを
説明する.この方法では,画像ファイルを置くときにも使える.
テキストボックスを挿入する
「挿入」から「テキスト:テキストボックス」
「シンプル-テキストボックス」をクリッ
クする(図 20).
図 20
シンプルテキストボックスを選ぶ
(2) 図の表示方法を設定する
あらわれたテキストボックスをクリックして選択して,
「書式」>「配置:位置」>「行内」を選ぶ.
図 21 「行内」に配置する
一行分として,テキストボックスが配置されるので,そのボックスを文書の幅に合わ
せて調整する.
- 14 -
図 22 テキストボックスを広げる
(3) グラフを張り付ける
グラフは,Excel で作成したものを張り付けることが多いので,通常は Excel から張り
付けるが,今回はグラフを作成する手間を省くため,Word で作成するサンプル図を張り
付けてみることにする.
「挿入タブ」>「図:グラフ」>好きなグラフを選ぶ.
図 23「グラフ」から好きなグラフを選ぶ
Excel の画面が出てきたら,閉じてもよい.簡単なグラフを埋め込むときには,この
Excel 上の数値を変えて,グラフを作ることもできる.実際のレポートには,レポートに
必要なグラフを張り付けてほしい.
- 15 -
図 24 グラフが表示された様子
(4) 図表番号を挿入する
図や表は,本文中から参照されていなければならない.そのため,図や表にはユニー
クな番号をつけなければならない.
テキストボックス内の,図をクリックし,図全体を選択状態にして,右クリックする.
メニューの中から「図表番号の挿入」を選択する.
図 25 「図表番号の挿入」を選ぶ
(5) ラベルを設定する
図であるときには,
「ラベル」項目の右側の▼を押して,
「図」を選ぶ.表の場合には,
「表」を選ぶ(図 27).
また,この中に無いラベルをつけたいときには,
「ラベル名」ボタンを押すと,追加で
きる.例えば,プログラムコードに付けるラベルとして「リスト」を追加したいときには,
のように追加することで,選択リストに「リスト」が追加される(図 26).
- 16 -
図 26 新しいラベルの作成
(6) 見出しをつける
「図表番号」の図*後ろに,図表の見出しをつける.さらに,「位置」を決める.図の
場合には,「選択した項目の下」を選び,表の場合には「選択した項目の上」を選ぶ.
図 27 「図」ラベルを選ぶ
図 28 見出しを入力する
(7) 見出しのフォントを調整する
ここでは,図の見出しをセンタリングにし,ゴシック体にする.見出し 1 行全体を選
択状態にし,太字を解除し(図 29),「MS ゴシック」を選択する(図 30).
(2)
(1)
図 29 見出しのスタイルを設定する(太字解除)
- 17 -
図 30 見出しのフォントを選ぶ
図 31 見出しをセンタリングする
テキストボックスの枠線を選択し,
「書式タブ」>「図形のスタイル」>「図形の枠線」
にて「線なし」を選ぶ(図 32).
図 32 図形の枠線を「線なし」にする
(8) 図表を本文から参照する
図表を掲載する場合には,
「集計結果の傾向を図 3 に示す.
」などのように,本文中で,
図を参照しなければならない.本文中に挿入する「図 3」などの部分は,
「相互参照」を用
いて,自動で参照するようにする.
- 18 -
参照する図表番号を追加したいところにカーソルを置く
「相互参照」を選ぶ
「挿入」>「リンク」>「相互参照」を選ぶ
相互参照の設定をする
「参照する項目」にて「図」や「表」など,設定したラベルから選ぶ(図 33).
「相互参照の文字列」から,どの記述を本文中に表示するかを選ぶ(図 34).おおくの
場合は,「図1」などのように「番号とラベルのみ」を選ぶ.
- 19 -
表 1 「相互参照の文字列」での選択肢の種類
相互参照の文字列
図表番号全体
番号とラベルのみ
説明文のみ
ページ番号
例
図 1 毎月の科目別学習時間
図1
毎月の科目別学習時間
1
図 33 「参照する項目」の選択
図 34 「相互参照の文字列」の選択
参考文献
参考文献の書き方には,複数の方法があるが,参考文献を箇条書きにするシンプルな
方法を紹介する.
(1) 参考文献の見出しを立てる
参考文献のリストを記述するための項目の見出しでは,章と同じレベルの見出しを用
いることが多いが,章番号は表示しない.そのための設定をする.
「参考文献」の章を作る
図 35 「参考文献」の章を作る
- 20 -
章番号を削除する
図 36 章番号を削除する
章番号の空白分ルーラーをずらす
図 37 ルーラーを調整する
(2) 参考文献を追加する
番号ライブラリから[1]のスタイルを選ぶ
図 38 番号ライブラリから選ぶ
- 21 -
図 39 番号が表示された様子
文献情報を書き込む
番号に続いて,文献情報を書き込む.文献情報のスタイルは,文書によって異なるが
ここでは,
「著者」
「タイトル」
「出版社」
「発行年」の順に,全角カンマを区切りとして使
う.例として,表 2 の書籍を参考文献で設定する.
表 2 参考文献の例
著者名
書籍名
出版社
発行年
木下是雄
理科系の作文技術
中央公論新社
1981
阿部圭一
明文術 伝わる日本語の書きかた
NTT 出版
2006
入力すると,図 40 のように表示されていることを確認する.
図 40 文献情報を書き込む
(3) 参考文献を本文から参照する
通常,本文から参考文献を参照するときには,参照元の文章の後ろもしくは,肩に番
号を付ける.そのマナーは書籍や,論文によって異なるが,今回は,肩に乗せる方法を紹
介する.
「相互参照」を選ぶ
肩に乗せたい箇所にカーソルを合わせてから,タブ「参考資料」>「図表」:「相互参
照」をクリックする.
- 22 -
図 41「相互参照」を選ぶ
参照先と番号の表示方法を選ぶ
図 42 相互参照の文字列を指定する
表示された番号を選択する
図 42 の「参照先」にある[1]の項目を選んで,
「挿入」ボタンを押す.すると,図 43
のように参照が文章に現われる.
図 43 番号を選ぶ
「上付き」を選ぶ
上付きにしたい文字を選んだ状態で,
「ホーム」タブ>「フォント:上付き」を選ぶ(図
- 23 -
44).
図 44 上付きを指定する
図 45 上付きに表示された様子
改行を設定する
前の行から間を開けたいときに,空行にて操作する方法をとることは適切とは言えな
い.また,行間を設定したいときがあるので,行間を設定する方法を示す.
(1) 見出し前の間隔をとる
見出し1で設定されている「第 2 章の見出し」が始まる前に,第 1 章との境目がわか
りやすくなるように,間隔をあけたい(図 46).
図 46 間隔を空けたい場所
そこで,
「ホーム」タブ>「段落」:
「行と段落の間隔」>「段落前に間隔を追加」を選
- 24 -
ぶ(図 47).第 2 章の見出しの前に,間隔が設けられた様子がわかる.
図 47 間隔を空ける
(2) 行間を設定する
文章の行間隔を設定するには,設定する段落を選択状態にして,「間隔」を設定する.
「ホーム」タブ>「段落」:「行と段落の間隔」>「行間のオプション」を開くと,図
48 のようなウィンドウが現われるので,
「行間」を「倍数」,
「間隔」を「1.25」にすると,
図 49 のように,元の設定よりも間隔があく.
- 25 -
図 48 行間のオプションの設定
図 49 行間を「倍数」の「1.25」にした時の様子
- 26 -
(3) 表の間隔を詰める
標準の状態では,表を作成すると,表 3 のように表示される.項目が多くなったり,
数値の列挙の場合に 1 セルの上下行の間隔が不要になったりする場合がある.その時には,
間隔を狭める.
表 3 行間調整前の表の状態
項目
OS
ワードプロセッサ
詳細
Windows7 Professional
Microsoft Office Home and Business 2010 Word
表 4 行間調整後の表の状態
項目
OS
ワードプロセッサ
詳細
Windows7 Professional
Microsoft Office Home and Business 2010 Word
(手順1) 表を選択状態にする
(手順2) 「ホーム」タブ>「段落」:「行と段落の間隔」>「行間のオプション」
(手順3) 「1 ページの行数を指定時に文字を行グリッド線に合わせる」のチェックを外
す(図 50).
- 27 -
図 50
行グリッド線への設定を解除する
ページ番号を表示する
「挿入」タブから「ヘッダーとフッター」で「ページ番号」をクリックする.
図 51 「ページ番号」をクリック
- 28 -
図 52 ページ番号のスタイルを選ぶ
印刷状態を確認する
Word の編集画面では,フォントがどのように反映されるか,どのように印刷されるか,
最終的な出力イメージを確認することが困難である.そのため,必ず印刷結果を確認する.
ただし,その都度印刷すると,紙が必要以上に無駄になることがあるため,PDF で出力
して,PDF にて出力状態を確認することをお勧めする.
- 29 -
6. ソースコードの掲載
プログラムリストを含めたいときには,ソースコードをエディタや統合開発環境で編
集していたソースコードを掲載することがある.この時に,ソースコードを適切に掲載す
る方法を紹介する.
ソースコードを掲載するときに,工夫する点は,以下である.

行番号をつける

ソースコードに適したフォントにする

ソースコードを参照する

ソースコード全体を囲う
これらが適用される方法を紹介する.
ソースコードを張り付ける
ソースコードを行番号付きで,ソースコード全体が囲まれた状態で掲載するために,
Excel を使って表を作って,その表を Word の表形式で張り付ける方法を取る.
(1) ソースコードの準備
ソースコードを準備する(図 53).
図 53 ソースコード
(2) タブをスペースに変換する
タブは,セルの区切りとして認識してしまうので,スペースに変換する(図 54).
- 30 -
図 54 エディタでタブから空白に変換
(3) エクセルにコードをペーストする
Excel の B 列にソースコードを張り付ける.見やすいように,B 列の幅を広げる(図
55).
図 55 ソースコードを張り付ける
(4) 行番号を振る
A 列に行番号を振る.1 から順に番号を自動的に振るために,1 と 2 を入れた後,1 と
2 を選択した状態で,オートフィルを使うことで,自動的に行番号を振ってくれる(図 56).
- 31 -
図 56 行番号をオートフィルで入力
(5) Word に張り付ける.
Excel の行番号とソースコードが入力されている範囲を選択し,Word 上に張り付ける
(図 57).
図 57 Word へのペースト
(6) 行間をつめる
表全体を選択した状態で,「段落」の「行間のオプション」を選択する(図 58).
図 58 行間のオプションを設定する
段落の「インデントと行間隔」で,
「1 ページの行数を指定時に文字を行グリッド線に
合わせる」のチェックを外す(図 59).
- 32 -
図 59 間隔を設定する
(7) 行番号を右に寄せる
行番号の桁の位置をそろえるために,右寄せにする(図 60).
図 60 行番号を右にそろえる
(8) コード部分を枠で囲う
コード部分を選択し,「段落」の罫線設定にて,
「外枠」を選ぶ(図 61).
図 61 コードの周りに枠をつける
- 33 -
(9) ソースコードを詰める
ソースコードを左側に合わせる(図 62).
図 62
コードをの左側をそろえて詰める
ソースコードのフォントを設定する
(1) 行番号のフォントを指定する
行番号の列を選んで,行番号のフォントを「Times New Roman」にする(図 63).
図 63 行番号のフォントを指定する
(2) ソースコードのフォントを指定する
ソースコードを選択して,「Source Code Pro」を選択する(図 64).Source Code Pro
は標準ではコンピュータ上にインストールされていないので,あらかじめインストールす
る必要がある.
図 64 コードのフォントを指定する
- 34 -
(3) フォントサイズを指定する
コード,行番号を選択して,9 ポイントに設定する(図 65).
図 65 行番号,コードのフォントサイズを指定する
(4) コードの設定をスタイルに登録する
フォントなどの設定が済んだ,ソースコードを選択する.その状態で,
「スタイル」の
「選択範囲を新しいクイックスタイルとして保存」を選択する(図 66).
図 66 クイックスタイルへの追加
新しいスタイルの名前を入力する(図 67).
図 67 スタイル名の設定
スタイルとして追加されている様子が確認できる.
- 35 -
図 68 スタイルに追加されている様子
ソースコードを参照する
(1) 表を選択する
「リスト」ラベルをつけたい表を選択して,右クリックする.
「図表番号の挿入」を選
択する(図 69).
図 69 見出し追加対象を選択
(2) 見出しをつける
ラベルとして,「リスト」を選択し,見出しを入力する(図 70).
図 70 ラベルの選択と見出しの入力
見出しがついた様子を図 71 に示す.
- 36 -
図 71 見出しが挿入された様子
(3) 本文から参照する
参照するには,参照したい箇所にカーソルを置き,ファイルメニュータブから,図表
の「相互参照」を選択する(図 72).
図 72 相互参照を選ぶ
「参照する項目」から「リスト」を選ぶ(図 73).
図 73 リストのラベルが追加一覧を表示
「図表番号の参照先」から参照したい項目を選ぶ(図 74).
- 37 -
図 74 参照先を選択
「相互参照の文字列」にて「番号とラベルのみ」を選ぶ(図 75).
図 75 参照に表示される文字列を選ぶ
本文に,挿入されている様子が確認できる.参照されている文字列部分では,カーソ
ルを重ねると,グレーの背景で表示される(図 76).
図 76 本文に挿入された参照箇所
- 38 -
- 39 -
7. 便利な使い方
テンプレートとして使う
文書を作成する度に,見出しの設定などを行うことは手間であるので,見出しなどの
設定が済んだ状態から書き出すための「テンプレート」として保存しておくとよい.
図 77 テンプレートとして保存する
テンプレートとして保存しておくと,そのテンプレートファイルを立ち上げると,そ
のテンプレートを作成するときの設定が適用されている.
立ち上がった文書は,新しい文書として立ち上がっているので,所望の場所に保存す
る.
文書の分割
TeX では,input や include コマンドを使って,ほかのファイルを取り込んで,1 件の
文書にまとめ上げることができる.
Word でも,同様のことができる.それは「グループ文書」という機能である.詳しく
は,また次回をご期待いただきたい.
アウトライン
Word の便利な使い方として,アウトライン表示がある.
「表示」タブ>「文書の表示」
:アウトライン
表示になる.
- 40 -
を選択すると(図 78)
,図 79 のような
図 78 「アウトライン」表示を選択
図 79 アウトライン表示
- 41 -
図 80 アウトラインのレベルを指定した様子
- 42 -
8. さいごに
Word は,適した設定にすることによりはじめて使えるようになる.TeX の場合には,
初期の状態が既に十分活用できる範囲にあり,スタイルファイルなどを活用することで,
設定を気にすることなく文書作成に集中することができる.
Word を使う場合は,自分ですべてを設定しなければならないことを踏まえて使わなけ
ればならない.そのような設定を自分で行うつもりがなければ Word を使わず,TeX を使
うべきである.
TeX で作成した文章は,中身がしっかりしていなくても,そこそこしっかり書いてい
るように見え,Word を使った文書よりも 2 割増し(数値に根拠なし)に見えるが,初期
設定の Word で作成した文章は,3 割から 5 割程度低く(数値に根拠なし)見える.
このような,それぞれの特性を理解したうえで,それぞれの場面に適した文書作成環
境を選択してほしい.
9. 準備
本章では,システムに標準では入っていないフォントや機能を追加する方法など,文
書作成を進めるうえで,あらかじめ準備しておくべきことを紹介する.
フォントのインストール
プログラムを表示するフォントとして,「Source Code Pro」を利用することにする.
このフォントは,日本語を含んでいないため,日本語については,他の代替フォントが適
用される点が残念であるが,プログラムを表示するフォントとして,適している.なお,
日本語フォントを含まない点について,解決方法を紹介しているサイトも参考にしてほし
い.
(1) フォントダウンロード
以下のサイトにアクセスする.
https://github.com/adobe-fonts/source-code-pro
- 43 -
下の方にスクロールすると,以下のような記載があるあので,「Latest release」をク
リックする.
「Downloads」のリンクがあるので.
「Source code(zip)」をダウンロードする.
- 44 -
(2) フォントインストール
ダウンロードしたファイルを展開して,
「OTF」というフォルダがあるので,その中身
を選択して,右クリックする.
すると,フォントのインストールが始まる.
- 45 -
インストールが完了すると,フォントを使えることができるようになる.
10. 課題
今日の授業で行った Word での文書の書き方が反映された形式のレポートを提出する.
記述する内容
(1) 文書タイトル,日付,名前,参考文献
(2) 第 1 章
はじめに
今日の授業で学んだことの概要を述べる.
(3) 第 2 章
Word の使い方
図の作成
図を挿入し,図番号を付ける.また.本文から図への参照として,図番号を参照する.
表の作成
表を挿入し,表番号を付ける.また.本文から表への参照として,表番号を参照する.
(4) 第 3 章
まとめ
今日の授業で学んだことをまとめて述べる.今回の授業で新たに得られたことを述べ
る.もし,すでに知っていたことがあれば,どのようなことが既知であったか,述べてみ
よう.
提出
メールにて提出する
宛先:fujita @nagano-nct.ac.jp
題名:電子情報工学基礎(Word)
添付ファイル:Word ファイル
ファイル名:3 ケタの組番号_名前.docx(例:431_藤田悠.docx)
参考文献
[1] 木下是雄,理科系の作文技術,中央公論新社.1981.
[2] 中島 利勝,塚本 真也,知的な科学・技術文章の書き方―実験リポート作成から学術
論文構築まで,コロナ社,1996.
[3] アメリカ心理学会,APA 論文作成マニュアル 第 2 版,医学書院,2011.
バージョン
(1) 2014.5.21
第 1 版作成
- 46 -
(2) 2014.8.19
(3) 2014.11.12
修正
ソースコードの掲載のしかたを追加
(4) 2015.2.14
フォントインストールの方法を掲載
(5) 2015.5.18
フォントの説明を追加,誤字を修正
(6) 2015.5.24
誤字の修正.
(7) 2016.6.16
誤字の修正
- 47 -
Author
Document
Category
Uncategorized
Views
9
File Size
3 011 KB
Tags
1/--pages
Report inappropriate content