close

Enter

Log in using OpenID

RICOH ステレオカメラ用ソフトウェア R-Stereo-GigE

embedDownload
RICOH ステレオカメラ用ソフトウェア
R-Stereo-GigE-Calibration
ユーザーズガイド
RICOH Industrial Solutions Inc.
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
1/18
目次
1.
機能概要 .......................................................................................... 3
1.1
使用環境 ........................................................................................ 3
2. 使用方法 ............................................................................................ 4
3. リファレンス ....................................................................................... 11
3.1 メニューバーについて ............................................................................. 11
3.1.1 ”ファイル”メニュー............................................................................ 11
3.1.1.1 保存データフォルダを選択 ......................................................................................................................... 12
3.1.1.2 カメラのキャリブレーションデータをファイルに保存 ............................................................................... 12
3.1.1.3 カメラのキャリブレーションデータを上書き ............................................................................................ 12
3.1.2 ”表示”メニュー ............................................................................. 12
3.1.2.1 画像 1, 画像 2 .............................................................................................................................................. 12
3.1.2.1.1 メニューバー......................................................................................................................................... 13
3.1.2.1.2 操作パネル ............................................................................................................................................ 14
3.1.2.1.3 ガイド ................................................................................................................................................... 14
3.1.2.1.4 ステータスバー ..................................................................................................................................... 15
3.1.4 ”ヘルプ”メニュー ........................................................................... 15
3.1.4.1 ログ .............................................................................................................................................................. 15
3.1.4.2 バージョン情報............................................................................................................................................ 15
3.2 操作パネルについて ............................................................................... 16
3.2.1 接続 ......................................................................................... 16
3.2.2 キャリブレーション ........................................................................... 16
3.2.3 設定 ......................................................................................... 16
3.2.4 進捗 ......................................................................................... 16
3.3 ステータスバーについて ........................................................................... 17
3.3.1 実行結果 ..................................................................................... 17
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
2/18
1. 機能概要
正しい距離画像を出力するには、ステレオカメラの基準カメラと比較カメラの校正が必要です。ステレオカメラが校正済み
で納品されますが、環境の影響によりカメラが微妙に動いてしまう場合があります。それに伴う距離精度の劣化を防ぐに
は、再校正の実施が必要です。本ソフトウェアと付属キャリブレーションプレートで再校正を実施する事で、距離精度の劣
化を防ぐ事が可能です。
本ソフトウェア「R-Stereo-GigE-Calibration」の主な機能は、以下のとおりです。
・画像表示:
ステレオカメラの基準カメラと比較カメラの輝度画像を表示します。
・カメラキャリブレーションの実施:
カメラキャリブレーション用の画像を撮像してキャリブレーションデータを算出します。
・カメラキャリブレーションデータの管理:
カメラキャリブレーションデータをカメラから PC へダウンロード、または PC からカメラへアップロードします。
1.1 使用環境
本ソフトウェアが正常に動作するには、照明が十分に明るい環境が必要です。但し、キャリブレーションプレート上に
照り返しが発生するとキャリブレーション精度に悪影響が出る可能性があるため、照り返しが発生しない様に照明を
調整してください。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
3/18
2. 使用方法
2.1 「スタート」
「すべてのプログラム」
「R-Stereo-GigE-Package
X.X.X.XX」
「Maintenance」
「Camera
Calibration」
を選択し、R-Stereo-GigE-Calibration を起動して下さい。
2.2 R-Stereo-GigE-Calibration の操作ウィンドウと画像表示ウィンドウが起動します。更に、
「フォルダの参照」ダイ
アログが表示されます。カメラキャリブレーションの中間データファイルの保存用フォルダを選択して「OK」を
クリックしてください。尚、操作ウィンドウと画像表示ウィンドウを別々で動かして、サイズを変更する事が出
来ます。
操作ウィンドウ
画像表示ウィンドウ(比較カメラ)
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
画像表示部ウシンドウ(基準カメラ)
4/18
保存フォルダを選択後、R-Stereo-Camera-Calibration の操作ウィンドウで「選択…」ボタンを押してください。
デバイス選択ダイアログが開くので、IP 設定ボタンを押します。
2.3 IP 設定ダイアログが開くので、ご自分の PC 環境に合わせて、新しい設定の IP アドレスとサブネットマスクを設
定して下さい。設定後、
「適用」ボタンを押して下さい。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
5/18
2.4 ステータスが OK に変われば IP 設定完了です。
「選択」ボタンを押してダイアログを閉じて下さい。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
6/18
2.5 「接続」ボタンを押して下さい。
「切断」ボタンがアクティブになれば接続 OK です。
カメラへ接続すると、新規キャリブレーションが開始されます。指定された中間フォルダに既存データが存在する
場合は上書きされるのでご注意ください。
接続後、カメラが自動的にショット 01 の撮像を開始します。
画像表示ウィンドウにリールタイムで現在のカメラ画像が表示されます。
その他に、色表示の「ガイド」四角が表示されます。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
7/18
2.6 画像上に映るプレートの位置、角度と大きさを見ながら、プレートの縁がガイドの四角と重なる様に、プレート
の位置、角度と距離を調整してください。
画像が正しく撮れたら、次のショットの撮像に進みます。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
8/18
2.7 全ショットが撮れたら、キャリブレーション処理を実行します。
「はい」をクリックしてください。
撮像された画像により、算出されたキャリブレーションデータの精度が良くないと言う警告が表示される場合あ
ります。その場合は、得たキャリブレーションデータを使用しない事をお勧めします。
2.8 次は、キャリブレーション結果をファイルに保存するかに対してお答えください。
キャリブレーション結果をファイルに保存する事をお勧めします。
2.9 最後に、キャリブレーション結果をカメラにアップロードするかお答えください。
アップロードすると、カメラ内部の既存キャリブレーションデータが上書きされます。アップロード後、新しい
キャリブレーションデータが直ぐ反映されます。
上記でキャリブレーションが完了です。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
9/18
2.10 カメラと切断する場合は「切断」ボタンを押して下さい。
操作ウィンドウを閉じると、カメラが自動的に切断されてアプリケーションが終了します。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
10/18
3. リファレンス
操作ウィンドウと画像表示ウィンドウの使用方法について説明します。
メニューバー 3.1 項 参照
操作パネル
接続 3.2.1 項 参照
キャリブレーション 3.2.2 項 参照
設定 3.2.3 項 参照
進捗 3.2.4 項 参照
ステータスバー 3.3 項 参照
3.1 メニューバーについて
3.1.1 ”ファイル”メニュー
3.1.1.1 項 参照
3.1.1.2 項 参照
3.1.1.3 項 参照
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
11/18
3.1.1.1 保存データフォルダを選択
中間データを保存するフォルダを設定します。
キャリブレーションの中間データ(キャリブレーションデータと画像ファイル)が自動的に中間データフォルダに保
存されます。保存フォルダの選択は、カメラに接続されていない時のみに行えます。
3.1.1.2 カメラのキャリブレーションデータをファイルに保存
カメラの内部キャリブレーションデータを PC にダウンロードして指定のファイルに保存します。カメラに接続され
ている時のみに行えます。
3.1.1.3 カメラのキャリブレーションデータを上書き
PC 上のキャリブレーションデータファイルを選択してカメラにアップロードします。カメラ内部の既存のキャリブ
レーションデータが上書きされるのでご注意ください。事前に、既存のキャリブレーションデータを PC にダウンロ
ードする事をお勧めします。本動作は、カメラに接続されている時のみに行えます。
3.1.2 ”表示”メニュー
3.1.2.1 項 参照
3.1.2.1 画像 1, 画像 2
R-Stereo-GigE-Calibration を起動した際に、画像 1, 画像 2 のウィンドウが起動します。
一旦閉じた後に再び表示させたい場合はメニューから選択します。
画像表示ウィンドウで輝度画像が表示されます。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
12/18
メニューバー 3.1.2.1.1 項 参照
操作パネル 3.1.2.1.2 項 参照
ガイド 3.1.2.1.3 項 参照
ステータスバー 3.1.2.1.4 項 参照
3.1.2.1.1 メニューバー
表示画像を保存します。
a)「ファイル」-「画像に名前を付けて保存」を選択します。
b)ダイアログが開くので、保存先とファイル名を指定後、保存ボタンを押して下さい。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
13/18
3.1.2.1.2 操作パネル
3.1.2.1.2.1 画像サイズ調整
「フィット」ボタンを押すと、画像表示ウィンドウサイズに合わせて、画像サイズが自動で調整されます。
3.1.2.1.2.2 拡大・縮小
表示画像の拡大・縮小倍率を調整します。
テキストボックスに値を入力する、または、トラックバーをスライドさせることで、
倍率を調整できます。
3.1.2.1.2.3 平滑化
表示画像を平滑化します。
画像を拡大するとジャギーを除去できていることがわかります。
「平滑化」ボタンを押す度に、OFF/ON が切り替わります。
初期は ON になっています。
3.1.2.1.2.4 表示色
画像の表示色を選択できます。
3.1.2.1.3 ガイド
キャリブレーションプレートの目標位置を表します。
画像上で、キャリブレーションプレートが表示される枠と重なる様に、プレートの位置と距離と角度を調整してく
ださい。
ショット毎に、ガイドが表す目標位置が変わります。また、プレートが基準カメラと比較カメラのガイド両方に同
時に入る様に調整する必要があります。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
14/18
ガイドの色が画像解析結果により変わります。詳しくは 3.2.4 項を参照して下さい。
3.1.2.1.4 ステータスバー
表示画像上にマウスのポインターを移動すると、ステータスバーに XY 座標と画素値が表示されます。
3.1.4 ”ヘルプ”メニュー
3.1.4.1 項 参照
3.1.4.2 項 参照
3.1.4.1 ログ
ログを選択すると、ログ情報が表示されます。
3.1.4.2 バージョン情報
バージョン情報を選択すると、ソフトウェアのバージョン情報が表示されます。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
15/18
3.2 操作パネルについて
3.2.1 接続
詳細は 2.起動方法を参照して下さい。
3.2.2 キャリブレーション
撮像の再開始・停止、表示ショットとキャリブレーションの実行を行えます。
カメラへ接続後、アプリケーションが自動的にショット1の撮像を開始します。キャリブレーションプレートの位
置と角度を調整して、プレート縁が画像上のガイド枠に重なる様にしてください。プレート位置調整中、アプリケ
ーションが自動的に画像を撮って、位置が正しいかどうかを判定します。正しい位置でプレートが撮像された時に、
アプリケーションが自動的に次のショットの撮像に進みます。
画像表示ウィンドウのカメラ画像がリールタイムで表示される時は、キャリブレーション画像の撮像が可能です。
カメラ画像が更新されない時は、撮像が停止されている状態です(既に撮った画像の確認あるいはエラー発生後)。
撮像がエラー発生により停止された場合、
「撮像スタート」ボタンを押す事で撮像を再開始します。または、
「撮像
ストップ」ボタンを押す事で任意のタイミングで撮像を停止する事が出来ます。
「ショットxx」コンボボックスで撮像済みのショットを選択すると、撮像が停止され、既に撮ったショットが表
示されます。「ショットxx」コンボボックスで最も番号の高い、選択可能な項目を選択すると、そのショットの
撮像が自動的に再開始されます。
必要なショット数の画像が正しく撮像されたら、
「キャリブレーション実行」ボタンを押す事でキャリブレーショ
ン処理を実行します。処理完了後、キャリブレーション結果をカメラにアップロードして反映出来ます。
キャリブレーション結果を PC 上のファイルに保存する事も出来ます。
3.2.3 設定
カメラの露光時間(シャッタースピード)は、トラックバーをスライドさせることで、露光時間調整できます。
尚、キャリブレーションプレートが画像上で検出されている時は、露光時間の自動調整が行われます。
3.2.4 進捗
キャリブレーションの進捗具合を表示します。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
16/18
撮像済みショット数
必要ショット数
画像解析結果
進捗インディケータ
画像解析結果:
画像内容により、解析結果は下記の何れかになります:
1. 「検出失敗」:主に下記の時に発生します:
キャリブレーションプレートが基準と比較カメラの画像に完全に映っていない時、
プレートが極端に遠い・近い時、プレートの角度が極端に傾いている時、画像の輝度分布が極端に明るすぎ
る・暗すぎる時、プレート上乱反射が映っている時、プレートが移動中に撮像された時。
対策:プレートが綺麗に画像の真ん中に映っている様にしてください。必要な場合は露光時間を手動で調整し
てください。
2. 「プレートの位置を調整してください」:
プレートが検出されたが、目標位置から離れた所で検出されたので、プレートを目標位置に近づけて下さい。
3. 「検出精度が低い事が検知された」
:
主に、プレートの一部が隠蔽されている時やプレートに乱反射が映っている時に発生します。プレートが綺麗
に映る様に、パタンを隠蔽しない事にご注意ください。照明は、局所的な乱反射が発生しない照明が相応しい
です。プレートの角度の微調整により、乱反射を防ぐ事が可能な場合もあります。
4. 「明るさ自動調整中」
:
露光時間が自動調整されます。プレートが既にガイドの枠内映っている時は、プレートを動かさないでくださ
い。但し、乱反射がプレート上に映っている時に、角度の微調整でプレートの明るさが均等になる様にしてく
ださい。
5. 「OK」:
画像がキャリブレーション処理画像に追加され、次のショットの撮像に進みます。
撮像から解析結果が出るまで1秒程度の遅延があるので、プレートをガイド枠に入れた時に、解析結果が出るまで
にプレートを動かさないでください。
3.3 ステータスバーについて
3.3.1 実行結果
ステータスバー左端に「接続」などを実行した際の結果が表示されます。
正常終了した場合は OK、エラーが発生した場合はその内容が表示されます。
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
17/18
改版履歴(Revision History)
版
Rev
作成年月日
Date
1.00
2015/03/24
改版記事
Changes

備考
Note
新規発行
RICOH Industrial Solutions Inc.
RICOH ステレオカメラ R-Stereo-GigE-Calibration
ユーザーズガイド Rev.1.00
18/18
Author
Document
Category
Uncategorized
Views
6
File Size
1 010 KB
Tags
1/--pages
Report inappropriate content