close

Enter

Log in using OpenID

テンプレートの作成ページ 4 - Tekla User Assistance

embedDownload
Tekla Structures
テンプレートとレポー
トに関するガイド
製品バージョン 21.1
8 月 2015
©2015 Tekla Corporation
目次
1
1.1
テンプレート................................................................................................ 3
テンプレートの作成...........................................................................................................4
HTML 形式のテンプレートの作成................................................................................................. 5
ネストされた製品用のテンプレートの作成................................................................................. 7
鉄筋加工図または解説図のテンプレートの作成 ..................................................................... 10
加工図属性..................................................................................................................................11
テンプレートへのイメージの追加............................................................................................... 12
1.2
1.3
内容タイプ.........................................................................................................................15
テンプレート属性ファイル.............................................................................................17
ユーザー定義のテンプレート属性............................................................................................... 18
ユーザー定義のテンプレート属性の追加..............................................................................20
ユーザー定義のテンプレート属性へのコメントの追加......................................................21
ユーザー定義のテンプレート属性への階層の追加..............................................................22
2
2.1
レポート...................................................................................................... 24
レポートの作成.................................................................................................................25
選択した図面のレポートの作成................................................................................................... 26
ネストされた製品のレポートの作成........................................................................................... 27
2.2
レポートの表示 ................................................................................................................27
レポートの表示方法の定義........................................................................................................... 28
レポートへのタブの追加............................................................................................................... 28
2.3
2.4
レポートの印刷 ................................................................................................................30
レポート設定.....................................................................................................................30
3
テンプレートおよびレポートのヒント.................................................. 32
3.1
3.2
3.3
3.4
3.5
3.6
レポートに含まれているオブジェクトの選択.............................................................32
ログやレポートの表示に役立つショートカット.........................................................33
計算でのテキストタイプの属性の使用.........................................................................34
フィート・インチ単位を使用する場合の値フィールドの内容の変更.....................34
カスタマイズされた日付形式の定義.............................................................................35
製品図またはキャストユニット図のシート番号.........................................................35
4
免責条項...................................................................................................... 37
2
1
テンプレート
テンプレートとは、Tekla Structures に含めることのできるフォームとテーブルの記
述です。グラフィック形式とテキスト形式のテンプレートがあります。グラフィ
ックテンプレートは、テーブル、テキストブロック、図面ヘッダーとして図面に含
めることができます。テキストテンプレートはレポートとして使用できます。テ
ンプレートフィールドの内容は、実行時に、Tekla Structures によって挿入されま
す。
Tekla Structures には、使用可能な標準テンプレートが豊富に用意されています。テ
ンプレートエディタを使用して、既存のテンプレートを変更したり、目的に合った
新しいテンプレートを作成したりできます。グラフィックテンプレート定義のフ
ァイル名には、拡張子.tpl が付けられます。テキストテンプレート定義のファイ
ル名には、拡張子.rpt が付けられます。
例
テンプレートの使用の詳細については、テンプレートエディタのヘルプまたはテン
プレートエディタのユーザーズガイドを参照してください。
テンプレートエディタのヘルプにアクセスするには、テンプレートエディタを開い
て、 [ヘルプ] --> [目次] をクリックします。
ガイドを.pdf 形式で開くには、
「Template Editor User's Guide (テンプレートエディタ
のユーザーズガイド)」をクリックします。
テンプレート
3
参照項目
テンプレートの作成ページ 4
レポートページ 24
テンプレートページ 3
Tables
1.1 テンプレートの作成
テンプレートを作成するには、次のようにします。
1.
[図面とレポート] > [テンプレートエディタ]をクリックします。
2.
テンプレートエディタで、[ファイル] > [新規作成]をクリックします。
3.
テンプレートタイプを選択し、[OK]をクリックします。新しい空のテンプレ
ートが作成されます。
4.
テンプレートに新しい行を追加します。
5.
a.
[挿入] --> [コンポーネント] --> [行]をクリックして、新しい行を追加しま
す。
b.
行の内容タイプを選択して、[OK]をクリックします。
c.
新しい行ごとに手順 a~b を繰り返します。
Tekla Structures データベースから必要なデータを取得できるように、値フィー
ルドを追加します。
a.
[挿入] --> [値フィールド]をクリックします。
b.
行内のフィールドの場所を定義する点をクリックします。
値フィールドの属性を選択するように促す[属性の選択]ダイアログボッ
クスが表示されます。
6.
c.
属性を選択し、[OK]をクリックします。
d.
値フィールドごとに手順 a~c を繰り返します。
テンプレートを保存します。
a.
[ファイル] --> [名前を付けて保存...]をクリックします。
b.
テンプレートフォルダ..\environment\<your_environment>
\template に移動します。
c.
[ファイル名]フィールドにテンプレートの名前を入力します。
d.
[OK]をクリックします。
テンプレート
4
テンプレートの作成
参照項目
テンプレートページ 3
HTML 形式のテンプレートの作成ページ 5
ネストされた製品用のテンプレートの作成ページ 6
鉄筋加工図または解説図のテンプレートの作成ページ 10
テンプレートへのイメージの追加ページ 12
HTML 形式のテンプレートの作成
HTML 形式のテンプレートでは、レイアウト、フォント、およびイメージをより柔
軟に使い分けることができます。HTML 形式の出力を生成するテンプレートはグ
ラフィック形式であり、ファイル名には*.html.rpt の拡張子が付けられます。
HTML 形式のテンプレートを作成するには、次のようにします。
1.
[図面とレポート] > [テンプレートエディタ]をクリックします。
2.
テンプレートエディタで、[ファイル] > [新規作成]をクリックします。
3.
[グラフィックテンプレート]を選択し、[OK]をクリックします。
4.
テンプレートに新しい行を追加します。
5.
a.
[挿入] --> [コンポーネント] --> [行]をクリックして、新しい行を追加しま
す。
b.
行の内容タイプを選択して、[OK]をクリックします。
c.
新しい行ごとに手順 a~b を繰り返します。
Tekla Structures データベースから必要なデータを取得できるように、値フィー
ルドを追加します。
a.
[挿入] --> [値フィールド]をクリックします。
b.
行内のフィールドの場所を定義する点をクリックします。
値フィールドの属性を選択するように促す[属性の選択]ダイアログボッ
クスが表示されます。
6.
c.
属性を選択し、[OK]をクリックします。
d.
値フィールドごとに手順 a~c を繰り返します。
値フィールドごとにヘッダーを追加します。
a.
[挿入] --> [コンポーネント] --> [ヘッダー...]をクリックします。
b.
[挿入] --> [テキスト...]をクリックします。
c.
テンプレートの見出しを入力し、[OK]をクリックします。
d.
点をクリックして、ヘッダー行の中の見出しの位置を定義します。
テンプレート
5
テンプレートの作成
e.
7.
手順 a~d を繰り返して、すべての値フィールドの見出しを作成します。
テンプレートを保存します。
a.
[ファイル] --> [名前を付けて保存...]をクリックします。
b.
テンプレートフォルダ..\environment\<your_environment>
\template に移動します。
c.
[ファイル名]フィールドにテンプレートの名前を入力します。
ファイル名の拡張子は*.html.rpt にします。たとえば、
Part_list.html.rpt のようになります。
d.
[OK]をクリックします。
注 HTML テンプレートにイメージを追加する場合、それらのイメージが..\Program
Files\Tekla Structures\<version>\nt\TplEd\bitmaps フォルダに配置さ
れている必要があります。このフォルダにない場合、HTML 出力にイメージは表示さ
れません。
例
テキストフィールドが含まれているヘッダー
2 つの値フィールドが含まれている行
参照項目
テンプレートページ 3
テンプレートへのイメージの追加ページ 12
テンプレート
6
テンプレートの作成
ネストされた製品用のテンプレートの作成
この例は、ネストされた製品の階層構造を示すテンプレートの生成方法を示してい
ます。 テキストテンプレート内で次の図のようなネストされた製品の構造を作成
します。
テキストテンプレート内でネストされた製品の構造を作成するには、次のようにし
ます。
1.
[図面とレポート] > [テンプレートエディタ]をクリックします。
2.
テンプレートエディタで、[ファイル] > [新規作成]をクリックします。
3.
[テキストテンプレート]を選択し、[OK]をクリックします。
4.
テンプレートに 4 つの新しい行を追加します。
a.
[挿入] --> [コンポーネント] --> [行]をクリックして、新しい行を追加しま
す。
b.
行の内容タイプを選択して、[OK]をクリックします。
1 行目と 3 行目については[製品]内容タイプを選択し、2 行目と 4 行目に
ついては[部材]内容タイプを選択します。
c.
5.
新しい行ごとに手順 a~b を繰り返します。
[並べ替えおよび作画の順序]の下の矢印ボタンを使用して、テンプレートに対
して、ネストされた製品構造を作成します。
a.
2 行目と 3 行目を 1 レベル下に移動します。
b.
4 行目を 2 レベル下に移動します。
これにより、次のような構造が出来上がります。
テンプレート
7
テンプレートの作成
6.
Tekla Structures データベースから必要なデータを取得できるように、値フィー
ルドを追加します。
この例では、製品または部材の位置、番号、および重量を値フィールドとして
追加しています。
a.
[挿入] --> [値フィールド]をクリックします。
b.
行内のフィールドの場所を定義する点をクリックします。
値フィールドの属性を選択するように促す[属性の選択]ダイアログボッ
クスが表示されます。
7.
8.
c.
属性を選択し、[OK]をクリックします。
d.
値フィールドごとに手順 a~c を繰り返します。
テンプレートのレイアウトを変更します。 たとえば、次のように定義します。
a.
印刷レポートにネストされた製品の構造が表示されるようにオブジェク
トを移動します。 これを行うには、移動するオブジェクトを選択し、目
的の位置までドラッグします。
b.
オブジェクトを整列します。これを行うには、整列するオブジェクトをす
べて選択し、右クリックで表示されるポップアップメニューから適切なオ
プションを選択します。たとえば、[整列] --> [右]を選択します。
c.
ヘッダーとフッターを追加します。これを行うには、[挿入] --> [コンポー
ネント] --> [ページヘッダー]および[ページフッター]をクリックし、ヘッ
ダーとフッターに必要な情報を追加します。
テンプレートを保存します。
例
テキストテンプレートとそれを使って作成したレポートの例を次に示します。
テンプレート
8
テンプレートの作成
注 ネストされた製品に対しては、テキストテンプレートと同様の方法でグラフィックテ
ンプレートを作成できます。 グラフィックテンプレートは、プロジェクトや会社の情
報のほか、表の罫線、画像、記号などのグラフィックを表示できる点がテキストテン
プレートと異なっています。
参照項目
テンプレートページ 3
テンプレート
9
テンプレートの作成
鉄筋加工図または解説図のテンプレートの作成
テンプレートエディタを使用して、鉄筋および曲げ溶接金網の鉄筋加工図や解説図
を作成し、鉄筋加工図に表示する情報のタイプを制御できます。
加工図を作成するには、次のようにします。
1.
[図面とレポート] > [テンプレートエディタ]をクリックします。
2.
ファイル --> [新規...] をクリックします。
3.
[グラフィックテンプレート]を選択し、[OK]をクリックします。
4.
[挿入] --> [コンポーネント] --> [行]をクリックして、新しい行を追加します。
5.
行の内容タイプとして[REBAR]または[MESH]を選択します。
6.
Tekla Structures データベースから必要なデータを取得できるように、値フィー
ルドを追加します。
a.
[挿入] --> [値フィールド]をクリックします。
b.
行内のフィールドの場所を定義する点をクリックします。
値フィールドの属性を選択するように促す[属性の選択]ダイアログボッ
クスが表示されます。
7.
c.
属性を選択し、[OK]をクリックします。
d.
値フィールドごとに手順 a~c を繰り返します。
REBAR または MESH 内容タイプ行にグラフィックフィールドを挿入しま
す。
a.
[挿入] --> [グラフィックフィールド...] をクリックします。
b.
マウスをクリックしたままドラッグし、枠を描画します。
8.
グラフィックフィールドをダブルクリックして、[グラフィックフィールドの
プロパティ]ダイアログボックスを開きます。
9.
[自由属性...]をクリックし、[ユーザー]タブに移動します。
10. 必要な加工図属性を追加します。
11. テンプレートを保存します。
テンプレート
10
テンプレートの作成
例
参照項目
加工図属性ページ 11
加工図属性
次の表に、テンプレート内の加工図で使用可能な属性と値を示します。
属性
FontName
デフォルト値
romsim
可能な値
FontSize
2.0
使用可能なフォントサイ
ズ
FontColor
1 (黒)
1=黒
使用可能なテンプレート
フォント
2=赤
3 = 明るい緑
4 =青
5 = シアン
6=黄
7 = マゼンタ
8=茶
9=緑
10 = 紺青
11 = 深緑
12 = オレンジ
13 = グレー
テンプレート
11
テンプレートの作成
属性
RotationAxis
デフォルト値
2
可能な値
0 = ビュー
1 = グローバル Z
2 = ローカル軸
Exaggeration
1
0 = いいえ
1 = はい
EndMark
1
1 = 直線
2 = 半矢印
3 = 全矢印
Dimensions
1
0 = いいえ
1 = はい
BendingRadius
0
0 = いいえ
1 = はい
BendingAngle
1
0 = いいえ
1 = はい
ImageWidth
グラフィックフィールド
の幅の 4 倍。
ピクセル数
ImageHeight
グラフィックフィールド
の高さの 4 倍。
ピクセル数
参照項目
鉄筋加工図または解説図のテンプレートの作成ページ 10
テンプレートへのイメージの追加
グラフィックテンプレートにイメージを追加することができます。 たとえば、図
面に会社のロゴを含めることができます。Tekla Structures のグラフィックテンプ
レートでは、 .bmp、.jpg、.jpeg、.tif、.tiff、および .png のイメージ形
式がサポートされます。
テンプレートにイメージを追加するには、次のようにします。
1.
テンプレートエディタで既存のグラフィックテンプレートを開きます。
2.
テンプレートに新しい行を追加します。
a.
[挿入] --> [コンポーネント] --> [行]をクリックして、新しい行を追加しま
す。
b.
行の内容タイプを選択して、[OK]をクリックします。
テンプレート
12
テンプレートの作成
3.
[挿入] > [ピクチャー]をクリックし、[画像ファイルの選択]ダイアログボックス
を開きます。
ローカルシンボルフォルダが存在する場合は、デフォルトではそのフォルダの
内容が表示されます。 common\symbols フォルダを選択することで、このフ
ォルダの内容を参照できます。 ローカルシンボルフォルダが存在しない場合
は、Tekla Structures に common\symbols フォルダの内容が表示されます。
4.
リストからイメージを選択し、[OK]をクリックします。
5.
マウスをクリックしたままドラッグし、イメージの枠を描画します。
注 •
大きいイメージは、更新に大幅な時間がかかるため追加しないでくださ
い。
•
印刷したものやエクスポートした DWG ファイルのものと、イメージエデ
ィタのものとではイメージの見た目が異なる場合があります。
•
DWG に図面をエクスポートすると、Tekla Structures では DWG ファイル
と同じフォルダにイメージがコピーされます。 何らかの理由でイメージ
が同じフォルダにない場合、DWG にはイメージではなくイメージ名だけ
が空のフレームと一緒に表示されます。
•
環境にローカルシンボルがある場合、ローカルシンボルフォルダも
common\symbols フォルダと共に検索パスに含まれます。 ローカルシ
ンボルフォルダに、common\symbols フォルダと同じ名前のファイルが
含まれている場合は、ローカルシンボルファイルが使用されます。
•
テンプレートに挿入されたイメージを含む図面を開くと、そのイメージ
は、まず、モデルフォルダ内で検索され、次に、現在の環境の\symbols
フォルダ内で検索されます。
•
詳細オプション DXK_SYMBOLPATH を使用して、Tekla Structures が常にイ
メージを検索するフォルダを定義できます。 イメージ用の企業フォルダ
を定義することもできます。
例
以下に、さまざまな環境でのフォルダ構造を示す[画像ファイルの選択]ダイアログ
ボックスの例をいくつか示します。
テンプレート
13
テンプレートの作成
次の例では、Tekla のロゴがテンプレートに追加されています。
参照項目
テンプレート
14
テンプレートの作成
テンプレートページ 3
1.2 内容タイプ
テンプレート内に新しい行を作成する場合、行の内容タイプを選択する必要があり
ます。 内容タイプによって、その行で使用できるテンプレート属性が決まります。
指定可能な内容タイプは以下のとおりです。
内容タイプ
ASSEMBLY
解説
製品および単品のリストを作成します。選択した部材とボ
ルトが使用されている製品がすべてリストに含まれます。
BOLT
ねじとボルトのリストを作成します。 選択した部材に接続
されているボルトがすべてリストに含まれます。
CAST_UNIT
キャストユニットのリストを作成します。
CHAMFER
角処理の長さのリストを作成します。
COMMENT
空白行、またはテキストデータまたは線のみが存在する行
をテンプレートの任意の場所に作成します。
CONNECTION
ジョイントのリストを作成します。
DRAWING
リビジョン履歴情報なしの図面リストを作成します。 レポ
ートおよび含まれている図面に使用します。
HISTORY
モデルの履歴情報を取得するために使用します。この内容
タイプは、PART、REBAR、CONNECTION、および DRAWING
行で使用できます。
この内容タイプで使用できるテンプレート属性は次のとお
りです。
•
TYPE:更新またはナンバリングなど、過去の操作のタイ
プ。
•
USER:変更を行ったユーザー。
•
TIME:変更された時間。
•
COMMENT:[上書き保存]をクリックしたときに入力され
たコメント。
•
REVISION_CODE:[上書き保存]をクリックしたときに
入力されたプロジェクトコード。
HOLE
孔のリストを作成します。
LOAD
荷重のリストを作成します。
LOADGROUP
荷重グループのリストを作成します。
MESH
溶接金網のリストを作成します。
テンプレート
15
内容タイプ
内容タイプ
解説
NUT
ナットのリストを作成します。 選択した部材に関連付けら
れているボルトのナットがすべてリストに含まれます。
PART
孔のリストを作成します。
REBAR
鉄筋のリストを作成します。
REFERENCE_MODEL
参照モデルをリストします。
REFERENCE_OBJECT
参照モデルの参照モデルオブジェクトをリストします。
ユーザー定義情報を持つ参照モデルオブジェクトだけをレ
ポートに表示します。
REVISION
リビジョンマークのリストを作成します。
SIMILAR_ASSEMBLY
類似した部材のリストを作成します。
SIMILAR_CAST_UNIT
この内容タイプを使うには、SIMILAR_*内容タイプの行の
上層に空の(出力から非表示になっている)ASSEMBLY 行、
PART 行、または CAST_UNIT 行が必要です。
SIMILAR_PART
行階層内で SIMILAR_*行内容タイプの下層に行を置くこ
とはできません。
注意: これらは、図面内で使用され、類似したオブジェクト
情報がモデルから収集されます。他のすべての属性情報
は、表示された図面オブジェクトから収集されます。
SINGLE_REBAR
鉄筋グループの個々の鉄筋リストを作成します。
たとえば、テーパー鉄筋グループの個々の鉄筋の長さを取
得するのに使用します。
SINGLE_STRAND
個々のプレストレス緊張材のリストを作成します。
STRAND
プレストレス緊張材のリストを作成します。
STUD
スタッドのリストを作成します。
SURFACING
仕上げ材のリストを作成します。
テンプレート
16
内容タイプ
内容タイプ
SUMMARY
解説
階層で SUMMARY の上部にある行の内容のサマリーを作成
します。
たとえば、PART - SUMMARY 階層を使って、PART 行の内容
のサマリーを作成します。
TASK
タスクのリストを作成します。
WASHER
ワッシャーのリストを作成します。 選択した部材に関連付
けられているボルトのワッシャーがすべてリストに含まれ
ます。
WELD
溶接リストを作成します。
参照項目
テンプレート属性ファイルページ 17
1.3 テンプレート属性ファイル
テンプレート属性はオブジェクトプロパティを表します。テンプレート属性を値
フィールド、式、行ルール内で使用して、必要なデータを Tekla Structures データベ
ースから取得できます。
テンプレートを出力すると、属性は、Tekla Structures により対応するオブジェクト
プロパティの実際の値で置き換えられます。たとえば、属性 WEIGHT をレポートテ
ンプレートに含めた場合、Tekla Structures ではモデルオブジェクトの重量がレポー
トに表示されます。
テンプレート属性は次のファイルに定義されます。
ファイル名
contentattributes.lst
解説
これは、実際の属性定義を格納するすべてのフ
ァイルを含むコンテナファイルです。
INCLUDE 文を使用してファイルを追加しま
す。contentattributes.lst に含まれる
ファイルの順序によって、ファイルの読み取り
順序が定義されます。
Tekla Structures の新しいバージョンをインスト
ールすると、このファイルはインストール中に
テンプレート
17
テンプレート属性ファイル
ファイル名
解説
上書きされます。更新の前に、このファイルの
コピーを必ず作成してください。
通常は、contentattributes.lst を変更す
る必要はありません。管理者以外のユーザー
は変更しないでください。
contentattributes_global.lst このファイルには、プログラムにハードコーデ
ィングされている属性が含まれます。このフ
ァイルは編集しないでください。
contentattributes_userdefine このファイルには、objects.inp ファイルに
d.lst
定義されたものと同じユーザー定義情報が含
まれます。
Tekla Structures の新しいバージョンをインスト
ールすると、このファイルはインストール中に
上書きされます。テンプレートおよびレポー
トで独自の属性を使用するには、このファイル
のコピーを作成し、必要な属性をそのファイル
に追加します。
デフォルトでは、これらのファイルは..\Program Files\Tekla Structures
\<version>\nt\TplEd\settings にありますが、この場所は環境によって異な
る場合があります。
contentattributes.lst ファイルの検索順序は以下のとおりです。
1.
モデルフォルダ
2.
XS_PROJECT により定義されたプロジェクトフォルダ
3.
XS_FIRM により定義された企業フォルダ
4.
XS_TPLED_INI で定義されているフォルダ
5.
XS_TPLED_DIRECTORY/settings で定義されているフォルダ
参照項目
ユーザー定義のテンプレート属性ページ 18
ユーザー定義のテンプレート属性
ユーザー定義のテンプレート属性は、contentattributes_userdefined.lst
ファイルに定義されます。デフォルトでは、部材プロパティダイアログボックスに
表示されるユーザー定義情報のほとんどがこのファイルに含まれます。テンプレ
ートおよびレポートで独自の属性を使用するには、このファイルのコピーを作成
し、必要に応じて名前を変更して、必要な属性をそのファイルに追加します。
テンプレート
18
テンプレート属性ファイル
contentattributes_userdefined.lst ファイルは 2 つのセクションに分か
れています。
•
属性名とデフォルト設定のリスト:
•
内容タイプに割り当てる属性のリスト:
テンプレートエディタ内の行の内容タイプ
テンプレートエディタ内の属性階層
カスタマイズ可能なコメント。ユーザー定義情報ダイアロ
グボックス内のタブ名など
objects.inp ファイルに指定されたものと同じユーザー
定義情報の名前
テンプレート
19
テンプレート属性ファイル
参照項目
ユーザー定義のテンプレート属性の追加ページ 20
ユーザー定義のテンプレート属性へのコメントの追加ページ 21
ユーザー定義のテンプレート属性への階層の追加ページ 22
ユーザー定義のテンプレート属性の追加
次の例は、独自のユーザー定義情報をテンプレートエディタの属性ツリーに追加す
る方法を示しています。
開始する前に、ユーザー定義情報を objects.inp ファイルに追加します。たとえ
ば、MY_ATTRIBUTE という名前の属性を図面のユーザー定義プロパティに追加で
きます。
ユーザー定義情報を属性ツリーに追加するには、次のようにします。
1.
contentattributes_userdefined.lst ファイルをテキストエディタで
開きます。
2.
適切な名前を付けて(MY_contentattributes_userdefined.lst など)、
ファイルを同じフォルダに保存します。
3.
属性名のリストに MY_ATTRIBUTE を追加し、次のように設定を定義します。
4.
内容タイプに割り当てられた属性のリストに MY_ATTRIBUTE を追加します。
objects.inp ファイル内でどのオブジェクトに属性が関連付けられている
かに応じて、内容タイプを選択します。この例では、内容タイプは DRAWING
です。USERDEFINED.<ATTRIBUTE_NAME>の形式で属性を追加します。
テンプレート
20
テンプレート属性ファイル
5.
変更を保存します。
6.
contentattributes.lst ファイルを開きます。
7.
ファイルに次の行を追加します。
[INCLUDE MY_contentattributes_userdefined.lst]
8.
変更を保存します。
属性は、テンプレートエディタの属性ツリー(DRAWING > USERDEFINED の
下)に表示されます。
参照項目
ユーザー定義のテンプレート属性ページ 18
ユーザー定義のテンプレート属性へのコメントの追加
テンプレートエディタの属性ツリーに独自のコメントを追加できます。
コメントを追加するには、次のようにします。
1.
contentattributes_userdefined.lst ファイルのコピーを開きます。
たとえば、MY_contentattributes_userdefined.lst です。 元の
contentattributes_userdefined.lst ファイルは変更しないでくださ
い。
2.
内容タイプに割り当てられている属性のリストを下方向へスクロールします。
3.
属性名の後ろに、引用符で囲んでコメントを追加します。
次に例を示します。
テンプレート
21
テンプレート属性ファイル
4.
変更を保存します。
追加したコメントは、テンプレートエディタ内の属性ツリーに表示されます。
参照項目
ユーザー定義のテンプレート属性ページ 18
ユーザー定義のテンプレート属性への階層の追加
テンプレートエディタの属性ツリーに独自の階層を追加できます。
階層を追加するには、次のようにします。
1.
contentattributes_userdefined.lst ファイルのコピーを開きます。
たとえば、MY_contentattributes_userdefined.lst です。 元の
contentattributes_userdefined.lst ファイルは変更しないでくださ
い。
2.
内容タイプに割り当てられている属性のリストを下方向へスクロールします。
3.
USERDEFINED.と属性名の間に、角括弧で囲んだ階層名を追加します。
次に例を示します。
注 角括弧の後ろと階層の間にピリオドがあることに注意してください。
4.
変更を保存します。
テンプレート
22
テンプレート属性ファイル
新しい階層は、属性ツリー内に次のように表示されます。
WARNING ユーザー定義情報では、大文字と小文字が区別されます。 属性名のどの文字
についても、大文字と小文字を正しく区別しながら入力してください。
参照項目
ユーザー定義のテンプレート属性ページ 18
テンプレート
23
テンプレート属性ファイル
2
レポート
モデルに含まれている情報のレポートを作成できます。たとえば、図面、ボルト、
部材などのリストを出力できます。Tekla Structures によりモデルから直接レポー
トが作成されるため、情報は常に正確です。レポートには、選択した部材の情報だ
けを含めることも、モデル全体の情報を含めることもできます。
Tekla Structures には、標準レポートテンプレートが豊富に用意されています。既存
のレポートテンプレートを変更したり、目的に合った新しいレポートテンプレート
を作成したりするには、テンプレートエディタを使用します。レポートテンプレー
トは、..\ProgramData\Tekla Structures\<version>\environments
\<environment>\system フォルダにあります。レポートテンプレートのファ
イル名拡張子は、.rpt です。
例
レポート
24
テンプレート属性ファイル
テンプレートの使用の詳細については、テンプレートエディタのヘルプまたはテン
プレートエディタのユーザーズガイドを参照してください。
テンプレートエディタのヘルプにアクセスするには、テンプレートエディタを開い
て、 [ヘルプ] --> [目次] をクリックします。
ガイドを.pdf 形式で開くには、
「Template Editor User's Guide (テンプレートエディタ
のユーザーズガイド)」をクリックします。
参照項目
レポートの作成ページ 25
テンプレートページ 3
2.1 レポートの作成
レポートを作成するときに、モデル全体に関連する情報または選択した部材のみに
関連する情報を含めることができます。Tekla Structures では、関連する製品とその
他のオブジェクトが自動的に選択されます。
レポートを作成するには、次のようにします。
1.
モデルを開きます。
2.
必要に応じて、モデルをナンバリングします。
3.
[図面とレポート] --> [レポートの作成...] をクリックします。
4.
リストからレポートテンプレートを選択します。
5.
必要に応じて、[レポートタイトル]の下で、使用するレポートタイトルを入力
します。
6.
必要に応じて、[名前]ボックスに、レポートファイルの新しい名前を入力しま
す。
7.
必要に応じて、[オプション]タブでレポートのオプションを設定します。
8.
モデル全体のレポートを作成する場合以外は、レポートに含める部材を選択し
ます。
9.
次のいずれかの操作を行います。
•
モデル全体のレポートを実行するには、[全部材]をクリックします。
•
選択したモデルオブジェクトのレポートを実行するには、[選択部材]をク
リックします。
ヒン モデルオブジェクトをナンバリングせずにレポートを作成できます。これは、大規
ト
模なマルチユーザーモデルからドラフトレポートを作成する場合に便利です。ナン
バリングが最新でない場合も、Tekla Structures により警告が表示されます。
レポート
25
レポートの作成
参照項目
レポートページ 24
レポート設定ページ 30
選択した図面のレポートの作成ページ 26
ネストされた製品のレポートの作成ページ 26
選択した図面のレポートの作成
開始する前に、レポートに含める部材の図面を作成します。
選択した図面のレポートを作成するには、次のようにします。
1.
モデルを開きます。
2.
[図面とレポート] --> [図面リスト...]をクリックします。
3.
[図面リスト]ダイアログボックスで、レポートに含める図面を選択します。
ヒント 複数の図面を選択するには、Ctrl キーを押しながら、選択する各図
面をクリックします。
4.
[図面とレポート] --> [レポートの作成...]をクリックします。
5.
リストから図面レポートテンプレートを選択します。
たとえば、[drawing_list]や[drawing_issue_rev]を選択します。
6.
必要に応じて、[レポートタイトル]の下で、使用するレポートタイトルを入力
します。
7.
必要に応じて、[名前]ボックスに、レポートファイルの新しい名前を入力しま
す。
8.
必要に応じて、[オプション]タブでレポートのオプションを設定します。
9.
[選択部材]をクリックします。
Tekla Structures では、選択した図面内のすべての部材が自動的に選択されて、
レポートに含まれます。
参照項目
レポート設定ページ 30
レポート
26
レポートの作成
ネストされた製品のレポートの作成
たとえば、製品のリストや、製品に含まれる部材のレポートを作成できます。 レ
ポートテンプレートにネストされた製品構造が含まれる場合、表示または印刷する
レポートに製品の階層が Tekla Structures に表示されます。
ネストされた製品のレポートを作成するには、次のようにします。
1.
モデルを開きます。
2.
レポートに含める製品を選択します。
3.
[図面とレポート] --> [レポートの作成...] をクリックします。
4.
リストから製品レポートテンプレートを選択します。
•
[製品リスト]:製品のリストを作成します。
•
[製品部材リスト]:製品に含まれる部材のレポートを作成します。
5.
必要に応じて、[レポートタイトル]の下で、使用するレポートタイトルを入力
します。
6.
必要に応じて、[名前]ボックスに、レポートファイルの新しい名前を入力しま
す。
7.
必要に応じて、[オプション]タブでレポートのオプションを設定します。
8.
[選択部材]をクリックします。
参照項目
レポート設定ページ 30
2.2 レポートの表示
作成済みのレポートを表示するには、次のようにします。
1.
[図面とレポート] --> [レポートの作成...]をクリックします。
2.
[ブラウズ...]をクリックし、表示するレポートファイルを選択します。
3.
[表示]をクリックして、レポートを表示します。
参照項目
レポートの表示方法の定義ページ 27
レポート
27
レポートの表示
レポートの表示方法の定義
レポートの表示方法を定義できます。たとえば、すべての HTML レポートを Web
ブラウザで開くことができます。デフォルトでは、すべてのレポートは、Tekla
Structures ウィンドウ内の新しいダイアログボックスに表示されます。
レポートの表示方法を定義するには、次のようにします。
1.
特定の種類のレポートファイルを開くために使用するプログラムを定義しま
す。
ヒン これを Windows 7 または Windows Vista で行うには、[コントロールパ
ト
ネル] --> [既定のプログラム] --> [ファイルの種類またはプロトコルの
プログラムへの関連付け]をクリックします。
2.
Tekla Structures では、[図面とレポート] --> [レポートの作成...]をクリックし、
[オプション]タブに移動します。
3.
[レポートの表示方法]リストで、[外部アプリケーション使用]を選択します。
4.
[レポート]ダイアログボックスで、[上書き保存]をクリックします。
参照項目
レポートの表示ページ 27
レポートへのタブの追加
特定の種類のレポートを Microsoft Excel で開くように、Tekla Structures を関連付け
ることができます。そのようなレポートを Microsoft Excel で開く場合、レポートテ
ンプレートの行がセルに適切に分割されない場合があります。これを修正するた
めに、セル間にタブを追加することができます。
レポートにタブを追加するには、次のようにします。
1.
既存のテンプレートファイルを開きます。
2.
テキストと値のフィールドの間に、\t を追加します。次に例を示します。
3.
レポートを保存します。
レポート
28
レポートの表示
Microsoft Excel での出力は、次のようになります。
テキストエディタでの出力は、次のようになります。
ヒ
ン
ト
別の方法として、カンマまたはセミコロンをテキストフィールド間の区切り文字と
して使用することもできます。 ただし、デフォルトの区切り文字はユーザーによっ
て異なる場合があり、一部のテキストエディタで出力を読み取れない場合がありま
す。
参照項目
レポートの表示ページ 27
レポート
29
レポートの印刷
2.3 レポートの印刷
レポートを印刷するには、次のようにします。
1.
2.
以下のいずれかの操作を行います。
•
[図面とレポート] --> [レポートの作成] をクリックし、[印刷]をクリックし
ます。
•
[ファイル] --> [印刷] --> [レポートの印刷] をクリックします。
[ブラウズ]を使用して[ファイルの選択]ダイアログボックスを表示します。こ
のダイアログボックスで、レポートのフォルダとファイル名を指定できます。
デフォルトでは、Tekla Structures がレポートファイル(*.xsr)フィルターを使用
して Tekla Structures レポートのみを表示します。
3.
必要に応じて、印刷設定を変更します。
•
レポートのフォントやフォントスタイルを変更するには、[選択]をクリッ
クします。
このダイアログボックスでは、フォントとフォントスタイルのみを変更す
ることができ、フォントサイズは 12 に固定されます。フォントサイズを
変更するには、作成したレポートをテキストエディタで開いて、レポート
上でフォントサイズを変更する方法もあります。デフォルトのフォント
は、詳細オプション XS_PRINT_REPORT_FONT を使用して変更できます。
•
4.
用紙のサイズや向きなど、プリンタに固有のオプションを設定するには、
[プリンタ設定]をクリックします。
[印刷]をクリックします。
2.4 レポート設定
[レポート]ダイアログボックスを使用して、レポート設定の表示と変更を行いま
す。
オプション
[レポートタイトル]
解説
オプションのレポートタイトル。
3 つまでのレポートタイトルを入力できます。各標準レ
ポートでは、これらのタイトルのうち、必要なものだけ
が使用されます。たとえば、[Assembly_list]レポートでの
フェーズ情報の表示には、[タイトル 1]が使用されます。
[ブラウズ...]
レポートの保存先フォルダを変更するために使用しま
す。 デフォルトでは、レポートは現在のモデルフォルダ
に保存されます。
レポート
30
レポート設定
オプション
[レポートの表示方法]
解説
レポートの表示方法を定義します。
[ダイアログ使用]を選択すると、新しいウィンドウでレポ
ートが表示されます。
[外部アプリケーション使用]を選択すると、関連付けられ
たプログラムでレポートが表示されます。たとえば、す
べての HTML レポートを Web ブラウザで開くことがで
きます。
[レポートを表示する]
レポート作成後にレポートを画面に自動的に表示するか
どうかを定義します。
参照項目
レポートページ 24
レポート
31
レポート設定
3
テンプレートおよびレポートの
ヒント
ここでは、テンプレートとレポートを効果的に使用する上で役立つヒントやコツを
紹介します。
詳細を確認するには、下のリンクをクリックしてください。
•
レポートに含まれているオブジェクトの選択ページ 32
•
ログやレポートの表示に役立つショートカットページ 33
•
計算でのテキストタイプの属性の使用ページ 34
•
フィート・インチ単位を使用する場合の値フィールドの内容の変更ページ
34
•
カスタマイズされた日付形式の定義ページ 35
•
製品図またはキャストユニット図のシート番号ページ 35
3.1 レポートに含まれているオブジェクトの選択
レポートに含まれているオブジェクトを選択するには、そのオブジェクトの
GUID(グローバル一意識別子)を使用します。
レポートに含まれているオブジェクトを選択するには、次のように操作します。
1.
レポートの作成に使用するテンプレートを作成します。
a.
[図面とレポート] --> [テンプレートエディタ...]をクリックします。
b.
テンプレートエディタで、[ファイル] --> [新規]をクリックします。
c.
[テキストテンプレート]を選択し、[OK]をクリックします。
d.
GUID の行を追加します。
•
[挿入] --> [コンポーネント] --> [行]をクリックします。
行の内容タイプを選択して、[OK]をクリックします。
テンプレートおよびレポートのヒント
32
レポートに含まれているオブジェクトの選択
•
[挿入] --> [テキスト]をクリックし、テキスト「guid:」、「Guid:」、
または「GUID:」を入力します。 [OK]をクリックします。
この操作により、モデル内でオブジェクトの選択が可能になります。
•
[挿入] --> [値フィールド]をクリックします。 行内のフィールドの場
所を定義する点をクリックします。 値フィールドの属性を選択する
ように促す[属性の選択]ダイアログボックスが表示されます。
[GUID]属性を選択して、[OK]をクリックします。
e.
その他の必要な行をテンプレートに追加します。
f.
[ファイル]- --> [名前を付けて保存...]をクリックします。 .
テンプレートの名前を入力して、..\environment
\<your_environment>\template フォルダを参照します。 ファイル
名拡張子.rpt を使用します。
2.
保存したレポートテンプレートに基づいてレポートを作成します。
a.
[図面とレポート] --> [レポートの作成...]をクリックします。
b.
作成したレポートテンプレートをリストから選択します。
c.
[すべてから生成]をクリックします。
レポートが表示されます。
3.
レポートの GUID 番号を含む行をクリックします。
アクティブなモデルビューで対応するオブジェクトが選択された状態になり
ます。
参照項目
テンプレートの作成ページ 4
レポートの作成ページ 25
3.2 ログやレポートの表示に役立つショートカット
ログファイルやレポートで項目を表示する際は、以下のショートカットを使用しま
す。
目的
操作
選択したオブジェクトにズーム 1.
する
2.
Z キーを押したままにします。
ID 番号を含む行をクリックします。
アクティブなモデルビュー内の対応するオブジ
ェクトにズームします。
テンプレートおよびレポートのヒント
33
ログやレポートの表示に役立つショートカット
目的
操作
選択したオブジェクトだけが含 1.
まれるように作業領域を調整す
2.
る
F キーを押したままにします。
ID 番号を含む行をクリックします。
アクティブなモデルビュー内の対応するオブジ
ェクトにズームします。
参照項目
レポートの表示ページ 27
3.3 計算でのテキストタイプの属性の使用
テキストを数値形式に変更します。
double(GetValue("ASSEMBLY_TOP_LEVEL"))
計算に適した形式に変更します(double=decimals)。
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
上記のすべてを計算式に追加します。
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
別の例 - 部材のエレベーションの場合
(double(GetValue("TOP_LEVEL"))(double(GetValue("BOTTOM_LEVEL"))))*1000
3.4 フィート・インチ単位を使用する場合の値フィールドの内容
の変更
フィート・インチ単位が使用されているかどうかを確認するための詳細オプション
GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1
多言語テキストの翻訳済み文字列の呼び出し
GetValue("TranslatedText("albl_Diameter_")")
単位の書式設定
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
ルールで上記のすべてを結合します。
テンプレートおよびレポートのヒント
34
計算でのテキストタイプの属性の使用
if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==1 then
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif
3.5 カスタマイズされた日付形式の定義
mid 関数を使用して、年、月、日を検索します。
mid("","","") string, offset, n
年
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
月
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
日
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
ルールで上記のすべてを結合します。
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
3.6 製品図またはキャストユニット図のシート番号
match 関数を使用して、"-" 文字を検索します。
match(GetValue("NAME_BASE"),"*-*")
mid 関数を使用して、"-"の後の文字だけを返します。
mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
ルールで上記のすべてを結合します。
テンプレートおよびレポートのヒント
35
カスタマイズされた日付形式の定義
if (match(GetValue("NAME_BASE"),"*-*"))
then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif
テンプレートおよびレポートのヒント
36
製品図またはキャストユニット図のシート番号
4
免責条項
© 2015 Tekla Corporation and its licensors. All rights reserved.
本ソフトウェアマニュアルは、該当ソフトウェア製品と共に使用する目的で作成さ
れています。 ソフトウェア製品および本ソフトウェアマニュアルの使用は、使用
許諾契約書に準拠するものとします。 使用許諾契約では、ソフトウェア製品およ
び本マニュアルの特定保証の規定、他の保証の放棄、回復可能な損害賠償の限定、
ソフトウェア製品の許可された使用方法の規定、およびソフトウェア製品の認定ユ
ーザーの定義を行います。 本マニュアルに記載されたすべての情報は、使用許諾
契約書に定められた保証の下で提供されます。 重要な義務、適用される制限事項、
および権利制限については、使用許諾契約書を参照してください。 Tekla は、テキ
ストに技術的な誤りや誤植がないことを保証いたしません。 Tekla は、ソフトウェ
アまたはその他の点での変更により、本マニュアルに対して変更および追加を行う
権利を有します。
また、本ソフトウェアマニュアルは、著作権法および国際条約により保護されてい
ます。 本マニュアルまたは本マニュアルの一部を無断で複製、展示、改変、また
は配布した場合、民事および刑事上の厳しい処罰の対象となることがあり、法律で
認められた最大限の範囲まで告訴されます。
Tekla、Tekla Structures、Tekla BIMsight、BIMsight、Tedds、Solve、Fastrak、および
Orion は、欧州連合、米国、およびその他の国における Tekla Corporation の登録商
標または商標です。 Tekla の商標の詳細については、 http://www.tekla.com/teklatrademarks を参照してください。 Trimble は、欧州連合、米国、およびその他の国
における Trimble Navigation Limited の登録商標または商標です。 Trimble の商標の
詳細については、http://www.trimble.com/trademarks.aspx を参照してください。 本マ
ニュアルで言及されているその他の製品名および会社名は、それぞれの所有者の商
標である可能性があります。 第三者の製品または商標についての言及は、明示的
に記載されている場合を除き、Tekla による第三者との提携または第三者による推
奨を意図せず、そのようないかなる提携または推奨も否定するものとします。
本ソフトウェアの一部には、以下の著作権者の著作権物が利用されています。
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved.
EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights reserved.
Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights reserved.
FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.
Teigha © 2003-2014 Open Design Alliance. All rights reserved.
免責条項
37
製品図またはキャストユニット図のシート番号
PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved.
本製品には、Flexera Software LLC とそのライセンサー(存在する場合)が所有する権
利、機密技術、情報、および創作物が含まれています。 本技術の一部または全部
を、Flexera Software LLC からの事前の書面による明示的許可なしに、使用、複製、
出版、配布、表示、改変または転載することはいかなる形態または手段を問わず厳
重に禁止いたします。 Flexera Software LLC によって書面で明示されている場合を
除き、この技術の所有は、禁反言、黙示などによっても、Flexera Software LLC が
所有するあらゆる知的財産権の下、ライセンスまたは権利を一切付与するものでは
ありません。
サードパーティライセンスを確認するには、Tekla Structures に移動し、 ヘルプ -->
[Tekla Structures について] をクリックして、[サードパーティライセンス]ボタンを
クリックします。
本マニュアルに記載されているソフトウェアの構成要素は、複数の特許で保護され
ており、欧州連合およびその他の国における係属中の特許出願である場合がありま
す。 詳細については、http://www.tekla.com/tekla-patents を参照してください。
免責条項
38
製品図またはキャストユニット図のシート番号
Author
Document
Category
Uncategorized
Views
0
File Size
648 KB
Tags
1/--pages
Report inappropriate content