close

Enter

Log in using OpenID

GIMP 入門

embedDownload
GIMP 入門
【GNUGeneral Public License Image Manipulation Program】
GIMP は、画像を編集することができるフリーウェア(ソフト)です。
Photoshop なみの高機能なソフトウェアですが、無料で使えます。
アイソバーコンサルタント
代表
村山一生
プロローグ
GIMP で出来ること
「画像編集」で、どのようなことが出来るのか、画像を利用してご説明していきます。
1:元々の写真
次の写真は、先日雪が降ったときに、何となく撮った写真です。
ところで、この写真・・・雪が青っぽい感じがしませんか?
ホワイトバランス機能などをうまく設定して撮らないと、本来は白いはずの部分が青っ
ぽくなってしまうことがあるそうです。
どうも設定が良くなかったみたいですねぇ。
特にこだわりのない写真であれば、「まぁしょうがないか」で済むんですけれど、子供
の晴れ舞台とか、一生に一度の写真だったなら、そうも行きません。
こんな写真を撮ってしまったら・・・・。
2:青っぽい写真の画像編集
でも、GIMP があれば大丈夫。
青っぽい写真も、より自然な色調に変更することができます。比べてみると、よく分か
るのではないでしょうか。
変更後は(上の右の写真)普通すぎて、つまらなくなった・・・という感じがしないで
もないですけどね。
(必ずしも自然な色であれば、良い写真というわけではありません)
1
3:写真サイズの変更
写真サイズの変更は、「縮小専用」でもできますが、もう少し細部に亘って、画像を見
ながら行いたい場合などは、GIMP を使います。
それでは、単純に縮小してみます。
GIMP を使うと、ブログで使う用途に合わせて、好きなように画像サイズの変更ができ
ます。撮影時のサイズそのまま使うと、一般的なブログの幅にはおさまらないことの方
が多いように思います。
また、逆に画像の拡大もできますが、目が粗くなるので、一般的に拡大することはあり
ません。
4:写真に文字を入れる
GIMP を使うと、写真内に、文字を入れることもできます。
文字を入れることができるわけですから、年賀状用の画像も簡単に作成できます。
お気に入りの写真を、年賀状に使う場合などに便利です。
「文字が機械的で嫌(いや)!」という人も、直接手書きが出来るし、スキャナがあれ
ば、紙に書いた文字を取り込むことも可能です。
5:不要な対象を消す
写真の中に何か不要なものがあれば、削除することもできます。いたって簡単に消せる
左上の枝と電線を消してみました。
2
手馴れた人は、GIMP を使って、有るものを消し、無いものを作るなどを簡単にやって
しまいます。
6:画像で遊ぶ
GIMP を使うと、写真を素材にして、画像遊びもできます。
例えば、フィルタの覆布(おいふ)化を使うと、簡単に次のような画像も作ることがで
きます。
また、GIMP を使って、昔の写真風に白ふち付きにして、陰をつけて立体感のある画像
にすることも簡単にできます。
GIMP を使うと、機能はそろっているので、使い込むほど、イロイロなことができます。
いかがでしょう?ちょっと興味がわいてきましたか?
3
目
次
1.GIMP画面の構成
2.新規作成
3.画像を開く
4.保存
5.選択ツール
6.自由選択(投げ縄)ツール
7.文字ツール
8.webdings
9.日本語入力
10.変換ツール
11.切り抜きツール
12.回転ツール
13.レイヤー
4
1.GIMP画面の構成
2.新規作成
・操作:ツールボックスのファイルメニューから「新規」をクリック
・操作:新規画像作成画面で、ダイアログで幅・高さを設定して
OK をクリックで画像ウィンドウが開きます
5
3.画像を開く
操作:画像ファイルを開くにはツールボックスのファイルメ ニューから
「開く」をクリック
・操作:画像ファイルを GIMP のアイコンへドラッグすると
GIMP が起動してファイルが 開きます
・操作:又は任意の画像を選んで「open」をクリック
6
4.保存
操作:画像ウィンドウの「ファイル」→「保存(別名保存)」
Name に拡張子を付けて「Save」後でまた編集をする時には
GIMP 固有形式の.xcf で保存すると作業中の状態を記録してくれます
完成してから jpg,png,gif として保存
操作:jpeg で保存の場合「画像ウィンドウ中でプレビュー」にチェックを入れ
ると画像を見ながら「品質」を設定できます
注意:何故か時々保存に失敗します
プレビューや GIMP で開くとちゃんと表示されるんですが HTML に貼付け
ると表示されない場合が多々あります
そう言う時はもう一度 GIMP で開いてファイルの保存を「画像の保存」ダ
7
イアログの「Name」入力からやりなおしますとうまくいきます
どうも 1 枚の画像を使い回すとよくそういう事になるようです
5.選択ツール
説明:各ツールは W クリック or ツールボックスをアクティブ&クリックで選び
ます
左より矩形・楕円・投げ縄・ファジー・色によ
る・電脳バサミ・ベジェ(複雑な曲線を、比較的少ないデータで描く方法の一
つ)
①矩形・楕円選択ツール
マウスをドラッグして選択します
選択をやり直すには画像をクリックで解除されます
shift キーを押しながらドラッグすると正方形・正円が選択できます
②操作:shift キーを押しながらドラッグすると
選択領域は+されます
③操作:control キーを押しながらドラッグすると-になります
④操作:shift キー+control キーでは
重なった範囲だけ表示されます
8
6.自由選択(投げ縄)ツール
①(投げ縄)ツール
操作:対象物の輪郭に沿ってドラッグする
最後の部分(終点)は、閉じないと中途半端な選択になります
shift キー(+)や control キー(-)を押しながらドラッグして調節します
②ファジー選択ツール
操作:画像上でクリックするとクリックした位置の近似色の範囲が自動的に選
択できます
③色による選択ツール
操作:画像上でクリックするとクリックした色の近似色の範囲が自動的に選択
できます
ファジー選択と違い、離れた領域も選択されます
9
④電脳バサミ選択ツール
操作:ポイントをクリックしていくと輪郭を自動的に選択してくれます
最後、出発点をクリックで閉じます
囲いの中を w クリックで選択領域になります
10
⑤ベジェ選択ツール
操作:マウスでポイントをクリックしていき最後は、最初のポイントを control
キーを押しながらクリックして閉じます
線をドラッグして曲線をあわせます
選択メニューの「パスから」をクリックで選択領域になります
⑥.クイックマスク
説明:画面全体をマスクして(隠して)選択部分だけ消しゴムや絵筆などでド
ラッグしてマスクを消して範囲を選択します
操作:
この投げ縄ツールなどを使って選択します
11
画像ウィンドウ左下の「クイックマスクの切り替え」ボタンをクリックしま
す
画像の赤色の部分がマスクがかかり隠れた状態です
消しゴムツールか、鉛筆ツールなどでドラッグして細かく修正します
描画色"白色"で選択領域 "黒色"はマスクの領域(隠す部分)になります
修正が終わればマスクボタンをクリックしてマスクを外すと選択領域ができ
ます
12
7.文字ツール
説明:
文字を入力するには、ツールボックスの文字ツールをクリックして画像をク
リックします。
操作:
①色は描画色になります
色は描画色になります
②画像をクリックすると文字エディタが現れます
文字を入力します
改行・スペースなどはそのまま反映されます
ツールオプションでフォントの種類・大きさなど設定できます
「テキストからパスを作成」を押して、画像ウィンドウの「編集」→「パスを
ストローク描画」で文字の縁取りも出来ます
13
文字だけの場合はそのまま保存すればいいのですが
続けて他の作業をする時は画像ウィンドウの「画像」→「画像の統合」をクリ
ックで続けられます
または、ドックの「レイヤー」タブで赤い丸の「新規レイヤー」をクリックし
てレイヤーを作っても OK
14
8.Webdings(Webdings とは、IE: インターネットエクスプローラ 4.0 から
付属のフォントです。)
説明:フォントタブにある「webdings」や「Zapf Dingbats」は半角英数字入力
で簡単に絵文字が描けます
「webdings」の対応は以下のとおりです
ちなみにこの webdings は数値文字参照を打ち込んでも絵文字を表現出来ます
具体的には<font face="webdings">数値文字参照</font>
で数値文字参照は&#041;などです(この見出しに使っています)
Mac の firefox では、きれいに出るんですが、safari では一部表示できません
IE for Mac ではまったくダメです。
Windows の IE ではどうなのかは未確認です。
数値文字参照は Web labo の「Webdings」にあります 。
15
9.日本語入力
説明:日本語を入力するにはテキストエディットなどで入力したのをコピーし
て(「コマンド」キー+c)GIMP の文字エディタにペースト(「control」
キー+v)します
文字を移動するには移動ツールを選択して移動します
文字の上をクリックして周りの点々が黄色から青に変われば移動できます
この指のときにドラッグするとレイヤーが移動します
10.変換ツール
左よりズームイン&ズームアウト・距離と角度を測る・移動・切り抜き
回転・拡大(縮小)・剪断変形・遠近・ミラー
11.切り抜きツール
レイヤーのみの切り抜きです
このツールで切り抜いて保存すると元のサイズのまま保存されます
操作:画像の上で切り抜きたい部分をドラッグします
青い丸の角をドラッグすると範囲を変更出来ます
白い丸の角は移動できます
16
中をクリックで切り抜けます
画像ごと切り抜くには
選択ツールで切り抜く部分を選択して
画像ウィンドウの「画像」→「画像の切り抜き」で OK
17
12.回転ツール
画像を回転させます
操作:画像をクリックして四隅の四角をドラッグします
この時 control キーを押しながらドラッグすると 15°単位で回転しま
す。 ↓ダイアログで角度の設定も行えます
決まれば↓Rotate をクリック
保存すればややこしい線は消えてます
13.レイヤー
説明:レイヤーは透明なシートを重ねたようなもので画像の他の部分に影響を
与えないで操作できるので簡単にいろんな操作がしやすくなります
背景を塗りつぶしツールで塗ります
レイヤータブをクリックして「新規レイヤー」をクリック
新規レイヤーに丸を描きます
18
新規レイヤーを用意して三角を描きます
最後に文字を入力します
レイヤーは 4 つ出来ています
操作:左下の赤い丸が「新規レイヤー」ボタンです
右のゴミ箱をクリックするとアクティブなレイヤーを削除できます
19
1 つのレイヤーを操作してみます
三角を描いたレイヤーをアク
ティブ(クリック)にして下の「レイヤを背面へ」ボタンをクリックまたはレ
イヤーを下にドラッグしても画像は入れ替わります
左の目をクリックして消すと
そのレイヤーは非表示になります
再びクリックすると表示されます
20
レイヤーを選んで「不透明度」
を下げるとそのレイヤーだけ透けます
モードも色々変えられます
「消散」にしてみました
以上
21
Author
Document
Category
Uncategorized
Views
11
File Size
925 KB
Tags
1/--pages
Report inappropriate content