close

Enter

Log in using OpenID

2D グラフの作成

embedDownload
Chapter 3
3
Chapter
2D グラフの作成
サンプルのデータを入力し、実際に
2D グラフを作成してみましょう。
グラフの種類によって編集方法が異なった
り、作成上の注意点があります。
目的のグラフに関するページを見つけさっ
そく始めましょう。
121
ORIGIN6.0
3 - 01
Chapter
2D 棒グラフ
棒グラフの作成方法とその編集方法について解説します。
2D 棒グラフの作成
次に示すサンプルデータから棒グラフを作成します。
サンプルデータ
「作図」メニューから「縦棒グラフ」を選びます。次にようなグラフが作成されます。グラフ
の作成方法は Chapter1-06 の「グラフ作成の基本」を参照してください。
2D 棒グラフのサンプル
122
Chapter 3
2D 棒グラフの編集
棒グラフの任意の棒をダブルクリックします。次に示す「作図の詳細」ダイアログが表示され
ます。
作図の詳細ダイアログ
- グループタブ
この例のようにグラフを作成した場合、データセット B と C の「編集方式」は、
「従属」にな
ります。これは、一方を編集すると他方もそれに応じて編集されるということです。編集され
る項目は、その下の「追加」項目で選びます。ここでは、
「塗り色」だけにチェックが付いて
いますので、一方の塗り色を変更すると他方も変わります。どの色に変更されるかは、
「パター
ン」タブの「塗りつぶし」項目の「塗り色」から「指定色」を選んで現れるプルダウンボック
スの順番に選ばれます。
作図の詳細ダイアログ
- パターンタブ
今、データセット B は、赤です。プルダウンボックスの「赤」の次の色は「緑」になっていま
す。ですから、データセットCは「緑」で表されているのです。ここで、データセットBの「赤」
を「深紅色」に変えてみましょう。するとデータセット C は「黄色」に変わるはずです。
123
ORIGIN6.0
データセット B を「深紅色」に
変更すると、データセット C が
「黄色」に変わる
もう一度、
「作図の詳細」ダイアログの「グループ」タブを開いてください。
「追加」の「境界色」
「境界タイプ」についても同様です。右側にプレビューボックスがありま
すので、これを見ながら確認します。
「境界色」
「境界タイプ」にチェックを付け、
「従属」関
係にします。すると、データセット C の境界線が「赤」の「破線」に変わりました。パターン
タブで確認すると、データセット B の縁(境界)は、色が「黒」で線種は「実線」になっていま
す。プルダウンボックスを開いて、
「指定色」を見ると、
「黒」の次は「赤」
、
「実線」の次は「破
線」になっていることがわかります。
このように、データセットの編集方式が「従属」になっていると、プルダウンボックスの順に
選ばれていきます。追加項目のチェックを外しておくと、同じ属性が選ばれます。
しかし、
プルダウンボックスの並び順で編集したくない場合があります。
このようなときには、
編集方式を「独立」にすると、それぞれのデータセットを個々に編集することができます。
パターン / パターンの色についても同様に「従属」で編集することができます。
さらに、棒グラフでは次の項目についても編集することができます。
棒間の間隔:X データ項目間の棒の間隔
重複:棒の重なり
「作図の詳細」ダイアログボックスで、
「間隔の開け方」タブをクリックします。
棒間の間隔を「50」
、重複を「30」とします。次に編集例を示します。
124
Chapter 3
作図の詳細ダイアログ
同じ大きさのグラフ内で、棒間の間隔を広げると棒が細くなります。
棒間の間隔を「50」
、重複を「30」
としたときの例
?
Hint
上のグラフで、同じ X 値に対応する棒 B と C の間隔を空けるには、重複を負の
値にします。
(新機能)
125
ORIGIN6.0
棒の追加方法
サンプルデータの図に「名古屋」の値を追加します。B(Y)=35.2、C(Y)=12.3 と入力してくださ
い。
データを追加したサンプルデータ
グラフを表示して、
「グラフ操作」メニューから「再スケールして全てを表示」を選びます。グ
ラフは次のようになります。
データを追加した棒グラフ
棒グラフの種類
縦棒グラフの他に横棒グラフ、浮動縦 / 横棒グラフ、積み上げ縦 / 横棒グラフが用意されてい
ます。いずれのグラフを作成する場合でもワークシートへのデータの入力方法は同じです。そ
れぞれのグラフのサンプルを次に示します。
126
Chapter 3
横棒グラフ
積み上げ縦棒グラフ
積み上げ横棒グラフ
積み上げ棒グラフの編集オプションには、棒を重ね合わせる「重複」のオプションはありませ
ん。
127
ORIGIN6.0
横の浮動棒グラフ
縦の浮動棒グラフ
浮動棒グラフについては、次の節で詳しく説明します。
128
Chapter 3
3 - 02
Chapter
2D 浮動棒グラフ
縦 / 横の浮動棒グラフの作成と編集方法について解説します。
浮動棒グラフの作成
浮動棒グラフは積み上げ式の棒グラフと似ています。
次のサンプルデータからグラフを作成し
てみましょう。
サンプルデータ
「作図」メニューの「特殊棒グラフ」から「浮動縦棒グラフ」を選択してください。次のグラ
フが作成されます。
サンプルデータから作成した
グラフ
図からも明らかなように浮動縦棒グラフはワークシートに入力した値を境界値として利用する
ものです。X 変数の隣にあるそれぞれの Y 変数が位置を示す値として使用され、棒値の大きさ
は、隣り合う Y 変数の差になっています。
129
ORIGIN6.0
浮動棒グラフの編集
浮動棒グラフの編集方法は通常の棒グラフと同じです。
任意の棒をダブルクリックしてくださ
い。次に示す「作図の詳細」ダイアログが表示されます。
作図の詳細ダイアログ
このダイアログでは次の内容について編集することができます。
境界線:線種、色、太さ
塗りつぶし:色、パターン、パターンの太さ
棒間の間隔:隣り合う棒の間隔
編集方式: 各データセットを独立して編集するか、従属方式で編集するかを選択
編集方式の項目:編集方式が「従属」の場合の編集項目の選択
棒の編集に関する詳細は Chapter3-01「2D 棒グラフ」の項を参照してください。
浮動横棒グラフ
横棒グラフは X 軸と Y 軸の位置を交換して作成したグラフです。ワークシートを表示したとき
の「作図」メニューの「特殊棒グラフ」から「浮動横棒グラフ」を選択すれば、簡単に作成で
きますが、ここでは先ほど作成したグラフを表示した状態で「グラフ操作」メニューから「X
軸と Y 軸の交換」を選択してください。その時の図を次に示します。
130
Chapter 3
浮動横棒グラフ
ラベルをつける
ワークシートに次のようにラベルとして各データセットの最大値(データセット D の値)を入
力してください。そして、データセット E の属性を「ラベル」にします。
ラベルデータを追加
レイヤアイコンをダブルクリックし、レイヤダイアログでラベルデータdata1-eをレイヤに追
加します。
レイヤダイアログ
131
ORIGIN6.0
グラフに表示されたラベルをダブルクリックし、
データラベル表示のダイアログでラベルの位
置を調整します。
データラベル表示ダイアログ
X 軸の正の方向に 40% オフセットしたときのグラフを次に示します。
ラベルを付けたグラフ
Column
作図の詳細ダイアログが変わりました!
Ver6.0 から作図の詳細ダイアログが変わりました。Ver5.0 までは、ラベルの編集には
「データラベル表示」ダイアログを使って編集していました。Ver6.0 からは、グラフに
関する編集は、すべて「作図の詳細」ダイアログで行うことができます。さらに「作
図の詳細」ダイアログでは、
「適用」ボタンを使えば、ダイアログボックスを閉じずに、
変更内容をグラフに反映させることができます。
132
Chapter 3
3 - 03
Chapter
円グラフ
円グラフの作成方法と編集方法について解説します。円グラフは入力した Y 変数の合計求め、
各 Y 値の示す比率を円上の占める面積として表現します。
ORIGIN6.0 では、3D 円グラフ(パイチャート)を描けるようになりました。2D の円グラフは、3D
円グラフを編集して作成します。また、部分円グラフはメニューから無くなりました。部分円
グラフを描くには、円グラフをレイヤで重ねて作成することになります。
(レイヤについては
Chapter4 を参照してください。
)
円グラフの作成と編集
はじめに次のサンプルデータを用意してください。
サンプルデータ
「作図」メニューから「円グラフ」を選択します。次のグラフが作成されます。
3D 円グラフ
2D 円グラフを作成する
ORIGINで円グラフを作成する
場合は、まず先ほどのような
133
ORIGIN6.0
3D 円グラフを作成する必要があります。この 3D 円グラフに対して、編集を施すことで 2D 円グ
ラフを作成することができます。
3D 円グラフをダブルクリックして、
「作図の詳細」ダイアログを開きます。
「円グラフの形状」タブをクリックして、
「3D 表示」の「視角」に「90」と入力します。
OK を押すと 2D 円グラフが描けます。
2D 円グラフ
ORIGIN6.0 で
は、円グラフを 1 つのグラフとして取り扱っています。2D 円グラフは、3D 円グラフの視点を
変えただけのものです。ですから、ここで作成した 2D 円グラフで編集できる項目は、3D 円グ
ラフと全く同一です。
円グラフの大きさを変更する
円グラフをダブルクリックして、作図の詳細ダイアログボックスを開きます。
「円グラフの形
状」タブで、
「半径/中心位置」項目の「半径の再スケール」を「40」にします。
半径を小さくしてグラフの大きさ
を変更
134
Chapter 3
グラフの大きさを変更するには、レイヤの大きさを変更する方法もあります。円グラフの周り
にある長方形の枠がレイヤです。
レイヤによるグラフの大きさを変更する方法は他のグラフ形
式にも有効です。レイヤの大きさを変更する方法については、Chapter4-03「レイヤの編集」を
参照してください。
数値ラベルの移動
作成した円グラフには自動的に割合を示す値が%で表示されます。数値ラベルの位置を変える
には、単純にラベルをドラックして移動するのが最も簡単な方法です。
この方法ですと、ラベルの位置を自由に決められるメリットはありますが、円グラフからの距
離がまちまちになってしまいます。円からの距離を正確にしたい場合は、
「作図の詳細」ダイ
アログを開き、
「ラベル」タブで「表示位置」の「円周からの距離」を入力します。
作図の詳細ダイアログ
- ラベルタブ
X 変数のラベルを表示する
作図の詳細ダイアログを開き、
「ラベル」タブで、
「表示内容」の「値を表示」にチェックを付
けると各スライスの値が表示され、
「カテゴリーを表示」にチェックを付けると各スライスの
カテゴリー(データセット A(X)の内容)が表示されます。
カテゴリーと値のラベルを
追加表示
135
ORIGIN6.0
スライスの抜き出し
円グラフの一部のデータを強調したい場合に、
そのデータを円グラフから切り離す場合があり
ます。これには、
「作図の詳細」ダイアログの「円グラフの形状」タブで右側にある「スライ
ス」項目の「スライス抜き出し」で抜き出したいデータにチェックをつけます。
ここではデータ B を抜き出します。B にチェックして、
「抜き出し量」を「30」にします。
作図の詳細ダイアログ
- 円グラフの形状
スライスを抜き出した円グラフ
136
Chapter 3
3 - 04
Chapter
面積グラフ
X 軸と線グラフの間の空間を塗りつぶした面積グラフ、及び ORIGIN6.0 から新たに加わった色
付き面積グラフの作成と編集方法について解説します。
面積グラフの作成
はじめに次のサンプルデータを準備してください。
サンプルデータ
「作図」メニューから「面積グラフ」を選択します。次の面積グラフが作成されます。
面積グラフ
!
Attention
面積グラフは折れ線グラフとX軸で囲まれる空白を任意の色で塗りつぶすグラ
フです。面積の計算を自動的に行うものではありません。
137
ORIGIN6.0
面積グラフの編集
面積グラフを編集する際はグラフ上のデータ点をダブルクリックします。
塗りつぶされた面積
部分をダブルクリックしても、編集することはできません。作成したグラフのデータ点(頂点)
をダブルクリックしてみましょう。
作図の詳細ダイアログ
グラフの線タブ
面積を作るデータ線の線種、色、接続の種類、太さを指定できます。
曲線以下の塗りつぶしのチェックを外すと折れ線グラフになります。
シンボルタブ
データ点のシンボルの形状、大きさ、色を指定できます。
ドロップラインタブ
各データ点から X 軸または Y 軸に垂直線または水平線を降ろすことができます。
パターンタブ
塗りつぶしのパターン、色を設定できます。
ここでは、
「グラフの線」タブで「接続線」を「スプライン」にし、
「色」を「赤」にします。
そして、
「シンボル」タブでデータシンボルを正方形の記号(■)にし、
「パターン」タブで「塗
りつぶし」の「塗り色」を「緑」にした例を示します。
編集した面積グラフ
138
Chapter 3
複数の Y 変数から作成される面積グラフ
先ほどのサンプルデータにさらにY変数のデータを追加し、次のようなデータを作成してくだ
さい。
複数の Y 変数を持つサンプル
データ
「作図」メニューから「面積グラフ」を選択します。
複数の Y 変数で作成した
面積グラフ
データセットCはデータセットBをベースラインとして描画され、データセットDはデータセッ
ト C をベースラインとして描画されます。
すべてのデータセットがX軸をベースラインとするように描画するには、これらデータセット
のグループ化を解除します。レイヤアイコンをダブルクリックして、右側のデータセット名を
選択し、非グループ化ボタンを押します。
139
ORIGIN6.0
すべてのデータセットの
ベースラインが X 軸
色付き面積グラフ
ORIGIN6.0 から新たに加わった新しいグラフです。このグラフは 1 つの変数 X に対して、Y デー
タが 2 つ必要になります。次のようなデータを用意してください。
サンプルデータ
Y 列を選択し、
「作図」メニューから「色付き面積グラフ」を選びます。次のようなグラフが作
成されます。
140
Chapter 3
色付き面積グラフ
この図からも分かるように、色付き面積グラフは、A(X)とB(Y)で作成される折れ線グラフから
C(Y)までの間を塗りつぶす面積グラフです。ですから、
「作図の詳細」ダイアログボックスの
「グラフの線」タブで変更できるグラフ線は、B(Y)のグラフ線だけです。
141
ORIGIN6.0
3 - 05
Chapter
株価チャート
株価の高値、安値、終値を表示するためのグラフです。
株価チャートの作図と編集
株価チャートの作成には日付に関するデータ(X 変数)と、株価の高値、安値、終値を次のよう
な形式でワークシートに入力する必要があります。
株価チャートのサンプルデータ
A(X)の属性を「日付」にする
!
ことを忘れずに!!
Attention
「作図」メニューから「株価(Hi-Lo-Cl.)チャート」を選択します。次のグラフが作成されます。
142
Chapter 3
株価チャート
株価チャートの編集に用いるコマンドは、他の 2D グラフと比べ特別なものはありません。通
常の編集方法で、自由に編集できます。
日付の表示方法
X軸の日付の表示方法を「1/2」の形式に変更します。次のダイアログは日付をダブルクリック
すると表示されます。
軸のダイアログボックス
143
ORIGIN6.0
日付の形式を変更
グラフはかなり見やすくなりました。
先のサンプルデータで 99/6/5 と 99/6/6 は入力しませんでした。ORIGIN の X 変数を時間/日付
に設定していましたので、時間間隔を正しく反映したグラフが作成できました。
ラベルの表示
例えば、終値の部分に実際の終値をラベルとして表示させたいときは、次の手順にしたがって
操作します。はじめに次のようにラベルのための列を作成します。
ラベルの列データを追加
ラベル属性を設定した列は、
そのすぐ左隣りにある列のラベルとしてグラフ上に追加表示され
ます。ラベル属性はテキストとして扱われます。
グラフを画面上に表示します。グラフのレイヤアイコンをダブルクリックし、レイヤダイアロ
グで、ラベルを右側にボックスにセットします。
144
Chapter 3
レイヤダイアログ
グラフに追加されたラベルは、データ線と重なって表示されます。任意のラベルをダブルク
リックし、作図の詳細ダイアログを表示します。
作図の詳細ダイアログ
X のオフセットを「50」とします。グラフは次のようになります。
145
ORIGIN6.0
ラベルを編集したグラフ
?
Hint
146
グラフの一番右のラベルが切り取られてしまっている場合には、X 軸をダブル
クリックして、軸のダイアログボックスのスケールタブで、日付の範囲を大き
く(99/6/13 など)しましょう。
Chapter 3
3 - 06
Chapter
2D 散布図
2D グラフの基本である散布図の作成方法と編集方法について解説します。
2D 散布図の作成と編集
散布図はデータの分布状況や相関関係を把握するのに大変便利なグラフです。ORIGINではグラ
フの作成を簡単に行うことができ、さらに自由に編集することができます。
次のサンプルデータを準備してください。
サンプルデータ
「作図」メニューから
「散布図」を選択して次のグラフを作成します。
サンプルデータから作成した
散布図
147
ORIGIN6.0
散布図を作成したら、次に回帰係数を求めてみましょう。
「解析」メニューから「フィット:線
形」を選択します。次のようなグラフとフィッティングの結果を示すウィンドウが作成されま
す。
線形回帰を実行したグラフ
フィッティングの結果
ORIGIN6.0 では、回帰係数などのデータ解析結果はすべて結果ログに表示されます。結果ログ
ウィンドウを閉じるには、標準ツールバーから結果ログボタンを押すか、ショートカットキー
「Alt+2」を押します。再度、表示する場合も同様です。
結果ログボタン
148
Chapter 3
線形回帰を実行したグラフの凡例をダブルクリックします。
テキスト制御ダイアログ
表示されたテキスト制御ダイアログボックスの背景の項目を「背景なし」にします。このよう
に凡例の枠線を消去することができます。
凡例の枠線を消去
散布図に引いた回帰直線の座標データは「LinerFit」というワークシートに表示されます。通
常、非表示になっていますので、プロジェクトエクスプローラから「LinerFit」という名前の
ウィンドウをダブルクリックして開きます。
149
ORIGIN6.0
回帰直線の座標データ
- LinearFit
150
Chapter 3
3 - 07
Chapter
エラーバー
データの誤差や標準偏差を表わすエラーバーの作成方法について解説します。
エラーバーを作成するために2つの方法が用意されています。一つはエラーバーとして利用す
る値が分かっており、それをワークシートに入力して利用する方法、もう一つはワークシート
に入力した観測データから自動的に計算し、その結果をグラフ化するものです。
エラーバーの値が既知の場合
次のようなデータが手元にあるとします。
X
Y
Y 誤差
1
3.5
1.2
2
5.6
2.3
3
9.8
1.1
4
4.6
0.5
5
7.3
0.65
ワークシートに次のように入力します。
サンプルデータ
次にデータセット C の属性を「Y エラーバー」に変更します。データセット名 C(Y)を右クリッ
クして、メニューから「列 XY 属性の設定」の「Y エラーバー」を選びます。
または、データセット名 C(Y)をダブルクリックし、
「ワークシートの列フォーマット」ダイア
ログを表示し、列の設定を Y エラーバーに変更しても構いません。
151
ORIGIN6.0
ワークシートの列フォーマット
ダイアログ
ORIGIN6.0 では、Y エラーバーと X エラーバーを選択できるようになりました。既知の X エラー
バー値を扱う場合には、列のフォーマットで X エラーバーを選んでください。
C 列を Y エラーバーに設定
エラーバーはワークシート中で、対応するY データの右隣に入力する必要があります。入力が
完了したらすべてのデータセットを選択(黒く反転)し、
「作図」メニューから「散布図」を
選択します。
152
Chapter 3
ワークシートデータから作成した
エラーバー図
ワークシートからエラーバーを計算する場合
次のようなデータをワークシートに入力し、散布図を作成します。
サンプルデータ
サンプルデータによる散布図
153
ORIGIN6.0
これに、各データ値を利用したエラーバーを追加する場合は「グラフ操作」メニューから「エ
ラーバーの追加」を選択します。すると、次のエラーバーダイアログが表示されます。
エラーバーダイアログ
エラーバーダイアログではエラーバーとして表示する値を選択します。
データの比率
データ値のある % を一律、エラーバーとして表示します。デフォルトではデータの 5%
をエラーバーとして利用します。OK ボタンを次のようなグラフが作成されます。
データの 5% をエラーバーとする
グラフ
この時、エラーバーの値も自動的にワークシート中に作成されます。その時のワーク
シートは次に示します。
作成されたデータセット
154
Chapter 3
ワークシートからも明らかなように、エラーバーのデータセットとして、データセッ
ト B の 5% に相当する値が自動的に作成されています。
データの標準偏差
データセットから標準偏差を計算し、
その値をエラーバーとしてグラフに表示します。
この時のグラフと作成されるデータセットを次に示します。
グラフの例
作成されたデータセット
データセット B から標準偏差を求めたわけですから、データセット C には一様に同じ
値が入力されます。
このようにして作成したエラーバー図の編集方法について説明します。エラーバーの
スタイルを編集する場合は、エラーバーの腕の部分をダブルクリックします。次のよ
うな「作図の詳細」ダイアログが表示されます。
155
ORIGIN6.0
作図の詳細ダイアログ
シンボルをダブルクリックするとシンボルに関する作図の詳細ダイアログが現れます。
シンボルの形状や色の変更、シンボルから軸への垂線などの設定はここで行います。
156
形式
エラーバーに関する色、線幅、キャップ幅の設定を行います。さらにシンボルを空白
にした場合、その中をエラーバーが貫通するか、否かの設定を行います。
方向
エラーバーの表示方向と X のエラーバー成分の表示をコントロールします。絶対と相
対のチェックボックスの意味は次の通りです。
絶対
正の誤差値を上方向へ
負の誤差値を下方向へ
相対
正の誤差値を 0 へ近づく方向へ
負の誤差値を 0 から遠ざかる方向へ
Chapter 3
3 - 08
Chapter
ヒストグラム
データの統計量をグラフ化するヒストグラムの作成と編集方法について解説します。
ヒストグラムはある一定の間隔で等分された範囲内のデータの分布状況を棒(ビン)を用いて表
現するときに用います。ORIGINでは、単純にヒストグラムを作成するだけでなく、様々な正規
分布曲線の表示も行えます。
ヒストグラムの作成と編集
次のようなサンプルデータを準備します。データの属性はY変数としてください。下図には12
個のデータしか表示されていませんが、0 から 100 までの値を 20 個くらい用意してください。
ヒストグラムデータの一部
「作図」メニューの「統計グラフ」から「ヒストグラム」を選択します。
次のグラフが作成されます。
157
ORIGIN6.0
サンプルデータを使った
ヒストグラム
ORIGIN は、自動的にビンのサイズ、度数を計算し、ヒストグラムを作成します。
計算用のワークシートは、BINn(n は数字)という名前で作成され、非表示になっています。
プロジェクトエクスプローラで BIN1 をダブルクリックして、表示します。
ORIGIN が作成したヒストグラムのビンサイズは、
「10」になっています。
(10 づつ区切られてい
ます。
)
計算用ワークシート
ビンサイズを「5」に変更してみましょう。ヒストグラムの任意の棒をダブルクリックします。
「作図の詳細」ダイアログボックスが現れます。
158
Chapter 3
作図の詳細ダイアログ
「自動ビン化」のチェックを外し、
「ビンサイズ」を「10」から「5」に変更します。
OK ボタンを押すと図のように、ビンサイズが「5」のヒストグラムに変更されます。
ビンサイズ 5 のヒストグラム
その他、
「作図の詳細」ダイアログで、次の項目を変更することができます。
パターンタブ
ヒストグラムのビンの色、パターン、線の太さを設定します。
間隔の空け方タブ
各ビンの間隔を設定できます。通常、ヒストグラムを表す場合には、ビンとビンとの
間の間隔は空けません。ここは、
「0」のままにしておきましょう。
データタブ
ビンのサイズ、表示開始位置、表示終了位置、分布曲線の指定ができます。
表示開始位置をビンの大きさより小さく指定すると、また表示終了位置をビンの大き
さより大きく指定すると、ビンがあっても表示されません。
159
ORIGIN6.0
正規分布曲線の表示とフィッティング
再び、ビンサイズを「10」に戻して、ヒストグラムを表示してください。
作成したヒストグラムに分布曲線を表示させましょう。
ヒストグラムの任意のビンをダブルク
リックして、
「データ」タブの「曲線」の項目で、
「種類」から分布曲線の種類を選びます。こ
こでは、正規曲線を表示させます。
「正規」を選んでください。その下の「スケール」という
項目は、曲線を高さ方向に大きくまたは小さくします。ここでは、100% のままにしておきま
しょう。
「正規」を選ぶと、作図の詳細ダイアログに「グラフの線」というタブが追加されま
す。これは分布曲線に対する設定を行います。線の色、線種、太さを変更することができます。
ここでは、設定を変えずにそのまま OK ボタンを押します。グラフに正規曲線が追加されます。
正規曲線を追加したグラフ
?
Hint
160
スケールを大きくした場合には、軸のスケールも変更する必要があります。
Chapter 3
積上げヒストグラム
積上げヒストグラムは、複数のヒストグラムを描く場合に使用します。各ヒストグラムはレイ
ヤ毎に描かれます。次のようにサンプルデータを 4 セット準備します。データの属性は Y 変数
としてください。0 から 100 までの値 20 個くらいを 4 セット用意してください。
サンプルデータ
B(Y)から E(Y)まですべて選択し、
「作図」メニューの「統計グラフ」から「積上げヒストグラ
ム」を選びます。次のようなグラフが作成されます。
サンプルデータによる
ヒストグラム
ウィンドウの左上を見て分かるように、
各ヒストグラムはレイヤ毎に分かれて表示しています。
ヒストグラムの編集方法や分布曲線を描く方法は、前述の通りです。
161
ORIGIN6.0
3 - 09
Chapter
確率とヒストグラム
ヒストグラムに対する累積確率を示すシンボルを合わせてプロットします。
ヒストグラム+確率グラフの作成と編集
グラフの作成はヒストグラムの項で解説した手順と同じです。その違いは、プロットされるグ
ラフ上に累積確率が同時に示される点です。次のようなサンプルデータを準備します。データ
の属性は Y 変数としてください。下図には 12 個のデータしか表示されていませんが、0 から
100 までの値を 20 個くらい用意してください。
サンプルデータの一部
「作図」メニューの「統計グラフ」から「ヒストグラム+確率」を選択します。次のようなグ
ラフが作成されます。
162
Chapter 3
確率+ヒストグラムのグラフ
グラフがプロットされると同時に結果ログウィンドウとビンの構成に関するワークシートBIN1
が作成されます。結果ログウィンドウには、データの分布に関する統計的な値が、ワークシー
ト BIN1 にはヒストグラムにおける度数データと、同時にグラフ化される累積確率が入力され
ています。通常、ワークシート BIN1 のウィンドウは、開いていません。プロジェクトエクス
プローラを使って開きます。
結果ログウィンドウ
163
ORIGIN6.0
BIN1 ワークシート
画面上のボタン「ガウス関数フィット」をクリックすると、ガウス曲線によるフィッティング
が実行されます。同時に「NLSF1」というワークシートが作成されます。ここには、フィッティ
ングに関するデータが入力されます。
ガウス曲線のフィットを実行した
グラフ
164
Chapter 3
NLSF1 ワークシート
グラフの編集
ヒストグラムに関する編集項目は、
「ヒストグラム」の節で解説したものと全く同じです。
ここでは、累積確率を示すプロットの編集方法を解説します。累積確率を示すプロットを「線
+シンボル」のグラフタイプに変更します。任意のデータ点をダブルクリックし、
「作図の詳
細」ダイアログの左下にある「作図形式」で「線+シンボル」を選択してください。
作図の詳細ダイアログ
165
ORIGIN6.0
累積状態を「線+シンボル」の
グラフで表示
作図のダイアログボックスで「作図形式」が現れない場合は、ダイアログボックスの左側が閉
じられています。ダイアログボックスの左下にある「<<」ボタンをクリックして、
左側を表示させましょう。
作図の詳細ダイアログ
(左側が閉じた状態)
166
Chapter 3
3 - 10
Chapter
ボックスチャート
統計分野で利用されるボックスチャートの作成/編集方法について解説します。
ボックスチャートの作成
はじめに次のサンプルデータを準備してください。
サンプルデータ
実際には、ボックスチャートでは Y 変数だけの値を利用します。B および C のデータセットを
選択し、「作図」メニューの
「統計グラフ」から「ボックスチャート」を選択します。
サンプルデータから作成した
ボックスチャート
ボックスチャートはデータ
167
ORIGIN6.0
セット内のデータの分布状況を調べるためのグラフです。したがって X 変数は利用しません。
グラフが作成されると同時に、ワークシート Bin1 も作成されます。
(正確には、ワークシート
Bin1 が作られてからグラフが作られます。
)
Bin1 ワークシート
ボックスチャートの見方
デフォルトで作成されるボックスチャートは、次のような意味を持っています。これらは、
「作
図の詳細」ダイアログボックスで変更することができます。
1. ボックスとひげについて
ボックスの上下のひげ
データの分布が 5 番目(%)および 95 番目(%)の位置
ボックスの上下の辺
データの分布が 25 番目(%)および 75 番目(%)の位置
ボックスの中の水平線
データの 50 番目(%)の位置
2. シンボルについて
上のシンボル
0 および 1 番目(%)
下のシンボル
99 および 100 番目(%)
中央のシンボル
データの平均値
168
Chapter 3
ボックスチャートの編集
任意のボックスをダブルクリックします。
「作図の詳細」ダイアログが表示されます。
作図の詳細ダイアログ
ダイアログボックスの内容について解説します。
パターンタブ
ボックスの線の色、太さ、ボックス内部の塗りつぶしなどを設定します。
間隔の開け方
ボックス間の間隔を指定します。
ボックスチャート
ボックスの種類、ボックス幅、ボックスやヒゲに関する意味の変更
パーセンタイル
各パーセンタイルで使用されるシンボルの形状、色、大きさを設定します。
グループ
ボックスデータセットを独立して編集するか、従属編集するかを設定します。
グラフを編集してみましょう。
パターンタブで、塗りつぶしのパターンを図のような斜線(中間)にし、ボックスチャートタブ
で、ボックスの範囲を「パーセント 10,25,75,90」にします。
編集したグラフを示します。
169
ORIGIN6.0
編集したボックスチャート
ORIGIN6.0 から加わった新機能について解説します。
ダイアモンドボックス
再度、ボックスをダブルクリックして、作図の詳細ダイアログボックスを開きます。
「ボックスチャート」タブのボックス範囲を「パーセント 25,75」にし、ボックス幅を「60」に
します。そして、その右側にある「ダイアモンドボックス」にチェックをつけます。OK を押し
てグラフを表示します。
170
Chapter 3
ダイアモンドボックスチャート
ダイアモンドの上下の頂点が、それぞれボックスの上下の辺(データの分布が 25 番目(%)およ
び 75 番目(%)の位置)と同じ意味を持っています。先ほど指定したボックスの範囲「パーセン
ト 10,25,75,90」で、ダイアモンドボックスを描くことはできません。
データ点を表示する
次に、ボックスチャートとデータ点を一緒に表示します。
「作図の詳細」ダイアログボックス
を開きます。
「ボックスチャート」タブの「種類」から「点列[左]+ ボックス[右]」を選びます。
点列(ドット)に対するオプションのタブが増えます。
作図の詳細ダイアログ
シンボルタブ
点列(ドット)に使われるシンボルの形状、色、大きさを指定します。
データタブ
点列の種類、ビン化オプション、分布曲線などを指定します。
171
ORIGIN6.0
「シンボル」タブをクリックし、シンボルに塗りつぶしの丸(●)を選びます。
「データ」タブを
クリックし、曲線から「正規」を選んで、OK ボタンを押します。
ボックスチャートにデータ点列と
正規分布曲線を追加
データ点
ここで使用される点列は、Y方向には意味を持っていますが、X方向には意味を持ちま
せん。ですから、
「作図の詳細」ダイアログボックスを使って、位置を左右に揃えるこ
とができます。また、Y 方向を一定に区切って、ヒストグラムのビンとして表すこと
もできます。
点列をヒストグラムにして
表わしたボックスチャート
172
Chapter 3
3 - 11
Chapter
ベクトルグラフ
ベクトルグラフの作成と編集の方法について解説します。ORIGIN6.0 から新たに加わった作成
方法についても解説します。
角度の単位とデータの準備
ベクトルグラフの作成には 4 つのデータセットが必要になります。
このデータの指定方法は、2 つあり、1 つは XYAM(X 座標、Y 座標、角度、大きさ)、もう1つは
XYXY(始点 X 座標、始点 Y 座標、終点 X 座標、終点 Y 座標)で持つことができます。
XYAM でデータを指定する
X 変数と 3 つの Y 変数(3 つのデータセット)を作成します。3 つの Y 変数は、順に Y 座標、角度、
大きさを表しています。
特に 2 つ目の Y 変数「ベクトルの角度」には注意が必要です。ORIGIN ではラジアン、度、グラ
ジアンの 3 種類の角度設定が可能です。ワークシートを表示した状態で、
「ツール」メニュー
の「オプション」を選択し、角度の単位を「度」に設定しましょう。角度の単位を誤ると正確
なグラフを描くことができません。
オプションダイアログで角度を
設定
173
ORIGIN6.0
ワークシートに次のサンプルデータを入力します。
サンプルデータ
グラフの作成
3 列の Y 変数を選択して、
「作図」メニューから「XYAM 型ベクトル」を選択します。次のグラ
フが作成されます。
ベクトルグラフ
ベクトルの角度と大きさのデータはグラフ作成後に変更することができます。
174
Chapter 3
XYXY でデータを指定する
2 つの X 変数と 2 つの Y 変数を作成します。これは、始点 X 座標、始点 Y 座標、終点 X 座標、終
点 Y 座標を表します。新規列を 2 列追加し、C(Y)を X 変数に変更します。
ワークシートに次のサンプルデータを入力します。
サンプルデータ
グラフの作成
すべての列を選択して、
「作図」メニューから「XYXY 型ベクトル」を選択します。次のグラフ
が作成されます。
終点のデータセットは、グラフ作成後に変更できます。
ベクトルグラフ
?
Hint
ワークシートへの入力でどうしても XXYY(A(X1),B(X2),C(Y1),D(Y2))のように
並べなければならない場合、列を選択せずに、
「作図」メニューから「XYXY 型
ベクトル」を選びます。
「作図データの選択」ダイアログボックスが現れます
ので、そこでどの XY が対になるかを指定します。
175
ORIGIN6.0
矢印の編集
矢印を編集する場合は、任意のベクトルをダブルクリックします。次に示す作図の詳細ダイア
ログが表示されます。
XYAM 型ベクトルの作図の詳細
ダイアログ
XYXY 型ベクトルの作図の詳細
ダイアログ
XYAM 型ベクトルの編集項目
グラフの線タブ
各ベクトルの X 座標と Y 座標を線で結び、その線の属性(線種、色、太さ)を変更でき
ます。通常は、
「線なし」にしておきます。
ベクトルタブ
ベクトルの色、ベクトル線の太さ、矢先の形状(長さ、角度、塗りつぶし)、ベクトル
に対する XY 座標の位置、角度と大きさの指定
176
Chapter 3
XYXY 型ベクトルの編集項目
グラフの線タブ
各ベクトルの X 座標と Y 座標を線で結び、その線の属性(線種、色、太さ)を変更でき
ます。通常は、
「線なし」にしておきます。
ベクトルタブ
ベクトルの色、ベクトル線の太さ、矢先の形状(長さ、角度、塗りつぶし)、終点座標
の指定
どちらのベクトルグラフでも構いませんから、次のように編集してみましょう。
「ベクトル」タブから「太さ」を「2」
、
「矢先形状」の「角度」を「60」
、
「開ける」にチェック
します。
編集したベクトルグラフ
!
Attention
ベクトル線を太くすると矢先形状で「開ける」にしても、線が太すぎて塗り
つぶされて見えることがあります。矢先形状で「開ける」にする場合、ベク
トル線をあまり太くしないように注意が必要です。
177
ORIGIN6.0
3 - 12
Chapter
関数グラフ
ORIGINには数式から直接グラフを作成する機能があります。ここでは2次元の関数グラフの追
加機能について説明します。
「ツール」メニューの「オプション」を選択し、数値の表現形式
で角度の単位が「ラジアン」になっていることを確認してください。
ORIGIN のワークシートが表示されている状態で、
「ファイル」メニューの「新規」を選択して
新しいグラフウィンドウを作成してください。
(標準ツールバーの「新グラフウィンドウ」ボタ
ンを押しても構いません。
)
新しいグラフシートを作成する
新グラフウィンドウボタン
新しい空のグラフウィンドウが作成できたら、次に関数を入力するダイアログを表示します。
「グラフ操作」メニューから「関数グラフの追加」を選択してください。表示されたダイアロ
グに次の式を入力してください。
入力する数式:2*sin(2*x)+4*cos(5*x)+10
作図の詳細ダイアログ
- 関数
178
Chapter 3
OK ボタンを押すと次のようなグラフを作成することができます。
関数を用いて作成したグラフ
Y 軸をダブルクリックして、
「スケール」タブから Y 軸の最大値を「25」にしています。
この様にして、関数を用いて自由にグラフを作成することができます。関数式は作成された順
番に F1、F2、F3.... という名前がつきます。関数式をグラフ化するために計算されたデータ
値を利用する場合は、
「作図の詳細」のダイアログボックスで「ワークシート」ボタンをクリッ
クします。画面上にデータセット名を確認するダイアログが表示されます。
新しいデータセット名の確認
ダイアログ
データセットの名前を決めたら、OK ボタンをクリックしてください。データセットを元にし
た「FuncCopy」というグラフが作成されます。目的のデータセットは、このグラフ上の曲線を
ダブルクリックし、表示される「作図の詳細」ダイアログの「ワークシート」ボタンをクリッ
クすると表示されます。
179
ORIGIN6.0
計算によって得られた
データセット
180
Chapter 3
3 - 13
Chapter
QC チャート
QC チャートの作成および編集方法について解説します。ORIGIN の QC チャートは、XbarR 管理
図を作成します。
データの準備
QC チャートのデータは X,Y などの属性を気にすることなく入力できます。
データだけを A(X)に 1 列で入力しても構いませんし、A(X)にグループ番号を入力し、B(Y)に
データを入力しても構いません。
次のようなデータを準備してください。
サンプルデータの一部
- データのみ
サンプルデータの一部
- グループ番号付き
181
ORIGIN6.0
QC チャートの作成
グラフ化するデータ列を選択し、
「作図」メニューの「統計グラフ」から「QC チャート」を選
択します。サブグループ数を決めるための QC テーブルダイアログが表示されます。
QC テーブルダイアログ
ここではサブグループを 3 とします。サブグループを 3 とすると、データセットに入力した値
は上から順番に3つ一組のサブグループとなります。3と入力し、OKボタンをクリックします。
次のようなグラフが作成されます。
サンプルデータから作成した
QC チャート
QC チャートの編集
QC チャートは 2 つのレイヤで構成されます。画面の上側に表示される散布図(平均値からの垂
線あり)はXバー管理図です。下側がR管理図になっています。これらそれぞれをダブルクリッ
クし、
「線 + シンボル」のグラフに変更します。
「作図の詳細」ダイアログの「作図形式」から「線+シンボル」を選びます。
182
Chapter 3
作図の詳細ダイアログ
グラフスタイルを変更
QC チャートの右側に表示されている表「QC チャート(XbarR)」をこの画面上で編集することは
できません。変更する必要があれば、プロジェクトエクスプローラから QCn という名前が付い
たワークシートをダブルクリックして開き、このワークシート内で行います。QC ワークシー
トには、1 つのサブグループ毎に計算された平均、範囲、シグマの結果が 1 行になって入力さ
れています。
183
ORIGIN6.0
ここで値を変更し、
「QC チャートの作成」ボタンを押します。
QC チャートの表
複数のデータセットを利用する
複数のデータセットから QC チャートを作成する場合は、グラフ化したいデータセット範囲を
選択し、
「作図」メニューの「統計グラフ」から「QC チャート」を作成します。
複数のデータセットを選択
次のようなダイアログが表示され、行ごとにデータをグループ化することを確認します。
184
Chapter 3
注目ダイアログ
ワークシートには1データセットにつき、13 個のデータを入力しましたので、サブグループ
の数は 13 個となります。そして次のようなグラフが作成されます。
3列のデータセットから作成した
QC チャート
?
Hint
サブグループは、
1つのデータ点を表すために使用されるデータグループです。
ORIGIN では、データが 1 列の場合は、入力したデータグループ数でデータを区
切ってグラフ化し、複数データセットの場合は、1 行をサブグループとして計
算します。
185
ORIGIN6.0
3 - 14
Chapter
三点グラフ
三点グラフの作成と編集の方法について解説します。
サンプルデータの準備
三点グラフは XYZ の 3 つのデータセットの値を 0 から 1 までの比率で表現するためのグラフで
す。ワークシートにはこの例のように観測した値をそのまま入力しても、自動的に比率(百分
率)に計算しなおしてプロットします。C 列をZ変数にして、ワークシートに次のようなデータ
を入力します。
サンプルデータ
グラフの作成と編集
サンプルデータの C(Z)を選択し、
「作図」メニューから「三点グラフ」を選択します。すぐに
次のような三点グラフが作成されます。
三点グラフ
186
Chapter 3
図からも明らかなように XYZ 軸の範囲は 0 から 1 となっており、入力したデータを百分比に変
換したことがわかります。軸や軸ラベルをダブルクリックしても、何のダイアログを表示させ
ることもできません。軸の範囲を変更するには、グラフを表示した状態で、
「フォーマット」メ
ニューの「軸スケール」から各軸を選びます。各軸の設定ダイアログが現れます。
「データシンボル」
、
「データシンボルから各軸への垂線」
、「軸タイトル」に関しては、グラフ
上の各オブジェクトをダブルクリックして編集できます。任意のデータシンボルをダブルク
リックして、丸いシンボル(●)に変更し、Y 軸と平行の Z 軸への垂線を描きましょう。
シンボルを変更し、Z 軸への
垂線を持つ三点グラフ
?
Hint
ここで作成した三点グラフは正三角形ではありません。これを正三角形で表示
するには、
「フォーマット」メニューの「作図の詳細(レイヤ)」を選び、
「レイ
ヤの大きさ・描画スピード」タブの「レイヤ領域」項目で、単位を「cm」や「mm」
に変えてから、
「幅」と「高さ」を同じにします。
187
ORIGIN6.0
3 - 15
Chapter
極線グラフ
原点からの距離とその角度によって座標位置を示す極線グラフの作成および編集方法について
解説します。
極線グラフを作成する場合は、まず ORIGIN の角度単位を確認しておきましょう。ワークシー
トを表示した状態で「ツール」メニューから「オプション」を選択します。
「オプション」ダ
イアログの「数値の表現形式」タブで設定されている角度の単位を「度」にします。
オプションダイアログ
次のようなデータを
ワークシートに入力して下さい。
サンプルデータ
188
Chapter 3
極線グラフに利用する角度は X 変数に、原点からの距離は Y 変数として入力します。用意がで
きたところで、
「作図」メニューから「極線グラフ」を選択してください。次のようなグラフ
ができます。
極線グラフのサンプル
極線グラフの編集
グラフの上側に「角度の範囲」というボタンがあります。
角度の範囲オプション
これをクリックすると極線グラフで表示されている円の表示領域を調整することができます。
このボタンをクリックしてください。次のダイアログが表示されます。
角度の領域ダイアログ
189
ORIGIN6.0
ここでは表示領域の最大値を 120 としてください。次のようなグラフになります。
限定された領域だけがグラフとして表示されています。
元の状態に戻す場合は先ほどのダイア
ログで最後の角度を「360」としてください。
始点の位置
角度の始点と座標の方向を決めます。デフォルトでは図のように時計の3時に相当する位置が
0 となり、反時計回りにグラフは作成されます。次のボタンをクリックすれば、時計の 12 時に
相当する位置を 0 として時計回りのグラフになります。
始点の位置を変更するボタン
半径の選択
「0 からの修正」は円の原点からの距離をグラフ上にプロットします。それに対し、
「Y 軸値の
使用」とはグラフ上の左に表示されている Y 軸上の値に対応して、座標をプロットします。
半径の選択
190
Chapter 3
グリッド線
中心から円の外側に向けて引かれている直線(放射状の直線)はX軸のグリッド線です。編集す
る場合は、これをダブルクリックするか、
「フォーマット」メニューの「軸スケール」から「X
軸」を選択し、次のダイアログを表示します。
軸ダイアログ
X 軸ダイアログ
グリッド線タブをクリックし、副グリッド線のチェックを外します。
副グリッド線のチェックを外した
グラフ
これに対し、グラフの内部で同心円上に描かれている円がY 軸のグリッド線です。これを編集
する場合は、X 軸と同じ方法でダイアログを表示することもできますが、画面上の左端に存在
191
ORIGIN6.0
する Y 軸をダブルクリックして表示させることもできます。Y 軸の副グリッドのチェックを外
してみましょう。次にその時の図を示します。
Y軸の副グリッドを外したグラフ
192
Chapter 3
3 - 16
Chapter
その他の 2D グラフ
メニューやグラフツールバーを見ると、
今まで解説したグラフ以外にもたくさんのグラフがあ
ります。この節ではこれらのグラフを紹介します。これらのグラフは、今まで解説したグラフ
を基本として、
「作図の詳細」ダイアログから設定を変えるだけで、作れるものです。
ですから、
ここでは詳細な解説は抜きにして、
メニューを選択するとどのようなグラフが描け、
基本のグラフからどのように作成するのかを説明します。
特殊ライン
このメニューにあるのは、基本的に「線 + シンボル」のタイプのグラフを拡張して作成される
ものです。
垂直ドロップライン
図のようなデータを用意します。
サンプルデータ
「作図」メニューの「特殊ライン」から「垂直ドロップライン」を選びます。次のよう
なグラフができます。
垂直ドロップライン
このグラフは、
「散布図」を描き、
「作図の詳細」ダイアログの「ドロップライン」タ
ブを使って、垂直線を降ろしたものです。
193
ORIGIN6.0
二点線分/三点線分
先ほど使用したデータを使います。
「作図」メニューの「特殊ライン」から「二点線
分」を選びます。次のようなグラフができます。同様に「三点線分」も作成します。
二点線分
三点線分
図を見て分かるように、データセットの先頭から 2 つまたは 3 つずつ線で結んだグラ
フです。
このグラフは、
「線 + シンボル」グラフの「作図の詳細」ダイアログで、
「グラフの線」
タブを選び、接続線を「2 点線分」または「3 点線分」にしたものです。
194
Chapter 3
垂直階段/水平階段
先ほど使用したデータを使います。
「作図」メニューの「特殊ライン」から「垂直階
段」を選びます。次のようなグラフができます。同様に「水平階段」も作成します。
垂直階段
水平階段
このグラフは、
「折れ線」グラフの「作図の詳細」ダイアログで、
「グラフの線」タブ
を選び、接続線を「垂直階段」または「水平階段」にしたものです。
195
ORIGIN6.0
スプライン
先ほど使用したデータを使います。
「作図」メニューの「特殊ライン」から「スプライ
ン」を選びます。次のようなグラフができます。
スプライン
このグラフは、
「線 + シンボル」グラフの「作図の詳細」ダイアログで、
「グラフの線」
タブを選び、接続線を「スプライン」にしたものです。
二重 Y 軸グラフ
次のようなデータセットを用意してください。2 つの Y 変数列を選択し、
「作図」メ
ニューの「特殊ライン」から「二重 Y 軸グラフ」を選びます。次のようなグラフがで
きます。
サンプルデータ
196
Chapter 3
二重 Y 軸グラフ
このグラフは、
「線 + シンボル」グラフをレイヤを使って 2 つ描いています。
線系グラフ
「二重 Y 軸グラフ」で使用したデータを使います。このグラフを描くには、Y データは
2 または 3 つ必要です。
(3 つ以上では描けません。
) 「作図」メニューの「特殊ライン」
から「線系グラフ」を選びます。次のようなグラフができます。
線系グラフ
このグラフは、
「線 + シンボル」グラフの「作図の詳細」ダイアログで、
「グラフの線」
タブを選び、接続線を「2 点線分」にしたものです。また、B(Y)に対応する X の値を
1、C(Y)に対応する X の値を 2 にする必要があります。
197
ORIGIN6.0
ウォータフォール
「二重 Y 軸グラフ」で使用したデータを使います。このグラフを描くには、Y データは
1 つでも構いませんが、グラフの特性上 2 つ使用しています。
「作図」メニューの「特
殊ライン」から「ウォータフォール」を選びます。次のようなグラフができます。
ウォータフォール
このグラフには、2Dウォータフォールオプションボタンがグラフの上側についていま
す。これは、グラフテンプレートを使用して描いているグラフです。また、このグラ
フは「面積グラフ」の「作図の詳細」ダイアログで「グラフの線」タブを選び、
「曲線
以下の塗りつぶし」のチェックを外したものです。
オプションボタン
ズーム化グラフ
「二重 Y 軸グラフ」で使用したデータを使います。このグラフを描くには、Y データは
1 つでも構いません。
「作図」メニューの「特殊ライン」から「ズーム化グラフ」を選
びます。次のようなグラフができます。
ズーム化グラフ
上側のグラフの四角で囲まれた部分を拡大して、下側に表示しています。
このグラフは、
「折れ線グラフ」とリンクしたレイヤを使って描いています。
198
Chapter 3
Y エラー
次のようなデータセットを用意してください。2 つの Y 変数列を選択し、
「作図」メ
ニューの「特殊ライン」から「Y エラー」を選びます。次のようなグラフができます。
サンプルデータ
Y エラー
このグラフは、ワークシートの C 列の設定を Y エラーバーにして、
「散布図」を描いた
ものと同じです。
199
ORIGIN6.0
XY エラー
次のようなデータセットを用意してください。3 つの Y 変数列を選択し、
「作図」メニューの
「特殊ライン」から「XY エラー」を選びます。次のようなグラフができます。
サンプルデータ
XY エラー
このグラフは、ワークシートの C 列の設定を Y エラーバー、D 列の設定を X エラーバーにして、
「散布図」を描いたものと同じです。
200
Chapter 3
カラー/バブル シンボル
このグラフを描くには、Y 変数列は少なくとも 2 列必要です。
バブル/カラーマップ
次のようなデータセットを用意してください。2 つの Y 変数列を選択し、
「作図」メ
ニューの「カラー/バブル シンボル」から「バブル」を選びます。次のようなグラ
フができます。同様に「カラーマップ」も作成します。
サンプルデータ
バブル
カラーマップ
このグラフは、ワークシートの A(X)と B(Y)を使って散布図を描き、バブルでは C 列を
シンボルの大きさに、カラーマップでは C 列をカラーマップとして使用しています。
201
ORIGIN6.0
カラーバブル
バブル/カラーマップと同じデータを使用します。2 つの Y 変数列を選択し、
「作図」
メニューの「カラー/バブル シンボル」から「カラーバブル」を選びます。次のよ
うなグラフができます。
カラーバブル
このグラフは、ワークシートの A(X)と B(Y)を使って散布図を描き、シンボルの大きさ
とカラーマップに C(Y)列を使用しています。
また、このグラフでは XYYY形式のワークシートを使って描くこともできます。ワーク
シートに D(Y)列を追加して、このグラフを描くと、C(Y)列をシンボルの大きさ、D(Y)
列をカラーマップとして使用します。
202
Chapter 3
区分グラフ
区分グラフはすべて「折れ線」グラフをレイヤを使って、並べたグラフです。
垂直二区分と水平二区分には、Y 変数のデータセットが 2 つ必要です。
四区分、九区分にはそれぞれ Y 変数のデータセットが 4 つ、9 つ必要です。
積上げグラフはデータセットの数に応じて積上げるグラフの数が変わります。
垂直二区分
水平二区分
四区分
203
ORIGIN6.0
9 区分
積上げグラフ
204
Author
Document
Category
Uncategorized
Views
0
File Size
827 KB
Tags
1/--pages
Report inappropriate content