close

Enter

Log in using OpenID

ENVI Tutorials - Harris Geospatial Solutions

embedDownload
ENVI チュートリアル
モザイク処理
この章は以下の内容から構成されています。
概要 ........................................................................................................................ 2
使用するファイル .................................................................................................. 2
ENVI におけるモザイク処理 .................................................................................. 4
一般事項 ................................................................................................................ 4
ピクセルベースのモザイク処理の例 ........................................................................ 6
画像のインポートと位置決め ................................................................................ 7
マップベースのモザイク処理の例 ........................................................................... 11
マップベースのモザイク画像の作成 ...................................................................... 11
フェザリング処理されていないモザイク画像の表示 ............................................. 11
フェザリング処理されたモザイク画像の作成 ........................................................ 12
モザイク処理中のカラーバランス処理 .................................................................... 14
カラーバランス処理を行わないモザイク画像の作成 ............................................. 14
RGB モザイクプレビュー ...................................................................................... 14
カラーバランス処理を行わないモザイクの出力 .................................................... 15
カラーバランス処理を行ったモザイク処理の出力 ................................................. 15
ENVI セッションの終了 ........................................................................................ 16
概要
この章では ENVI の画像モザイク処理機能に関する概要を説明します。詳細は、
ENVI オンラインヘルプを参照してください。
使用するファイル
DVD: Resource DVD
Path: Data / a vmosai c
ファイル
概要
ピクセルベースのモザイク処理
dv06_2.img
AVIRIS Scene 02
dv06_2.hdr
上記用の ENVI ヘッダ
dv06_3.img
AVIRIS Scene 03
dv06_3.hdr
上記用の ENVI ヘッダ
dv06a.mos
AVIRIS モザイク用のモザイクテンプレート
dv06b.mos
フ ェ ザ リ ン グ 処 理 の AVIRIS モ ザ イ ク 用 モ ザ イ ク
テンプレート
dv06_fea.img
フェザリングされたモザイク画像
dv06_fea.hdr
上記用の ENVI ヘッダ
幾何補正されたモザイク処理
lch_01w.img
ワープ処理されたヒストグラムマッチング画像
lch_01w.hdr
上記用の ENVI ヘッダ
lch_01w.ann
上記用のカットラインフェザリングの注釈
lch_02w.img
ワープ処理されたヒストグラムマッチング画像
lch_02w.hdr
上記用の ENVI ヘッダ
lch_a.mos
lch_mos1.img
幾 何 補 正 さ れ た 画 像 モザ イ ク 処 理 用 の モ ザ イク テ ン
プレート
幾何補正されたモザイク処理の結果
2
lch_mos1.hdr
上記用の ENVI ヘッダ
モザイク処理中のカラーバランシング
mosaic1_equal.dat
ヒ ス ト グ ラ ム 平 坦 化 スト レ ッ チ が 各 バ ン ド に適 用 さ
れた Landsat 7 ETM 画像のサブセット
mosaic1_equal.hdr
上記用の ENVI ヘッダ
mosaic_2.dat
ス ト レ ッ チ が 適 用 さ れ て い な い 、 同 じ Landsat
7ETM 画像のもう 1 つのサブセット
mosaic_2.hdr
上記用の ENVI ヘッダ
3
ENVI におけるモザイク処理
モザイク処理は、複数の画像を結合して 1 つの合成画像にする技術です。ENVI
には、幾何補正されていない画像群を 1 つのモザイク内に配置したり、幾何補正
された画像群を幾何補正された 1 つの出力モザイク内に自動的に配置するための
対話的な機能があります。ENVI では、透明化処理、ヒストグラムマッチング処
理、自動カラーバランス処理が行えます。また、ENVI の仮想モザイク機能を使
用すると、大きな出力ファイルを作成せずに状況に応じてモザイクを作成して表
示することもできます。
一般事項
以下の項では、演習を行う前に ENVI でモザイク処理を行 うために必要ないくつ
かの準備について説明します。演習を実際に開始するのは、6ページの 「 ピクセル
ベースのモザイク処理の例」の項からです。
ENVI の起動
プログラムを起動する前に、インストールガイドの指示通り ENVI が正しくイン
ストールされていることを確認してください

UNIX もしくは Macintosh OS X で ENVI を起動するには、UNIX のコマ
ンドラインに envi と入力してください。

Windows システムで ENVI を起動するには、ENVI アイコンをダブルクリ
ックしてください。
プログラムが正常にロードされ実行されると、ENVI メインメニューが表示され
ます。
フェザリング処理
モザイク処理された画像群の接合部を、ブレンドするかぼかした方が良い場合が
よくあります。ENVI には、重なり合う部分のエッジに対して、ユーザが指定し
た距離だけエッジフェザリングまたはカットラインフェザリングという処理を行
う機能が用意されています。画像のモザイク処理時にフェザリングを使用するた
めには、はじめにフェザリングを行わずに最下層の画像をインポートします。さ
らに、重なり合う画像をインポートする際に必要に応じてエッジまたは、カット
ラインのいずれかでフェザリング処理を行います。
エッジフェザリング処理
エッジフェザリング処理では、Mosaic Entry Input Parame ters ダイアログの
Edge feathering distance (pixels) テキストボックスで指定された距離を使用
して、画像のエッジに沿って画像の接合部をブレンドします。エッジは、エッジ
フェザリング距離として指定した範囲で 2 つの画像がその距離内で平均的になる
ように線形勾配でブレンドされます。たとえば指定した距離が 20 ピクセルであ
る場合は、エッジ部では最上層画像を 0%、最下層画像を 100% 使用してブレン
ドし、出力画像が作成されます。指定された距離(20 ピクセル)だけエッジから
離れた位置では、最上層画像を 100%、最下層画像を 0% 使用して出力画像が作
4
成されます。エッジから 10 ピクセル離れた位置では、両画像を 50% 使用して出
力が作成されます。
図 1:エッジフェザリング処理
カットラインフェザリング処理
カットラインフェザリング処理では、 Cutline fea thering distance (pixels)
テキストボックスで指定されたカットライン距離と Mosaic Entry Input
Parameters ダイアロ グの Ann File で選択された注釈ファイルを使用して、画
像の境界部をブレンド処理します。カットラインは、モザイク処理の前に注釈ツ
ールを使用して定義しておく必要があります。注釈ファイルには、画像のエッジ
部からエッジ部まで引かれたカットラインを定義する Polyline (ポリライン)、
および画像内の切り取られる部分に付けられた記号が含まれていなければなりま
せん。指定したカットライン距離を使用して、カットラインからの距離に応じて
2 つの画像が平均的になるような線形勾配が作成されます。たとえば指定した距
離が 20 ピクセルである場合は、カットラインの位置では最上層画像を 100%、
最下層画像を 0% 使用してブレンドし、出力画像が作成されます。カットライン
から外側に指定された距離(20 ピクセル)だけ離れた位置では、最上層画像を
0%、最下層画像を 100% 使用して出力画像が作成されます。カットラインから
外側に 10 ピクセル離れた位置では、両画像を 50% 使用して出力が作成されます。
図 2:カットラインフェザリング処理
仮想モザイク
ENVI では、モザイクテンプレートファイルを使用して「仮想モザイク」を作成
することができます。仮想モザイクとは、実際の出力モザイクファイルを作成せ
ずに ENVI に表示して使用できるモザイクのことです。
5
<注>
フェザリングは、ENVI で仮想モザイクの作成中には実行することができま
せん。
1.
仮想モザイクを作成するには、モザイクを作成し、Image Mosaicking ダイアログ
の File -> Save Template を使用してテンプレートファイルとして保存してくださ
い。モザイクのレイアウトが説明されている小さなテキストファイルが作成され
ます。
2.
その仮想モザイクを使用するには、ENVI メインメニューから File -> Open
Image File を選択してモザイクテンプレートファイルを開いてください。そのモ
ザイクに使用されているすべての画像が開かれ、対応するバンドが Available
Bands List ダイアログにリストされます。仮想モザイクの任意のバンドを表示、
処理してみてください。実際のモザイク出力ファイルとまったく同様に個々の画
像が ENVI で処理されます。処理された新しいファイルのモザイクのサイズは指
定された値になり、入力ファイルは、モザイク内の指定された位置に配置されま
す。
ピクセルベースのモザイク処理の例
この項では、ENVI のモザイク処理ツールを使用してピクセルベースのモザイク
を作成する方法を説明します。
1.
ENVI メインメニューから Map -> Mosaicking -> Pixel Based を選択して ENVI
のピクセルベースのモザイク機能を起動してください。Pixel Mosaic ダイアログ
が表示されます。
図 3:Pixel Mosaic ダイアログ
6
画像のインポートと位置決め
ピクセルベースの画像は以下のように位置決めを行います。
1.
Pixel Mosaic ダイアログから Import -> Import Files を選択してください。
2.
Mosaic Input Files ダイアログで Open -> New File をクリックし、avmosaic デ
ィレクトリを表示し、dv06_2.img ファイルを選択してください。
3.
Mosaic Input Files ダイアログで、Open -> New File を再度クリックし、
dv06_3.img ファイルを選択してください。
4.
Mosaic Input Files ダイアログで、キーボードの Shift キーを押しながら
dv06_2.img と dv06_3.img ファイル名をクリックし選択してください。その後
OK をクリックしてください。
5.
Select Mosaic Size ダイアログで、X Size に 614、Y Size に 1024 を入力してモザ
イクサイズを指定してください。
6.
Pixel Mosaic ダイアログで dv06_3.img ファイル名をクリックしてください。画
像の現在の位置が、ダイアログの下にあるテキストボックスにピクセル単位でリ
スト表示されます。
7.
YO テキストボックスで値 513 を入力し、キーボードの Enter キーを押してくだ
さい。dv06_3.img は dv06_2.img の直ぐ下に表示されます。
<注>
ダイアログの右側にあるモザイクダイアグラムで任意の画像をマウスの左ボ
タンでクリックしてそのままドラッグすることで位置を移動し、マウスボタ
ンを放した場所に画像を配置することもできます。
8.
Pixel Mosaic ダイアログで File -> Apply を選択してください。表示される
Mosaic Parameters ダイアログに、出力ファイル名として dv06.img と入力して、
OK をクリックしモザイクを作成してください。

9.
新しいモザイクファイルの代わりに仮想モザイクを作成するには、
Pixel Mosaic ダイア ログで File -> Sa ve T emplate を選択してく
ださい。表示される Output Mosaic Templa te ダイアログに、出
力ファイル名として dv06a.mos と入力してください。
Available Band List でバンド名 dv06a.mos をクリックして、Load Band をクリ
ックするとモザイク画像が表示されます。
7
図 4:2 つの単一バンド AVIRIS 画像(左)
最終的に接合部がない状態に両者が統合された様子(右)
この例の次の手順では、XO、YO の値を入力するか、ダイアログ内で任意の位置
に画像をドラッグすることで、2 つの画像を合成モザイク画像内に配置します。
この例では、エッジのフェザリング処理も行います。
1.
Pixel Mosaic ダイアログで、Option -> Change Mosaic Size を選択してください。
Select Mosaic Size ダイアログで、X Size と Y Size テキストボックスのどちらへ
も値 768 を入力し、OK をクリックして出力モザイクのサイズを変更してくださ
い。
2.
Pixel Mosaic ダイアログで Display #2 の緑色のグラフィック枠内で左ボタンをク
リックしてください。Display #2 をダイアグラムの右下のコーナーにドラッグし
て配置してください。
3.
モザイクが表示されている Display #3 の赤色のグラフィック枠内でマウスの右ボ
タンをクリックし、Edit Entry を選択してください。Entry: filename ダイアログ
が表示されます。
8
図 5:Entry ダイアログでのモザイクパラメータの編集
4.
Data Value to Ignore テキストボックスで、値 0 を入力してください。
Feathering Distance テキストボックスに値 25 を入力し OK をクリックしてくだ
さい。
5.
他の画像にも手順 3 と 4 を繰り返し実行してください。
6.
File -> Save Template を選択し、出力ファイル名として dv06b.mos を入力して
ください。Available Band List でモザイクテンプレート名をクリックし、Load
Band をクリックすると画像が表示されます。仮想モザイクを使用している場合、
フェザリング処理は行われません。
7.
実際に出力ファイルを作成することで、同じ画像をフェザリング処理されたモザ
イクとして作成してください。Pixel Mosaic ダイアログで、 File -> Apply を選択
し OK をクリックしてください。
8.
出力ファイル名を入力し、Background Value として値 255 を入力して OK をク
リックしてください。Available Bands List にリスト表示されているモザイクを、
新しいウィンドウに表示してください。
<注>
イメージウィンドウに画像全体を表示することができない場合、ウィンドウ
のコーナーをクリックしドラッグすることで、ウィンドウのサイズを変更す
ることができます。
9.
リンクディスプレイ機能とダイナミックオーバーレイを使用して、仮想モザイク
とフェザリング処理されたモザイクを比較してください。
以下の図は、前述の 2 つの AVIRIS シーンを重ねて生成した、フェザリング処
理された出力モザイクです。
9
図 6:最終的なフェザリング処理されたモザイク
10
マップベースのモザイク処理の例
幾何補正されたモザイク画像を配置するには、フェザリング処理等を事前に行っ
ておく必要があります。以下の項では、ENVI のモザイク処理ツールをフェザリ
ング処理と一緒に使用して、幾何補正されたモザイク画像の作成を行う方法を説
明します。
マップベースのモザイク画像の作成
1.
ENVI のメインメニューから Map -> Mosaicking -> Georeferenced 選択し て、
ENVI Georeferenced Mosaic 機能を開始してください。
2.
File -> Restore Template を選択し、lch_a.mos ファイルを選択してください。こ
れによりファイルが開き、幾何補正、フェザリング処理されたモザイクのために
必要なモザイクパラメータが読み込まれます。
図 7:Map Based Mosaic ダイアログ
画像の入力による位置決め
幾何補正された画像を手動操作で入力してフェザリング処理オプションを設定し、
前述のように画像を個々にインポートすることもできます。画像は、地理的に正
しい位置に自動的に配置されます。幾何補正された画像の位置とサイズは、出力
モザイクのサイズを決定します。
フェザリング処理されていないモザイク画像の表示
1.
Available Band List で、ファイル lch_01w.img を選択し、バンド名と Load
11
Band ボタンをクリックしてグレースケールとして表示してください。
2.
イメージウィンドウで、マウスの右ボタンをクリックしてショートカットメニュ
ーを表示し、Toggle -> Display Scroll Bars を選択して、スクロールバーを表示し
てください。水平スクロールバーをクリックして、画像の表示を調整してくださ
い。
3.
イメージウィンドウメニューから Overlay -> Annotation を選択し、Annotation
ダイアログを開いてください。
4.
Annotation ダイアログで File -> Restore Annotation を選択し、ファイル
lch_01w.ann を選択してください。このモザイクに 2 つの画像を表示するために
使用される赤いカットラインを表示してください。
5.
Available Bands List で lch_02w.img を新しいウィンドウに読み込み、この画像
で使用されるカットラインの特性を調査してください。
6.
ENVI メインメニューから File -> Open Image File を選択し、入力ファイルとし
て lch_a.mos を選択してください。Available Bands List でこの画像を新しいウ
ィンドウに読み込み、モザイクを作成するために使用した 2 つの画像のフェザリ
ング処理されていないエッジを調査してください。
フェザリング処理されたモザイク画像の作成
1.
Map Based Mosaic ダイアログで File -> Apply を選択してください。Mosaic
Parameters ダイアログで出力ファイル名として lch_mos.img を入力し、OK をク
リックすると、フェザリング処理されたモザイクが作成されます。
2.
ワープ処理された個々の画像を含む 2 つのイメージウィンドウを閉じ、モザイク
画像を新しいウィンドウに読み込んでください。
3.
リンクディスプレイ機能とダイナミックオーバーレイを行うことで、フェザリン
グ処理されたモザイクとフェザリング処理されていないモザイクを比較してくだ
さい。
以下の図は、左側の画像は選択されたカットラインでワープ処理とヒストグラム
マッチングが行われた画像を表します。右側の画像は、カットラインフェザリン
グによるモザイク処理の結果を表します。
12
図 8:マップベースの画像モザイク処理の例
13
モザイク処理中のカラーバランス処理
以下の項では、自動カラーバランス処理機能を使用して、幾何補正されたモザイ
クを作成するプロシージャを説明します。この演習では、Landsat 7 ETM 画像
の重ねられた 2 つのサブセットを使用します。サブセットの 1 つは各バンドにヒ
ストグラム平坦化ストレッチが適用されているため、各バンドは他のサブセット
の同じバンドよりも非常にシャープなヒストグラムを持っています。
カラーバランス処理を行わないモザイク画像の作成
最初にカラーバランス処理を行わずにモザイクを作成します。フェザリングを行
わずに 2 つの画像をインポートします。これにより、2 つの画像の継ぎ目を確認
することができます。
1.
ENVI メインメニューから Map -> Mosaicking -> Georeferenced を選択し、
ENVI の Georeferenced Mosaic 機能を実行してください。Map Based Mosaic ダ
イアログが表示されます。
2.
Import -> Import Files を選択してください。
3.
ファイル選択ダイアログが表示されますので、Open -> New File ボタンを選択し
てください。avmosaic ディレクトリにある mosaic1_equal.dat ファイルに移動し、
Open をクリックしてください。
4.
Mosaic Input Files ダイアログで再度 Open -> New File ボタンを選択してくださ
い。そして、今回は avmosaic ディレクトリから mosaic_2.dat というファイルを
選択し、Open をクリックしてください。
5.
Mosaic Input Files ダイアログで mosaic_2.dat ファイルを選択し、その後 Shift
キーを押しながら mosaic1_equal.dat ファイルを選択して、OK ボ タンをクリッ
クしてください。
2 つの画像は、自動的に Mosaic Previe w ウ ィンドウ内の地理的に正しい位置に
それぞれ配置されます。このプレビューウィンドウに表示される画像は、それぞ
れにデフォルトで 2% のコントラストストレッチングが適用されます。
RGB モザイクプレビュー
プレビューウィンドウに、これらのマルチスペクトル画像の RGB カラー合成を
表示します。
1.
Map Based Mosaic ウィンドウの下部に表示されている mosaic1_equal.dat ファ
イルというファイル名をマウスの右ボタンでクリックし、Edit Entry を選択して
ください。
2.
表示されるダイアログから Mosaic Display 用に RGB を選択してください。
14
3.
Red は 1 を、Green は 2 を、Blue は 3 を選択します。これにより、ENVI はプ
レビューウィンドウにモザイクを表示する際に、赤色カラーブラシに Band 1 を、
緑色カラーブラシに Band 2 を、青色カラーブラシに Band 3 を読み込みます。
OK をクリックしてください。モザイクプレビューに色を使用して表示されている
mosaic1_equal.dat 画像を確認することができます。
4.
他のファイルに手順 1 から 3 を繰り返し実行し、モザイク処理を行ってください。
3 つのバンド画像の場合、デフォルトでは ENVI は最初のバンドに赤色、 2 つ目
のバンドに緑色、3 つ目のバンドに青色を使用して自動的にモザイクプレ ビュー
に RGB 表示を行います。しかし、画像が 3 バンド以上持っている場合、モザイ
クプレビューは Band 1 をグレースケールのみで表示します。モザイク入力画像
が 1 つのバンドのみを持つ場合は、プレビューウィンドウにはそのバンドがグレ
ースケールで表示されます。
カラーバランス処理を行わないモザイクの出力
モザイクプレビューウィンドウの表示は、最終的なモザイク処理の結果と必ずし
も一致しない場合があります。モザイクプレビューウィンドウでは 2 つの画像は
それぞれストレッチされますが、1 つの画像として一緒にモザイク処理が行われ
表示される場合は、ウィンドウへのコントラストストレッチングは結合された 2
つの画像からのデータ上で計算されます。
1.
Map Based Mosaic ウィンドウから、File -> Apply を選択してください。
2.
Mosaic Parameters ダイアログで、Output Filename として
mosaic_unbalanced.dat と入力し OK を選択してください。処理が終了すると、
モザイクが Available Bands List にリスト表示されます。
3.
新しいモザイクが、Band 1 に赤色、Band 2 に緑色、Band 3 に青色を使用して
RGB で表示されます。
<注>
2 つの画像の継ぎ目は、多くの場所ではっきりと表示されます。
カラーバランス処理を行ったモザイク処理の出力
Map Based Mosaic ダイアログに戻り、モザイク処理を再度適用します。今回
はカラーバランス処理を実行して、最終的なモザイク画像で 2 つの画像間のコン
トラストを最小にします。
1.
Map Based Mosaic ダイアログに表示されている mosaic1_equal.dat ファイルの
名前をマウスの右ボタンでクリックし、Edit Entry を選択してください。
2.
表示されるダイアログの下部の Color Balancing の下にある Adjust を選択してく
ださい。これにより、他の画像に一致するようこの画像のコントラストが調整さ
れます。OK を選択してください。
15
3.
mosaic_2.dat ファイルの名前をマウスの右ボタンでクリックし、Edit Entry を選
択してください。
4.
表示されるダイアログの Color Balancing の下にある Fixed を選択してください。
これにより、この画像のコントラストは変更されません。他の画像がこの画像に
一致するよう調整されます。OK を選択してください。
5.
Map Based Mosaic ウィンドウから File -> Apply を選択してください。
6.
表示される Mosaic Parameters ダイアログの下部に、Color Balance using オプ
ションがあります。この項目を stats from overlapping regions に設定してくださ
い。通常カラーバランス処理は、重なっている範囲のみから計算された統計解析
を基として実行された場合により良い結果が得られます。他のオプションは stats
from complete files です。これは、モザイク処理が行われた画像の重なる範囲が
少ない場合もしくは重なる部分がない場合に使用されます。
7.
Output Filename として mosaic_balanced.dat と入力して、OK を選択してくだ
さい。処理が終了すると、モザイク処理された画像が Available Bands List に表
示されます。
8.
新しいモザイク画像が、Band 1 は赤色で、Band 2 は緑色で、Band 3 は青色で
RGB 表示されます。
<注>
かすかに 2 つの画像の継ぎ目が確認できます。
ENVI セッションの終了
ENVI セッションを終了するには、 ENVI メインメニューから File -> Exi t
(UNIX は Quit)を選択し、さらに OK を クリックして IDL を終 了します。
ENVI RT をご使用の場合は、 ENVI を終了するとオペレーティングシステムに
戻ります。
16
Author
Document
Category
Uncategorized
Views
2
File Size
694 KB
Tags
1/--pages
Report inappropriate content