close

Enter

Log in using OpenID

2014/04/17 担当 堀江 コンピュータ演習2回目 コンピュータ演習 → 技術

embedDownload
2014/04/17 担当 堀江
コンピュータ演習2回目
概要
1~
5回堀江担当(Excel のツール)
6~10回今駒先生担当(VBA
プログラム基礎)
11~15回大村先生担当(VBA
プログラム応用)
コンピュータ演習 → 技術計算のための Excel
◆表計算ソフト
数値データの集計・分析に用いられる作表アプリケーションソフト。縦横に並んだマス
目(セル)に数値や計算ルールを入力していくと、表計算ソフトが自動的に数式を分析し、所
定の位置に計算結果を代入してくれる。
◆化学工学→モデル解析
プロセスおよびの本質を見極めモデル化すること
プロセスのモデル化→現象を数式(微分方程式など)化すること
→数式により現象を表現できれば、実際に起こる現象を予想することができる
計算機性能の向上により、非線形連立方程式や微分方程式を誰でも解くことができるよう
になった。その手法として・・・
Excel のワークシート(初級編)
Excel 上のプログラミング VBA(中級~上級編)
<モデル式>
<Excel 上のツール>
連立1次方程式
ワークシート関数
非線形方程式(1変数)
ゴールシーク
連立非線形方程式(多変数) ソルバー
最小2乗法などの最適化
ソルバー
(連立)常微分方程式
VBA
ゴールシーク:未知数を変化させて繰り返し計算を行い、条件に合う未知数を探索する。
ソルバー:多変数の連立非線形方程式の解法に用いられる。また、最小2乗法などの最適
化にも用いられる。
マクロ(VBA)
:エクセルが BASIC 言語で記述されるようになり、エクセル上でプログラ
ミングを直接行える。汎用性があるが、使いこなすにはコンピュータ言語に関す
る学習が必要。
準備(コンピュータ演習を行う前に)
◆Excel 2010 は以下の手順を行う。
1.
ファイルタブを左クリックしてオプションを左クリック
2.
アドインを左クリック
3.
アクティブなアプリケーションアドインの項目に「ソルバーアドイン」、「分析ツール」
、
「分析ツール VBA」があるかを確認
4.
なければ、アドイン「設定」を左クリック
5.
「ソルバーアドイン」
、「分析ツール」、「分析ツール VBA」にチェックをして OK
6.
インストールしますか?ときいてくるので「はい」
開発タブの表示
1.
ファイルタブを左クリックしてオプションを左クリック
2.
リボンのユーザー設定を左クリック
3.
右メインタブの開発にチェックを入れる
4.
OK をクリック
◆Excel 2007 は以下の手順を行う。
1.
Office ボタンを左クリックして Excel オプションを左クリック
2.
左のメニューバーのアドインを左クリック
3.
アクティブなアプリケーションアドインの項目に「ソルバーアドイン」、「分析ツール」
、
「分析ツール VBA」があるかを確認
4.
なければ、管理 Excel アドイン設定を左クリック
5.
「ソルバーアドイン」
、「分析ツール」、「分析ツール VBA」にチェックをして OK
6.
インストールしますか?ときいてくるので「はい」
開発タブの表示
1.
Office ボタンを左クリックして Excel オプションを左クリック
2.
基本設定
3.
[開発]タブをリボンに表示するにチェックを入れる
4.
OK
************
「ソルバーアドイン」→ソルバーを使うとき
「分析ツール」→ヒストグラムなどをつくるとき
「分析ツール VBA」→Visual Basic プログラムを使うとき
1.エクセル(表計算ソフト)
◆エクセル必須機能
表計算:関数の種類(sum, exp, ln, log, average, sin, asin, sinh, min, max, pi, rand, stdev,
var, mod, row, column など 300~400 種)
・・・
(合計、エクスポネンシャル、自然対数、対
数、平均、サイン、アークサイン、ハイパボリックサイン、最小値、最大値、π、ランダ
ム、標準偏差、分散、余り、行、列)
使い方:セルの中に =sum(この部分はマウスで範囲指定)
pi(), rand()などは括弧だけでよい
その他の機能
1)
+マークダブルクリック
6)
Ctrl+V
2)
$マーク(絶対参照)
7)
ウィンドウ枠の固定
3)
Ctrl+Shift+矢印
8)
並べ替え機能
4)
Shift+矢印
9)
条件付き書式
5)
Ctrl+C(または Ctrl+X)
データの読み込み
テキスト形式データ、CSV(実験装置からのデータ出力で多く用いられる)
正規分布図
◆標準偏差(standard deviation)
標準偏差、データが有限個の場合は

(x
i
 )2
68.27%
N 1
xi は個々の測定値、は平均値である。
分散値は標準偏差の二乗で表される。
95.45%
99.73%
ちなみに偏差値は T  50  10
xi  

で表される。
-3σ
-2σ
-σ
μ
σ
2σ
3σ
演習1:ゴールシークを使ってみる
ゴールシーク(1 変数の非線形方程式を解く)
() = ( + 1)3 −   + 3 ln( + 1) − 10 = 0
−1< <6
を満たす x を求めよ。という問題を解く場合、これを“x =”の形にすることは難しい。
この解を瞬時に求めてくれるのがゴールシーク。
練習:初期値を変化させて上の問題を解け
【ふろく】

テキストファイルの開き方
エクセル開く⇒開く⇒すべてのファイル⇒課題テキストファイルを開く
テキストファイルウィザード⇒次へ⇒カンマにチェック⇒完了

ヒストグラムの作り方
データ分析というタブをクリック⇒ヒストグラムを選択⇒OK
出力先⇒今回は$D$1 を選択
グラフ作成にチェック
入力範囲およびデータ区間を選択⇒OK
(おまけ)

エラーバーの付け方(基礎)
グラフツール⇒レイアウト⇒誤差範囲▼
課題 2-1
kadai2-1 は成績の分布をテキスト形式で保存したファイルである。
3-4 ページのヒントを利用して、別紙の通り、Excel の表を作成せよ。ウィンドウ枠の固
定も行うこと。
課題 2-2(宿題)
kadai2-2 は、身長の分布表をテキスト形式で保存したファイルである。
課題 2-1 と同様に表を作成せよ。
Author
Document
Category
Uncategorized
Views
1
File Size
434 KB
Tags
1/--pages
Report inappropriate content