close

Enter

Log in using OpenID

60 1 グラフの作成

embedDownload
第5章
グラフの作成
この章では、表のデータを基にグラフを作成する方法やグラフの移動やサイズの変更方法、グラ
フの書式の変更方法などを学習します。
グラフは、作成したデータを視覚的にわかりやすく表現し、データ全体の傾向を把握するのに役
立ちます。
1 グラフの
グラフの作成
元となるセル範囲を選択し、[挿入]タブの[グラフ]グループから作成したいグラフの種類を選択するだけで、簡単にグラフを
作成することができます。作成したグラフは、元データとリンクしており、データが変更されると自動的に更新されます。
≪グラフの
グラフの元データ≫
データ≫
グラフの元データを選択するときは、数値データと共にグラフの項目名となるセルを含めて範囲選択します。離れたセルを使
用してグラフを作成することもできます。
≪[グラフツール
グラフツール]タブ
グラフツール タブ≫
タブ≫
グラフを作成すると[グラフツール]タブが追加され、ここから作成したグラフを編集することができます。[グラフツール]タ
ブには、[デザイン]、[レイアウト]、[書式]の 3 つのタブがあり、グラフを選択しているときだけ表示されます。
≪[グラフツール
グラフツール]の
デザイン]タブ
グラフツール の[デザイン
デザイン タブ≫
タブ≫
[デザイン]タブを使用すると、グラフの種類や元データ、スタイルなどを変更することができます。
【グラフの
グラフの種類の
種類の変更】
変更】
[グラフの種類の変更]ダイアログボックスを表示し、グラフの種類を変更します。
【 行/ 列の切 り替え】
X 軸と Y 軸のデータを入れ替えます。
【データの
データの選択】
選択】
[データソースの選択]ダイアログボックスを表示し、グラフデータの範囲を変更します。
【グラフの
グラフのレイアウト】
レイアウト】
定義済みのグラフのレイアウトを選択し、タイトル、凡例、ラベルなどのグラフ要素が特定の位置に配置されたグラフにす
ばやく変更することができます。不要な要素は Delete キーで簡単に削除することができます。
【グラフの
グラフのスタイル】
スタイル】
定義済みのグラフのスタイルを選択し、グラフの色やフォントなどをすばやく変更することができます。
※
定義済みのグラフのスタイルには、グラフ内のフォントの書式(フォント・サイズ・スタイル・色など)も含まれるた
め、フォントの書式を変更する場合は、グラフのスタイルを設定した後に行います。
60
第5章
グラフの作成
【グラフの
グラフの移動】
移動】
[グラフの移動]ダイアログボックスを表示し、グラフを別のシートに移動することができます。グラフだけを表示するグラ
フシートに移動することもできます。(STEP6 One Point グラフシート参照)
2 グラフの
グラフの構成要素
グラフは様々な要素から構成されています。グラフの構成要素には、
『グラフエリア』、
『プロットエリア』
、
『グラフタイトル』
、
『項目軸』
、
『項目軸ラベル』、
『数値軸』
、
『数値軸ラベル』、
『数値軸目盛線』
、
『データラベル』
、
『凡例』などがあり、必要に応
じて追加したり、それぞれの要素を選択し、個別に編集することができます。
グラフエリア
グラフタイトル
プロットエリア
縦(値)軸目盛線
データラベル
縦(値)軸ラベル
凡例
横(項目)軸
縦(値)軸
横(項目)軸ラベル
≪グラフ要素
グラフ要素の
要素の選択≫
選択≫
A)
各要素にマウスポインタを合わせ、要素の名前がポップヒントで表示されたらクリックします。
B)
[グラフツール]の[書式]または[レイアウト]タブにある[現在の選択範囲]の[グラフの要素]
ボックスの下向き三角ボタンをクリックし、一覧から編集したい要素をクリックします。
3 グラフの
グラフの位置と
位置とサイズ変更
サイズ変更
≪グラフ全体
グラフ全体の
選択≫
全体の選択≫
グラフエリア(グラフの余白部分)を選択すると、グラフの外枠にサイズ変更ハンドルが表示され、グラフ全体を選択している
状態になります。
≪グラフの
グラフの移動≫
移動≫
グラフを移動するには、グラフエリアをポイントしてドラッグします。グラフの移動中は、マウスポインタの形状が
に
変わります。
※
グラフエリア内の各要素(グラフタイトル、プロットエリア、凡例、ラベルなど)も、ドラッグして移動することが
できます。
61
第5章
グラフの作成
≪グラフの
グラフのサイズ変更
サイズ変更≫
変更≫
グラフのサイズを変更するには、サイズ変更ハンドルをポイントし、マウス
ポインタの形状が
※
に変わったらドラッグします。
縦横比を変えずにサイズ変更するには、 Shift キーを押しながら四隅
のサイズ変更ハンドルでドラッグします。
※
セルの境界線に合わせてサイズ変更するには、 Alt キーを押しながら
ドラッグします。
<こんな方法も!!>
サイズ変更ハンドル
プロットエリアのサイズ変更
プロットエリアのサイズを変更するとグラフ全体のサイズを変更することなく、
グラフ部分のみのサイズ変更ができます。
プロットエリアもグラフエリアと同様に、選択して表示されるハンドルをドラッグ
してサイズを変更したり、移動したりすることができます。
グラフのコピー
グラフの種類や書式設定、サイズなどが同じグラフを複数作成する場合は、まず 1 つ目のグラフを完成させ、完成した
グラフをコピーして元データを変更すると、何度も同じ設定を繰り返さずに効率よく作成することができます。
グラフのコピーは、データのコピーと同様に[ホーム]タブの[コピー]ボタンと[貼り付け]ボタンを使用したり、グラフエ
リアを選択した状態で、 Ctrl キーを押しながらドラッグします。
5章―1
操作してみよう
操作してみよう!
してみよう!
ここでは、表からグラフを作成し、[グラフツール]の[デザイン]タブを使用して、手軽に見栄えのするグラフを作成する方法と
グラフの移動やサイズ変更などについて練習します。
STEP 1
Excel を起動し、ドキュメントフォルダから“5 章(1)グラフ作成.xlsx”ブックを開きましょう。
STEP 2
[挿入]タブを使用して、セル A3 から C6 を基に“4 月”から“5 月”の支店別の積み上げ横棒
グラフを作成しましょう。
STEP 3
STEP2 で作成したグラフの種類を集合縦棒グラフに変更し、横軸に月、縦軸に各支店の売上高が表示されるように項目を入れ替え
ましょう。
62
第5章
グラフの作成
STEP 4
カラーリファレンスを使用して、グラフに 4 月から 6 月のデータが含まれるように変更しましょう。
①
グラフのプロットエリアを選択します。
※
②
グラフの元データの範囲が青、緑、紫の枠線で囲まれて表示されます。
セル B4 から C6 を囲む青の枠線の右下のハンドル(■)をセル D6 までドラッグします。
※
グラフの元データの範囲が広がり、6 月のグラフが追加されます。
STEP 5
グラフに 4 月から 9 月のデータが含まれるように、グラフの元データをセル A3 から D6
とセル F3 から H6 に変更しましょう。
※
追加したいデータの範囲が元データと連続していない場合は、
カラーリファレンスは使用できません。
STEP 6
グラフのレイアウトを[レイアウト 9]に設定しましょう。
※
グラフタイトル、横軸と縦軸のラベルが追加されます。
STEP 7
右図を参考に、次の編集をしましょう。
グラフタイトル:「上半期支店別売上高」と入力
縦(値)軸ラベル:「単位:千円」と入力
横(項目)軸ラベル:削除
STEP 8
グラフのスタイルを[スタイル 26](左から 2 番目の上から 4 番目)に設定しましょう。
STEP 9
完成例を参考に、グラフのサイズと位置を Alt キーを使用してセル A9 から F25 の範囲に合わせて調整しましょう。
STEP10
“上期合計”の支店別の売上構成比を表す円グラフを作成しましょう。
グラフの元データ:セル A3 から A6 と J3 から J6
グラフの種類:3-D 円グラフ
グラフタイトル:「支店別売上構成比」
STEP11
グラフのスタイルを[スタイル 26](左から 2 番目の上から 4 番目)に設定しましょう。
STEP12
完成例を参考に、グラフのサイズと位置をセル G9 から J25 の範囲に合わせて調整しましょう。
※
縦棒グラフと円グラフの間は、少し間を空けます。
STEP13
“5 章(2)グラフ編集.xlsx”というファイル名を付けて、ドキュメントフォルダ内の“保存用”フォルダに保存しましょう。
STEP14
63
第5章
グラフの作成
Excel を終了しましょう。
参照) ドキュメントフォルダ内の“5 章(2)グラフ編集.xlsx”ブック
完成例
4 グラフ要素
グラフ要素の
要素の追加
≪[グラフツール
グラフツール]の
レイアウト]タブ
グラフツール の[レイアウト
レイアウト タブ≫
タブ≫
[グラフツール]の[レイアウト]タブを使用すると、既存のグラフに必要なグラフ要素(タイトルや軸、凡例、ラベルなど)を追加
したり、レイアウトや書式を変更することができます。
【ラベルグループ】
ラベルグループ】
各ボタンから『グラフタイトル』
、
『軸ラベル』
、
『凡例』
、
『データラベル』
、
『データテーブル』の表示の有無や配置する位置
などを設定します。選択しているグラフの種類により使用できるボタンが異なります。例えば円グラフでは[軸ラベル]ボタ
ンは使用できません。
【軸グループ
グループ】
各ボタンから『軸』、
『目盛線』の表示の有無や表示の方法などを設定します。選択しているグラフの種類により使用できな
くなります。
【背景グループ
背景グループ】
グループ】
各ボタンから『プロットエリア』
、
『グラフの壁面』
、
『グラフの床面』の塗りつぶし有無などを設定します。
選択しているグラフの種類により使用できるボタンが異なります。また、3-D グラフでは、[3-D の回転]ボタンをクリックし、
表示される[グラフエリアの書式設定]ダイアログボックスで回転角度などを細かく設定することができます。
<こんな方法も!!>
要素の削除
グラフ内の各要素は、次の方法でも簡単に削除することができます。
64
A)
削除したい要素を選択し、 Delete キーを押します。グラフエリアを選択した状態ではグラフ全体が削除されます。
B)
削除したい要素で右クリックし、ショートカットメニューから削除を選択します。
第5章
グラフの作成
5 グラフの
グラフの書式設定
各グラフ要素の文字は、[ホーム]タブの[フォント]と[配置]グループやミニツールバーを使用して、見やすく編集することがで
きます。また、各グラフ要素の[書式設定]ダイアログボックスを表示して各オプションや塗りつぶし、枠線、影などを細かく
設定することができます。
≪[書式設定
書式設定]ダイアログボックス
書式設定 ダイアログボックスの
ダイアログボックスの表示≫
表示≫
[レイアウト]タブ、または[書式]タブの[現在の選択範囲]グループの[グラフの要素]ボックスから
目的のグラフ要素を選択し、[選択対象の書式設定]ボタンをクリックします。
<こんな方法も!!>
A)
[レイアウト]タブの各ボタンの一覧の最後にある[その他の○○オプション]をクリックします。
B)
グラフ要素を右クリックし、ショートカットメニューの[○○の書式設定]をクリックします。
≪[グラフツール
グラフツール]の
書式]タブ
グラフツール の[書式
書式 タブ≫
タブ≫
[グラフツール]の[書式]タブを使用すると、各グラフ要素(グラフエリア、プロットエリア、タイトル、凡例など)の塗りつぶし
や枠線、文字などを見栄えよく設定することができます。
【図形の
図形のスタイルグループ
スタイルグループ】
グループ】
定義済みの図のスタイルを選択し、グラフ要素に枠線や塗りつぶし、フォントの色などをすばやく設定することができます。
また、[図形の塗りつぶし]、[図形の枠線]、[図形の効果]ボタンから個別の詳細な設定を行うことができます。
※
定義済みの図のスタイルには、図の中のフォントの書式(フォント・サイズ・スタイル・色など)も含まれるため、
グラフ内のフォントの書式を変更する場合は、図のスタイルを設定した後に設定します。
6 グラフの
グラフの印刷
ワークシート上に作成したグラフは、通常のワークシートの印刷と同様の操作で元となった表のデータと共に印刷することが
できます。また、ワークシート上のグラフをあらかじめ選択しておくと、グラフのみを印刷プレビューで確認したり、印刷す
ることができます。
※
グラフシートに作成したグラフも通常のワークシートと同様の操作で印刷することができます。
≪グラフに
グラフに対するヘッダー
するヘッダーと
ヘッダーとフッターの
フッターの設定≫
設定≫
グラフシートやワークシート上のグラフのみを印刷する際にヘッダーとフッターを設定する場合は、グラフシートやワーク
シート上のグラフを選択し、[ページ設定]ダイアログボックスの[ヘッダーとフッター]タブを使用して設定します。
[ページ設定]ダイアログボックスは、[ページレイアウト]タブの[ページ設定]グループの右下に表示されている小さな矢印の
ボタン
※
(ダイアログボックス起動ツール)をクリックして表示します。
ページレイアウトビューのヘッダーとフッターの各ボックスは、ワークシートのヘッダーやフッターを設定するため
のもので、ワークシート上のグラフのみを印刷する場合には使用できません。またグラフシートでは、ページレイア
65
第5章
グラフの作成
ウトビューは使用できません。
グラフシート
『グラフシート』とは、グラフのみが表示されるシートのことです。グラフシートにグラフを作成するには、一度ワー
クシート上にグラフを作成し、[グラフツール]の[デザイン]タブの[グラフの移動]ボタンをクリックして、表示される[グ
ラフの移動]ダイアログボックスで[グラフの配置先]から[新しいシート]を選択して移動します。
シート名を入力すると指定したシート名
で新しいグラフシートが作成されます。
[オブジェクト]でシート名を選択すると
埋め込みグラフのまま別のシートに移動
することもできます。
5章―2
操作してみよう
操作してみよう!
してみよう!
ここでは、作成したグラフに必要なグラフ要素を追加し、書式の設定方法やグラフの印刷方法などを練習しましょう。
STEP 1
Excel を起動し、ドキュメントフォルダから“5 章(2)グラフ編集.xlsx”ブックを開きましょう。
(5 章-1:操作してみよう!を練習した場合は、ドキュメントフォルダ内の“保存用”フォルダから開きます)
STEP 2
“上半期支店別売上高”グラフ(縦棒グラフ)を選択し、[グラフツール]の[レイアウト]タブを表示しましょう。
STEP 3
凡例の位置をグラフの下に配置しましょう。
STEP 4
右図を参考に、縦軸ラベル“単位:千円”を編集し、プロットエリアの横幅を
広げましょう。
①
[軸ラベル]ボタンをクリックし、[主縦軸ラベル]から[軸ラベルを水平に配置]
を選択します。
※
プロットエリアのサイズが変更されます。
②
軸ラベルをドラッグして、上に移動します。
③
プロットエリアを選択し、左中央のサイズ変更ハンドルをドラッグします。
66
第5章
グラフの作成
STEP 5
縦軸の目盛間隔を“25000”に変更しましょう。
①
[軸の書式設定]ダイアログボックスの[軸のオプション]を表示します。
②
[目盛間隔]で[固定]をクリックし、
「25000」と入力します。
STEP 6
“支店別売上構成比”グラフ(円グラフ)に分類名とパーセンテージのデータラベルを表示し、表示形式を設定しましょう。
①
“支店別売上構成比”グラフを選択し、[データラベルの書式設定]ダイアログボックスを表示します。
②
[ラベルオプション]で[ラベルの内容]の[分類名]チェックボックスと[パーセンテージ]チェックボックスをオンにします。
③
[ラベルの位置]を[中央]に設定します。
④
[表示形式]で[パーセンテージ]の[小数点以下の桁数]を「1」に設定します。
⑤
凡例を削除します。
STEP 7
[グラフツール]の[書式]タブを使用して、
“上半期支店別売上高”グラフ(縦棒グラフ)に図形のスタイルを設定しましょう。
グラフエリアと凡例:枠線のみ-アクセント 1(左から 2 番目の上から 1 番目)
グラフタイトルとプロットエリア:パステル-アクセント 1(左から 2 番目の上から 4 番目)
STEP 8
[グラフツール]の[書式]タブを使用して、
“支店別売上構成比”グラフ(円グラフ)に図形のスタイルを設定しましょう。
グラフエリア:枠線のみ-アクセント 1 (左から 2 番目の上から 1 番目)
グラフタイトル:パステル-アクセント 1 (左から 2 番目の上から 4 番目)
STEP 9
[ホーム]タブを使用して、
“上半期支店別売上高”グラフ(縦棒グラフ)のフォント
サイズを変更しましょう。
※
[ホーム]タブではリアルタイムプレビューが利用できます。
グラフタイトル“上半期支店別売上高”
:14pt
縦(値)ラベル“単位:千円”
:8pt
STEP10
ミニツールバーを使用して、
“支店別売上構成比”グラフ(円グラフ)のフォントの編集をしましょう。
グラフタイトル“支店別売上構成比”
:14pt
データラベル:12pt、太字
67
第5章
グラフの作成
STEP11
画面表示をページレイアウトビューに切り替えて、円グラフが J 列の内側に収まるようにサイズや位置を調整しましょう。
※
グラフの輪郭が J 列を超えると K 列までが印刷対象となります。
STEP12
セル A1 のタイトルを「上半期売上報告」に変更し、次の書式を設定しましょう。
フォント:HGP 創英角ゴシック UB
サイズとスタイル:28pt、斜体
フォントの色:任意の色
配置:セル A1 から J1 の幅で結合して中央揃え
STEP13
表とグラフが左右の余白内で中央に印刷されるように設定し、印刷プレビューで確認しましょう。確認後、印刷プレビューを閉じ
ましょう。
STEP14
ヘッダーに“NPS 商社”
“上半期支店別売上高”グラフ(縦棒グラフ)だけを印刷する準備を行いましょう。
①
“上半期支店別売上高”グラフ(縦棒グラフ)を選択します。
②
印刷プレビューを確認します。
③
[ページ設定]ダイアログボックスを表示し、次の設定をします。
印刷の向き:横
ヘッダーの右側:「NPS 商社」と入力
※
④
と印刷されます。
印刷の向きの変更は、[ページレイアウト]タブでも設定できます。
[印刷]ボタンをクリックし、[印刷]ダイアログボックスの[印刷対象]が
[選択したグラフ]になっていることを確認します。
⑤
キャンセル ボタンをクリックし、[印刷]ダイアログボックスを閉じます。
STEP15
“5 章上期グラフ.xlsx”というファイル名を付けて、ドキュメントフォルダ内の“保存用”フォルダに保存しましょう。
STEP16
Excel を終了しましょう。
参照) 完成フォルダ内の“5 章上期グラフ_完成.xlsx”ブック
完成例
68
<印刷プレビュー>
第5章
グラフの作成
第 5 章のトレーニング
ここでは、グラフの作成方法と書式の設定、印刷について練習しましょう。
STEP 1
Excel を起動し、ドキュメントフォルダから“5 章トレーニング.xlsx”ブックを開きましょう。
STEP 2
支店ごとの 4 月から 9 月の売上推移を表す折れ線グラフを作成しましょう。
グラフ元のデータ範囲:セル B3 から B7 とセル D3 から I7
グラフの種類:折れ線グラフ
グラフのスタイル:スタイル 10 (左から 2 番目の上から 2 番目)
グラフのレイアウト:レイアウト 1 (グラフタイトルと軸ラベルが追加されます)
グラフタイトル:「上半期売上推移」
グラフのサイズと位置:STEP7 の図を参考にセル A11 から F33 に合わせて調整
STEP 3
STEP7 の図を参考に、凡例を編集しましょう。
①
[レイアウト]タブを使用して、凡例の位置を右に重ねて配置します。
②
グラフエリアの下方(横軸の上)へ移動します。
③
サイズ変更ハンドルをドラッグし、高さを縮めます。
STEP 4
縦(値)軸を編集しましょう。
①
[レイアウト]タブの[軸]ボタンを使用して、数値を千単位で表示します。
②
[軸の書式設定]ダイアログボックスで目盛間隔を 20000 に設定します。
STEP 5
縦(値)軸表示単位ラベル“千”を次のように編集しましょう。
①
縦(値)軸表示単位ラベルの“千”を「単位:千円」に変更します。
②
不要になった[軸ラベル]を削除します。
③
[表示単位ラベルの書式設定]ダイアログボックスを表示し、
[配置]の文字列の方向を[横書き]に設定します。
④
⑤
⑥
フォントサイズを 9pt に設定します。
縦(値)軸表示単位ラベルを上に移動します。
プロットエリアの幅を左方向に広げます。
STEP 6
[レイアウト]タブを使用して、
“東京”支店の折れ線グラフにだけデータラベルを
表示しましょう。
①
[グラフの要素]ボックスから[系列“東京”]を選択します。
②
[データラベル]ボタンを使用して、データラベルをデータ要素の上に表示します。
STEP 7
凡例に[図形スタイル]の[パステル‐アクセント 6](右から 1 番目の上から 4 番目)を
設定しましょう。
69
第5章
グラフの作成
STEP 8
月ごとに支店別の売上の割合を表す横棒積み上げグラフを作成しましょう。
グラフ元のデータ範囲:セル B3 から B7 とセル D3 から I7
グラフの種類:3-D 100%積み上げ横棒グラフ
グラフのスタイル:スタイル 10 (左から 2 番目の上から 2 番目)
グラフのサイズと位置:セル F11 から K33
STEP 9
[レイアウト]タブを使用して、次のグラフ要素の追加と削除をしましょう。
グラフタイトル:「支店別月別売上構成比」
データテーブル:凡例マーカー付きで表示
凡例:削除
STEP10
画面表示をページレイアウトビューに切り替え、拡大縮小印刷を使用して、
ページの横幅を 1 ページに収めましょう。
STEP11
右図を参考に、グラフと凡例のサイズと位置を調整しましょう。
STEP12
印刷プレビューで確認しましょう。
確認後、印刷プレビューを閉じましょう。
STEP13
“5 章売上報告グラフ xlsx”というファイル名を付けて、ドキュメントフォルダ内の“保存用”フォルダに保存しましょう。
STEP14
Excel を終了しましょう。
参照) 完成フォルダ内の“5 章売上報告グラフ_完成.xlsx”ブック
完成例
70
<印刷プレビュー>
Author
Document
Category
Uncategorized
Views
1
File Size
698 KB
Tags
1/--pages
Report inappropriate content